LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2004, 05:36 AM   #1
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Rep: Reputation: 30
X cannot start if GLX option is enabled in XFree86-4


I just made a new kernel 2.6.8 and installed the newest nvidia driver, everything seems to have been going great, except that:

X cannot start if GLX option is enabled in XFree86-4

If I reinstall the nvidia driver, I can enable GLX, but after a reboot it is not working again.

any ideas ?
 
Old 10-05-2004, 07:41 AM   #2
nazir
Member
 
Registered: Apr 2002
Location: Poland, Gliwice/Pszczyna
Distribution: Mandrake, Slackware
Posts: 41

Rep: Reputation: 15
As far as I remember NVIDIA drivers come in two parts, a X driver, and a kernel module. It doesn't work after reeboot because you don't load the module i think. After reeboot write (as root) modprobe nvidia, or better add this command to rc.module or something (depending of your distro)
 
Old 10-05-2004, 08:02 AM   #3
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
That could be the problem !!

Where should I put it in debian linux kernel 2.6.8.1 ?

/etc/moduls ??
 
Old 10-05-2004, 10:14 AM   #4
nazir
Member
 
Registered: Apr 2002
Location: Poland, Gliwice/Pszczyna
Distribution: Mandrake, Slackware
Posts: 41

Rep: Reputation: 15
yes, try to put it into /etc/modules in new line, that should be ok.
 
Old 10-05-2004, 10:16 AM   #5
nazir
Member
 
Registered: Apr 2002
Location: Poland, Gliwice/Pszczyna
Distribution: Mandrake, Slackware
Posts: 41

Rep: Reputation: 15
oh, I forgot. In /etc/modules you must put just the module name without modprobe command.
 
Old 10-05-2004, 02:35 PM   #6
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
and it works like a charm, thank you :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kompmgr wouldnt start with shadow enabled cyberfishee Linux - Software 8 06-12-2005 01:43 PM
XOrg/XFree86 with graphic 3D accel enabled motovoi Linux - Software 3 12-18-2004 09:53 PM
Mouse wheel and GLX not working after upgrade to XFree86 4.4 Oxyd Linux - Software 8 05-03-2004 12:17 PM
GLX/Xfree86/DRI/nvidia geforce 4 mx 420 problem asalford Linux - Hardware 3 04-01-2004 03:28 PM
GLX & DRI problems on XFree86 4.3 with RADEON 9200 peyotl Linux - Hardware 14 12-05-2003 12:48 PM


All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration