LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-09-2006, 02:46 AM   #1
GeoRanger
LQ Newbie
 
Registered: Mar 2006
Location: Oregon
Distribution: SuSe on AMD64 Athlon
Posts: 9

Rep: Reputation: 0
wvdial worked on Ubuntu but won't work on SUSE


Hi:

My computer previously was able to dial in to my ISP, using wvdial, from either Windows XP or from Ubuntu Linux. I replaced Ubuntu with SuSe, making sure that I kept a copy of wvdial.conf when I did so. Under SuSe, I ran wvdialconf to make sure the relevant settings were the same (they were). When I ran wvdial from the terminal window, I could see NO CARRIER right after the password was sent. After going through the modem and ISP configuration in YaST, I am now trying to use kinternet and see basically the same result in the log file that it produces (included below).

I created and tested a new dial-up connection in Windows to make sure I had my username and password correct.

When I dial in from SuSe the noises made by the modem all sound normal and identical to those made when I dial in under Windows.

I cannot tell if my end or my ISP's end is hanging up.

Does anyone have any ideas about where I should look or what I should try to get this to work with SuSe?

Thanks for any help,
GeoRanger

Modem : External US Robotics 56K faxmodem.
CPU : AMD 64-bit Athlon
Memory: 1 GB
OSs : SuSe Linux 10.1, Windows XP SP2.

Logfile:

SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on Ophir.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: --> WvDial: Internet dialer version 1.54.0
pppd[0]: --> Initializing modem.
pppd[0]: --> Sending: ATZ
pppd[0]: ATZ
pppd[0]: OK
pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd[0]: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
pppd[0]: OK
pppd[0]: --> Sending: ATM1
pppd[0]: ATM1
pppd[0]: OK
pppd[0]: --> Modem initialized.
pppd[0]: --> Sending: ATDT2461435
pppd[0]: --> Waiting for carrier.
pppd[0]: ATDT2461435
pppd[0]: CONNECT 45333/ARQ/V90/LAPM/V42BIS
pppd[0]: --> Carrier detected. Waiting for prompt.
pppd[0]: CVX Access Switch.
pppd[0]: Access is restricted to authorized users only.
pppd[0]: login:
pppd[0]: --> Looks like a login prompt.
pppd[0]: --> Sending: [my account name]
pppd[0]: [my account name]
pppd[0]: password:
pppd[0]: --> Looks like a password prompt.
pppd[0]: --> Sending: (password)
pppd[0]: NO CARRIER
pppd[0]: --> Don't know what to do! Starting pppd and hoping for the best.
pppd[0]: Serial connection established.
pppd[0]: Renamed interface ppp0 to modem0
pppd[0]: Using interface modem0
Status is: connecting
pppd[0]: Connect: modem0 <--> /dev/ttyS0
pppd[0]: Serial line is looped back.
pppd[0]: Connection terminated.
Status is: disconnected
pppd[0] died: Loopback detected (exit code 17)
 
Old 11-09-2006, 09:29 AM   #2
Albrich
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Rep: Reputation: 4
wvdial modem

I had similar problems with a U.S.Robotics Message Modem.
The ATZ defaults to ATZ0 - which resets to factory defaults. You probably want ATZ4 - set to PC defaults. (or AT&F1 or AT&Y3)
The Hayes code descriptions in the kde manual 'KDE-Internet-Dial UP-Kppp-appendix B' have more details but you need the U.S.Robotics ones on your disk (use Konqueror) because some are different.
Another thing to look at is the Guard Tone &G0/1/2 which is sent or not sent fron the other modem, and does not always follow local standards. If this is wrong you will get the NO CARRIER.
 
Old 11-10-2006, 11:51 PM   #3
GeoRanger
LQ Newbie
 
Registered: Mar 2006
Location: Oregon
Distribution: SuSe on AMD64 Athlon
Posts: 9

Original Poster
Rep: Reputation: 0
Thank you for your interest in my problem. :-)

The initialization codes you suggested had no perceptible effect, however trying them got me poking around in the place where I was able to find what is apparently the real problem.

The YaST2 configuration has a panel with about five checkboxes where you configure your ISP. One of those is labeled (no joke) "Stupid Mode". I had this unchecked. I tried checking it and that setting made the difference. (I confirmed the result by unchecking and checking it again.)

I looked around on the internet and the setting seems to have something to do with synchronizing the receipt of a login prompt from the ISP with a handoff between wvdial and ppp. I didn't really understand it but some of the material I read indicated it is a problem with the ISP.

I still have my old wvdial.conf file from Ubuntu. Interestingly and to my puzzlement, when I compare that file to the wvdial.conf that was generated under SuSe, the Ubuntu version does not have "stupid mode" turned on (set to 1) but the SuSe version does. I don't understand why "stupid mode" was not needed under Ubuntu, especially if the problem is something to do with the ISP.

Thanks for your help! :-)
GeoRanger
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unusual exit of pppd/wvdial in Ubuntu. Mindlesscomic Ubuntu 2 09-27-2012 02:28 PM
problem with wvdial on ubuntu bugpolo Linux - Newbie 6 10-01-2009 04:36 AM
Tried Ubuntu, does Suse work better? mdubs Suse/Novell 11 10-09-2006 08:32 AM
Ubuntu: My winmodem worked ONCE. PlantPerson Linux - Hardware 6 04-11-2006 05:56 AM
wvdial (modem) works w/ ubuntu not w/ others towsonu2003 Linux - Hardware 6 10-11-2005 11:13 AM


All times are GMT -5. The time now is 10:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration