LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2003, 09:04 AM   #1
lawadm1
Member
 
Registered: Jul 2003
Location: Illinois
Distribution: Fedora 11, Ubuntu 9.04
Posts: 80

Rep: Reputation: 15
wu-ftpd problem


I'm having problems setting up ftp. Using putty, I can telnet from XP to Red Hat, and I can connect via SSH, but I cannot ftp.

In /etc/xinetd/wu-ftpd I made the change to disable=no, but am I missing something else?

I tried using ws_ftp pro, but it hangs for a minute before returning the "Blocking call canceled".

any suggestions is appreciated.
 
Old 07-15-2003, 10:40 AM   #2
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
After enabling the configuration file /etc/xinetd.d/wu-ftpd, you will need to restart xinetd to refresh the configuration file changes.

Do a:
/etc/rc.d/init.d/xinetd restart
and you should be in business.
 
Old 07-15-2003, 11:01 AM   #3
lawadm1
Member
 
Registered: Jul 2003
Location: Illinois
Distribution: Fedora 11, Ubuntu 9.04
Posts: 80

Original Poster
Rep: Reputation: 15
oh sorry. i forgot to say that afterwards, i did run:
> service xinetd restart

I'm assuming that this accomplishes the same thing as:
> etc/rc.d/init.d/xinetd restart
??
 
Old 07-15-2003, 11:09 AM   #4
bentz
Member
 
Registered: Mar 2003
Distribution: Fedora, Mac OSX
Posts: 362

Rep: Reputation: 30
Yep it does. Try 'netstat -a' and look for a
tcp *:ftp LISTEN
line. If you don't get an entry like this, something is wrong with xinetd/wuftpd. If you do get an entry like this, you've got firewall/connectivity problems.
 
Old 07-15-2003, 10:09 PM   #5
lawadm1
Member
 
Registered: Jul 2003
Location: Illinois
Distribution: Fedora 11, Ubuntu 9.04
Posts: 80

Original Poster
Rep: Reputation: 15
Yep. The LISTEN is there for ftp.

When I tail -f on /var/log/mesages, I get:

ftpd[1971]: wu-ftpd - TLS settings: control allow, client_cert allow, data allow

THEN:

ftp session closed (Then WS-FTP Pro returns with blocking call)

Again, SSH and telnet are fine
 
Old 03-10-2004, 07:08 AM   #6
newbie104
LQ Newbie
 
Registered: Mar 2004
Location: Birmingham UK
Distribution: Redhat
Posts: 1

Rep: Reputation: 0
Only a thought. What user are you? root or other
root has restrictions by default so try another user to see if the problem still exists.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FTPD default permissions (wu-ftpd) bd1308 Linux - Software 1 10-22-2005 07:01 AM
Disabling Kerberos ftpd for wu-ftpd mortisd Linux - Software 0 08-31-2004 06:37 AM
WU-FTPD problem (Redhat 7.1) leetcrew Linux - Networking 4 03-07-2004 09:47 AM
wu-ftpd problem efski Linux - Networking 4 06-09-2003 08:40 PM
wu-ftpd problem cosmoh2o Linux - Networking 1 02-08-2003 01:14 PM


All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration