LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-20-2005, 10:56 PM   #1
sundaraz
LQ Newbie
 
Registered: Oct 2005
Location: Wisconsin
Distribution: Fedora Core 4
Posts: 15

Rep: Reputation: 0
Wrong UTC time


Hi,
I have a dual boot system. My BIOS clock is set to local time. I also have the "System Clock Uses UTC" option turned off. But stiil linux thinks that the BIOS time is the UTC time and adjusts the system time accordingly.

Please find the contents of /etc/sysconfig/clock file

ZONE="America/Chicago"
UTC=false
ARC=false

Is there any way to say that the BIOS time is not UTC time?

Also the command 'hwclock' with any of the options, produces no ouput. Not sure if this is a problem.

Thanks,
Raj
 
Old 10-21-2005, 10:11 AM   #2
xhi
Senior Member
 
Registered: Mar 2005
Location: USA::Pennsylvania
Distribution: Slackware
Posts: 1,065

Rep: Reputation: 45
Try

`timeconfig`

It should help.
 
Old 10-21-2005, 04:58 PM   #3
sundaraz
LQ Newbie
 
Registered: Oct 2005
Location: Wisconsin
Distribution: Fedora Core 4
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks. But it does the same thing as Desktop->System Settings->Date & Time and doesn't help. I am trying to do something with hwclock, but it doesn't do anything. Like, even hwclock -h doesn't produce any output.
 
Old 10-21-2005, 05:32 PM   #4
xhi
Senior Member
 
Registered: Mar 2005
Location: USA::Pennsylvania
Distribution: Slackware
Posts: 1,065

Rep: Reputation: 45
hmm, what happens if you do a
`hwclock --debug`

also
from man page
hwclock tries to use /dev/rtc. If it is compiled for a kernel that doesn't have that function or it is unable to open /dev/rtc, hwclock will fall back to another method, if available.

does /dev/rtc exist? maybe you dont have "another method" available if it does not exist? i know before i added it into the kernel, debug from hwclock gave me errors about no /dev/rtc... maybe add that? if so CONFIG_RTC is under character devices in kernel config

?
 
Old 10-21-2005, 10:45 PM   #5
sundaraz
LQ Newbie
 
Registered: Oct 2005
Location: Wisconsin
Distribution: Fedora Core 4
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks again. I figured out (through google) that i had to do "setenforce 0" to see output on hwclock. So, i enabled Network Time Protocol (NTP) and did hwclock --systohc. Anyways my BIOS clock was already right and local, I also did hwclock --localtime, to associate hwclock time to localtime.

Rebooted and am back to square one. I checked rc.sysinit and it seems to be calling /etc/sysconfig/clock, which looks right as i had pasted before.

Since i am connected all the time, I am just leaving it at NTP for now.

But i would be really glad to know, how to make linux think that hwclock is only localtime.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting system time to UTC triley Linux - General 2 08-25-2009 07:56 PM
Time zone stuck in UTC - how to change? Ook Slackware 2 04-24-2005 10:55 PM
Re: UTC Time unixfreak Linux - Newbie 2 08-30-2004 02:09 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
change UTC to EST time zone. brian_eye Linux - Newbie 1 10-27-2003 05:08 PM


All times are GMT -5. The time now is 10:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration