LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2009, 09:06 AM   #1
Jmont
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Rep: Reputation: 0
wrong master super block magic --HELP


Hi there - VERY VERY NEW To LINUX

I'm having problems with a RHES 5 server rebooting all the time. Having booted with a live CD isolinux with Kernel 2.6 trying to access logs on it, but can't seem to do the mount of my Logical drive with following error after MOUNT command:

<4>reiser4[mount(5474)]: init_reader_super (fs/reiser4/init_super.c:604)[nikita-20B]:
WARNING: sda: wrong master super block magic
FAT: invalid media value (0x8e)
mount you must specify the filesystem type


Adding this : The scsi hdd has a vfat partition and then all other partions being extfs3.

I need a clue on how to workaround this error

Thnx a lot

Jmont
 
Old 07-20-2009, 09:41 AM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,549
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Welcome to LQ!

Post the 'mount' command line that you utilized.
 
Old 07-21-2009, 10:35 AM   #3
Jmont
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

Welcome to LQ!

Post the 'mount' command line that you utilized.
Hi,

the command i used was :

mount -a -l -v /dev/sda3 /mnt/mydir . I think the problem is that that the root (/) filesystem is full (99% - i could see it doing a 'df -h')That was the only thing i could do before (another) restart after login . When i was doing the mount i was using a isolinux liveCD . The server was not on my charge but (by superior orders) now i'm the one in charge . The problem is i'm (I CONFESS) a Win Admin . This machine is our first Linux server . . . nice job ...
 
Old 07-21-2009, 03:04 PM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,549
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Quote:
excerpt from 'man mount';

-v Verbose mode.

-a Mount all filesystems (of the given types) mentioned in fstab.

-l Add the ext2, ext3 and XFS labels in the mount output. Mount
must have permission to read the disk device (e.g. be suid root)
for this to work. One can set such a label for ext2 or ext3
using the e2label(8) utility, or for XFS using xfs_admin(8), or
for reiserfs using reiserfstune(8).
You can always 'man command' to get full information to allow a better understanding of the usage.

If you look at the '-a' option you will see that the mount should use the static information from the 'fstab'.

The '-v' is just a verbose so as to get information from the actions.

The '-l' is for label use.

If you take the information from the command line and the output that you received. You did not have a '-a' specification for the the device that you were trying to mount via the 'fstab'. Plus no label definition.

If I were mounting a 'ext' filesystem then the 'mount /dev/some_device /mnt/some_mount_point' would default to the 'ext' filesystem since one was not specified. Now if that file was a 'NTFS' then I would use 'mount -t ntfs-3g /dev/some_NTFS_device /mnt/some_mount_point'. The 'ntfs-3g' file type would be used to allow R/W of the filesystem.

You should 'man mount' to understand a little more.

Look at 'Rute Tutorial & Exposition' to get some background.

The above link and others available from 'Slackware-Links'. More than just SlackwareŽ links!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bad magic number to open super block Ritho Linux - Newbie 1 03-06-2008 09:02 AM
Bad magic number in super-block Cadmium Linux - Newbie 2 10-03-2007 02:50 AM
Bad magic number in super-block while trying to open /dev/hda6 Daddyfix Linux - Hardware 1 11-20-2006 11:05 PM
e2fsck: Bad magic number in super-block jamesdin Debian 3 04-25-2005 06:14 PM
Bad magic number in super-block kubokubik Linux - Newbie 4 01-26-2005 11:52 AM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration