LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Wrong keyboard layout at boot (http://www.linuxquestions.org/questions/linux-newbie-8/wrong-keyboard-layout-at-boot-659701/)

vlachakb 08-01-2008 05:08 AM

Wrong keyboard layout at boot
 
Yesterday I installed Fedora 9(Gnome)on my Medion Desktop and have an issue with the keyboard layout at boot. I am using a AZERTY(Dutch ver.) Medion wireless keyboard with receiver connected to a USB port.

If I wish to edit GRUB or enter my password at login the keyboard layout is always US. During installation I had selected Dutch layout for keyboard and had noticed that while setting up the password and user account the wrong characters appeared. After first login I set the keyboard to Dutch and within the user account it works fine once logged in. Yet at boot and login screen the layout is always US (have to think where the character of AZERTY are compared to QWERTY).

Can anyone shead some light on this for me.

ronlau9 08-01-2008 05:20 AM

In my opinion before FC 9 is active the keyboard works according the settings in the BIOS
So my advice check you,re BIOS settings

aus9 08-01-2008 05:29 AM

I have never done one, but it sounds like you need to edit your /boot/grub/menu.lst to include

setkey

http://www.gnu.org/software/grub/man...ey.html#setkey

Here is an example

http://www.kanotix.com/index.php?mod...rubBootManager

http://linuxforum.at/agora/beitrag.php?id=106&start=0

In case you need blunt advice...the setkey command must exist one per line in your menu.

I will have to find keyboard layout maps or do you already have them?

here is one
http://en.wikipedia.org/wiki/Keyboard_layout

vlachakb 08-07-2008 01:43 AM

Quote:

Originally Posted by ronlau9 (Post 3233059)
In my opinion before FC 9 is active the keyboard works according the settings in the BIOS
So my advice check you,re BIOS settings

No entry or option was found in the BIOS that has to do with keyboard layout. Tried installing Mandriva Spring 2008 and have no problems with keyboard layout.

Installing OpenSusse 11.0 and Fedora 9, the keyboard layout at boot is not correct. Very strange...

The method of aus9 works, but I still find it odd That Madriva Spring 2008 has no problem with it. Any ideas, I am curious.

jay73 08-07-2008 03:01 AM

Hi,

I was recently surprised to run into the same issue. I am using an nvidia 9600GT, which means I have to use the latest drivers (still a bit beta). Well, all of a sudden I could not log in anymore because my password was rejected for some reason. I tried all sorts of tricks on the command line trying to figure out what was wrong until I realized that my machine had for some reason reverted to US keyboard layout. I had a look at my xorg.conf, and I found out that it did NOT specify any keyboard layout. So I simply copied those two or three lines of information from the xorg.conf.failsafe and the problem appears to be gone. If you haven't got a failsafe, try this:
Quote:

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

vlachakb 08-10-2008 12:56 PM

Jay73,

Thanks very much for your advice. It has cured all keyboard layout problems. Your are the MAX...



Quote:

Originally Posted by jay73 (Post 3239557)
Hi,

I was recently surprised to run into the same issue. I am using an nvidia 9600GT, which means I have to use the latest drivers (still a bit beta). Well, all of a sudden I could not log in anymore because my password was rejected for some reason. I tried all sorts of tricks on the command line trying to figure out what was wrong until I realized that my machine had for some reason reverted to US keyboard layout. I had a look at my xorg.conf, and I found out that it did NOT specify any keyboard layout. So I simply copied those two or three lines of information from the xorg.conf.failsafe and the problem appears to be gone. If you haven't got a failsafe, try this:


abcdef 03-26-2009 12:54 AM

Have a problem with my keyboard
 
I have installed fedora 10 in HP 540 laptop.In this single,double qoutes key is not working only this key is not working..
need some help to recover this problem


All times are GMT -5. The time now is 12:55 PM.