LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-24-2012, 06:41 AM   #1
imayneed
Member
 
Registered: Jul 2012
Distribution: Mint 9 Gnome, Mint 13 KDE
Posts: 60

Rep: Reputation: Disabled
wrong fs type after formatting ext4 to fat32


I formatted 2 partitions from ext4 to fat32.
Now, it says root can mount it.
When I open Storage Device Manager, it sees those partitions as ext4.
When I choose the option that any user can mount it, file manager gives me the error that fs information is bad.
When I open the file manager as root, it sees the partitions empty.
How can I fix this?
In the attached images, second one left side is Storage Device Manager info, and the right part is GParted info.
Thanks.
Attached Images
File Type: png 778800Untitled_window_001.png (15.8 KB, 12 views)
File Type: png 568661Bottom_Expanded_Edge_Panel_003.png (8.9 KB, 9 views)
File Type: png 911434Untitled_window_006.png (20.7 KB, 12 views)
 
Old 08-24-2012, 07:11 AM   #2
iamwilliam
Member
 
Registered: Apr 2006
Location: Nairobi
Distribution: CentOS
Posts: 78

Rep: Reputation: 21
Hi,

Creating a new partition / Re-formatting a partition is usually a 2 step process.
Modifying the partition table (I prefer fdisk). Verify that your partition table is correct by running the following commands as root

Code:
fdisk -l
Then create the new filesystem. You will lose any data on the 2 partitions when you run the commands below
Code:
mkfs.vfat /dev/sda6
mkfs.vfat /dev/sda7
modify /etc/fstab appropriately to allow other users to mount the new partitions.
 
1 members found this post helpful.
Old 08-24-2012, 09:55 AM   #3
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,530

Rep: Reputation: 705Reputation: 705Reputation: 705Reputation: 705Reputation: 705Reputation: 705Reputation: 705
Only root can do that is standard behavior so do you have an entry in /etc/fstab to allow users to mount as mentioned by iamwilliam above? You did reboot or remount, correct? If you formatted the partitions, you should not expect any data to be on the partitions.
 
Old 08-24-2012, 11:18 AM   #4
imayneed
Member
 
Registered: Jul 2012
Distribution: Mint 9 Gnome, Mint 13 KDE
Posts: 60

Original Poster
Rep: Reputation: Disabled
Storage Device Manager is still seeing them as ext4 instead of fat32.
It is the same with fstab. It sees them as ext4.

Code:
/dev/sda6                                  /media/sda6  ext4     users                    0  0  
/dev/sda7                                  /media/sda7  ext4     users                    0  0
The thing is I can boot to them. Nothing wrong with the files.
By the way, I expected to see data in them when I was root, because I had written data to them after the format to fat32.
Should I format it again with the way suggested by iamwilliam to create fat32 partitions?

fdisk -l wouldn't give me any information since this is a gpt disk and this partitions are partitions over 4 and primary.
gptsync didn't inform any problems.

Last edited by imayneed; 08-24-2012 at 11:20 AM.
 
Old 08-24-2012, 11:34 AM   #5
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
hi imayneed,
I would suggest you to re-format the two drives as indicated by iamwilliam, remember that those commands must be issued as root when the partitions are not mounted (but I don' think you can mount them anyway). After formatting, as root, open /etc/fstab file with your favorite text editor and change the corresponding lines in something like
Code:
/dev/sda6   /media/sda6    vfat    auto,users,rw,umask=0000,uid=1000,gid=1000 0 0
/dev/sda7   /media/sda7    vfat    auto,users,rw,umask=0000,uid=1000,gid=1000 0 0
Those are the setting I use for my fat32 disk, which work fine. Someone might suggest some different setting or you can type
Code:
man fstab
, read and decide the option which suit best your needs.
 
1 members found this post helpful.
Old 08-24-2012, 11:36 AM   #6
imayneed
Member
 
Registered: Jul 2012
Distribution: Mint 9 Gnome, Mint 13 KDE
Posts: 60

Original Poster
Rep: Reputation: Disabled
I just realized that I can mount the drives by gparted!
Thanks for the fstab info.

I just realized that I haven't thanked iamwilliam at all.
Thank you.

Last edited by imayneed; 08-24-2012 at 11:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Formatting external drives in ext4 Cultist Linux - Hardware 1 12-19-2010 07:51 PM
[SOLVED] raid5 with ext4: values for parameters when formatting the raid crts Linux - Software 1 12-19-2010 08:21 AM
[SOLVED] Formatting hard drive with ext3/ext4 while getting full rwx permissions PasBern Linux - Newbie 10 12-30-2009 12:16 PM
Convert ext4 FS to ext3 without formatting HDD n03x3c Linux - General 3 12-04-2009 05:47 AM
Formatting drive to ext4 simonb1975uk Slackware 2 01-08-2009 11:10 AM


All times are GMT -5. The time now is 03:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration