LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   wrong fs type after formatting ext4 to fat32 (http://www.linuxquestions.org/questions/linux-newbie-8/wrong-fs-type-after-formatting-ext4-to-fat32-4175423769/)

imayneed 08-24-2012 06:41 AM

wrong fs type after formatting ext4 to fat32
 
3 Attachment(s)
I formatted 2 partitions from ext4 to fat32.
Now, it says root can mount it.
When I open Storage Device Manager, it sees those partitions as ext4.
When I choose the option that any user can mount it, file manager gives me the error that fs information is bad.
When I open the file manager as root, it sees the partitions empty.
How can I fix this?
In the attached images, second one left side is Storage Device Manager info, and the right part is GParted info.
Thanks.

iamwilliam 08-24-2012 07:11 AM

Hi,

Creating a new partition / Re-formatting a partition is usually a 2 step process.
Modifying the partition table (I prefer fdisk). Verify that your partition table is correct by running the following commands as root

Code:

fdisk -l
Then create the new filesystem. You will lose any data on the 2 partitions when you run the commands below
Code:

mkfs.vfat /dev/sda6
mkfs.vfat /dev/sda7

modify /etc/fstab appropriately to allow other users to mount the new partitions.

yancek 08-24-2012 09:55 AM

Only root can do that is standard behavior so do you have an entry in /etc/fstab to allow users to mount as mentioned by iamwilliam above? You did reboot or remount, correct? If you formatted the partitions, you should not expect any data to be on the partitions.

imayneed 08-24-2012 11:18 AM

Storage Device Manager is still seeing them as ext4 instead of fat32.
It is the same with fstab. It sees them as ext4.

Code:

/dev/sda6                                  /media/sda6  ext4    users                    0  0 
/dev/sda7                                  /media/sda7  ext4    users                    0  0

The thing is I can boot to them. Nothing wrong with the files.
By the way, I expected to see data in them when I was root, because I had written data to them after the format to fat32.
Should I format it again with the way suggested by iamwilliam to create fat32 partitions?

fdisk -l wouldn't give me any information since this is a gpt disk and this partitions are partitions over 4 and primary.
gptsync didn't inform any problems.

VDP76 08-24-2012 11:34 AM

hi imayneed,
I would suggest you to re-format the two drives as indicated by iamwilliam, remember that those commands must be issued as root when the partitions are not mounted (but I don' think you can mount them anyway). After formatting, as root, open /etc/fstab file with your favorite text editor and change the corresponding lines in something like
Code:

/dev/sda6  /media/sda6    vfat    auto,users,rw,umask=0000,uid=1000,gid=1000 0 0
/dev/sda7  /media/sda7    vfat    auto,users,rw,umask=0000,uid=1000,gid=1000 0 0

Those are the setting I use for my fat32 disk, which work fine. Someone might suggest some different setting or you can type
Code:

man fstab
, read and decide the option which suit best your needs.

imayneed 08-24-2012 11:36 AM

I just realized that I can mount the drives by gparted!
Thanks for the fstab info.

I just realized that I haven't thanked iamwilliam at all.
Thank you.


All times are GMT -5. The time now is 03:42 AM.