LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-06-2005, 05:17 AM   #1
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Rep: Reputation: 15
Writing to windows partitions, Suse 9.2


Hello,
I have both WinXP and Suse 9.2 on my hard drive. I have stored all my digicam pictures to windows/D (FAT32). I have no problems reading them, but I can not put new pictures there with Suse. It seems I have no write access to it. I have tried to put my account as owner, but it didn't work.

Should I modify SUSE's way of mounting the D at boot, and if so, how can I do that?

Or would it be better just to store the pics to the Suse partition?
 
Old 08-06-2005, 05:27 AM   #2
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Edit your /etc/fstab from:
/dev/hdax /foo/bar vfat blah,blah,ro 0 0
to
/dev/hdax /foo/bar vfat blah,blah 0 0

then unmount and remount the drive in question.

Good Luck!
 
Old 08-06-2005, 05:58 AM   #3
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
Thank you for the fast reply.
However, I didn't get that to work, maybe I messed it up somehow? Here's my fstab:
Quote:
/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda4 /windows/D ntfs users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdram /media/dvdram subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
After modifying that, I remounted the drive:
umount /dev/hda4
mount /dev/hda4
 
Old 08-06-2005, 06:02 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
If your Windows D drive is FAT 32, why's it set to NTFS in your fstab? If it is FAT 32, then the entry should have "vfat" in the filesystem column and not "ntfs". Linux can't write to NTFS, AFAIK.
 
Old 08-06-2005, 06:10 AM   #5
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Nylex
If your Windows D drive is FAT 32, why's it set to NTFS in your fstab?
Now, that is a good question.
I'll have to look into that. Thanks.
 
Old 08-06-2005, 01:26 PM   #6
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
OK, I reformatted the D to FAT. Now, I can access it as root (both read and write) but not with my own account. How can I change the permissions so that any user can fully access D? I tried it the windows way, i.e. right-clicking on the D and selecting the permissions tab, but that failed to do the trick.
 
Old 08-06-2005, 01:39 PM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Use the chmod command:

# chmod -R +rw /windows/D

Last edited by Nylex; 08-06-2005 at 01:40 PM.
 
Old 08-06-2005, 03:34 PM   #8
badbunny
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Kubuntu Gutsy
Posts: 95

Original Poster
Rep: Reputation: 15
OK, that's it. Now it works.

Thanks to all you guys for the help.
 
Old 08-06-2005, 07:36 PM   #9
PeterRJG
Member
 
Registered: Jun 2005
Location: Northern NSW, Australia
Distribution: Distro Astro 1.02, Windows 7
Posts: 123

Rep: Reputation: 15
I know I'm late in on this thread but I have fstab set up like:
/dev/hda1 /mnt/win_c vfat users,rw,owner,umask=000 0 0

Worked like a charm so far
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Writing permission for windows and linux partitions jaakkop Slackware 3 07-25-2005 06:14 AM
writing to windows 2000 fat32 partitions from Fedora 2 michaelweaver Linux - Newbie 5 05-24-2005 09:40 PM
Question about writing to windows partitions ludwig W Linux - Newbie 5 04-20-2005 03:25 AM
Accessing and writing to Windows partitions Delmarc Linux - Newbie 3 02-14-2004 10:39 AM
reading and writing to Linux partitions from windows Moebius Linux - General 2 01-21-2004 04:57 PM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration