LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-23-2005, 11:00 PM   #1
btb
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Rep: Reputation: 0
write permissions in /etc/fstab for vfat filesystem


Hi all, First, I am running FC4. I've added this line to my /etc/fstab file to mount my vfat partition:

Code:
/dev/hda5     /fatsys        vfat    auto,user,rw,sync,exec,uid=500,gid=500     0 0
unfortunately, this does not allow me to write to fatsys when I'm not logged in as root. I've tried different configurations of the options, as well as trying to change the permissions as root by chmod. It does not allow non root users to have write permissions. Any tips?

Thanks!

Last edited by btb; 10-24-2005 at 12:25 AM.
 
Old 10-23-2005, 11:10 PM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
Re: write permissions in /etc/fstab for vfat filesystem

Code:
/dev/hda5     /fatsys    vfat    owner,users,rw     0 0
try that.......
 
Old 10-23-2005, 11:14 PM   #3
btb
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
That doesn't work either unfortunately. Even when I try to change the permissions in the filebrowser as root, it just doesn't click the write box for other and group permissions.

update: I've also tried putting the permissions in the options:
auto,user,rw,sync,noexec,uid=500,gid=500,mode=777

No luck!

Last edited by btb; 10-23-2005 at 11:33 PM.
 
Old 10-24-2005, 12:22 AM   #4
btb
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I can't even add write permissions for individual files in the fatsys. Also I tried a restart, and with the configuration of options I have above, fatsys does not mount automatically at boot time, although I have "auto." I tried it with "defaults" and it was able to mount automatically at boot time. But still the write permissions problem persists.

Any ideas would be appreciated!
 
Old 10-24-2005, 07:31 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,930

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
To allow read / write for all users

/dev/hda5 /fatsys vfat users,umask=000 0 0

A FAT32 filesystem does not have any permissions.
 
Old 10-24-2005, 02:37 PM   #6
btb
LQ Newbie
 
Registered: Jun 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I added the umask and it works fine. thank you! here is the complete setup:

auto,rw,user,sync,exec,dev,suid,uid=500,gid=500,umask=000
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Filesystem other than vfat on pc card? JohnKFT Slackware 1 04-03-2005 01:54 PM
fstab vfat read write prob gbarny Linux - General 3 06-20-2004 02:19 AM
Can't mount Vfat or Msdos Filesystem!! RKris Linux - Software 6 06-19-2002 05:58 PM
vfat write permissions andrea.corelli Linux - General 4 04-23-2002 03:43 AM
Mounting a vfat filesystem in RH 7.2 M.I. Linux - General 8 11-28-2001 10:06 PM


All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration