LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2010, 04:26 PM   #1
lostzinzthought
Member
 
Registered: Sep 2010
Location: USA
Distribution: Slackware13.1
Posts: 47

Rep: Reputation: 4
WPA2 [netID and pass] wireless network from wicd and/or command line


The university I go to uses a WPA2 wireless network that requires a netID and password to connect too.
I installed wicd but I can't seem to connect to this network, is there a way to add this functionality to wicd, and if so, how do I do that (links to a how-to or guide would be nice, I've yet to find one).

also, I spend most of my time on campus in the command line, so I'd like to know if there is a way to use command line utilities to connect to this network (again, a guide or how-to would be nice)

I can get online through my fedora live USB just fine (w/ network manager) but I'd rather get on directly from slackware.

thank you in advance!
 
Old 09-23-2010, 07:27 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
If you're using wicd, you should first be sure you're using the most recent release. However, even with that release, I had some problems using WPA2. (You're supposed to be able to configure it from the "properties" button network selection box, but that didn't work for me on one of my systems but it worked fine on others.) So, what I did was to hard-code my network information in /etc/wpa_supplicant/wpa_supplicant.conf, and that seemed to do the trick. (Note that I'm using a Fedora system, so my conf file location may differ from the Slack one.)

If you do a complete wicd install, you should have the wicd-curses package also installed, which provides a command-line wicd interface. That may be a separate package on Slack, but it should be available.

I understand that I haven't provided many details, but man wpa_supplicant.conf does describe the process fairly well.

Here's what my wicd configuration file looks like on a system where wicd works:
Code:
$ sudo cat /var/lib/wicd/configurations/00150544e96d 
[sudo] password for Peter: 
ap_scan=1
ctrl_interface=/var/run/wpa_supplicant
network={
       ssid="TSS3"
       scan_ssid=0
       proto=WPA RSN
       key_mgmt=WPA-PSK
       pairwise=CCMP TKIP
       group=CCMP TKIP
       psk=<- Redacted ->
}
Since you're using a different scheme, you need to "tweak" that example per the instructions the the wpa_supplicant manual pages.
 
1 members found this post helpful.
Old 09-23-2010, 08:24 PM   #3
lostzinzthought
Member
 
Registered: Sep 2010
Location: USA
Distribution: Slackware13.1
Posts: 47

Original Poster
Rep: Reputation: 4
Thank you ^_^ That helped a lot, actually - I hadn't been aware of the wpa_supplicant.conf man page, and the man page for wpa_supplicant didn't really help me, I'll try it out tomorrow when I'm back on campus and see how it goes

Any more advice is still appreciated, I can't test this until tomorrow so I won't know until then if it's solved or not
 
Old 09-23-2010, 11:20 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
I just figured out what my problem with the system that was unable to use wicd: You can't have both the NetworkManager service and the wicd service running on the same system, and many distributions (I don't know about Slackware) default to having NetworkManager enabled. I'd neglected to disable NetworkManager and enable wicd on the problem system.

Now it works fine.

I don't think that that's your problem, but you should check. When the NetworkManager service is running, the wicd-client will appear to run, but functionality (like actually connecting to a network) will fail with strange messages, etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
connecting to a wireless network via command line greplinux Linux - Newbie 3 08-10-2010 12:24 AM
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 03:51 AM
Connecting to a wireless network from command-line Daravon Linux - Newbie 21 12-06-2009 02:35 AM
Connecting to wireless network using command line. imagine_me2 Linux - Newbie 2 12-03-2009 05:28 AM
Wicd on Fedora 10 will not connect to WPA/WPA2 network after install Mikazo Linux - Wireless Networking 2 04-11-2009 01:38 PM


All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration