LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2003, 06:05 AM   #1
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Rep: Reputation: 15
Wot no Umlauts


Hi folks,

I know there are several posts regarding international characters in Linux fonts/appz, but I am still rather puzzled.

I use and view many German documents and web sites, but either have 'Unicode?' in file names or simply omission of the offending character altogether in emails and webpages - which is pretty damned annoying as I am still learning the language.

It appears that Alt codes don't count in Linux either... so I can't write 'em either.

Any help/redirections/links gratefully accepted.

Kaine.

 
Old 07-18-2003, 06:07 AM   #2
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
In german it's perfectly acceptable to write an "e" after the umlauted vowell. I know, doesn't help with the typing issue (which I am interested in learning the answer to, as well), but still.

Auf Wiederhoeren
 
Old 07-18-2003, 06:24 AM   #3
kaine
Member
 
Registered: Jun 2003
Location: Bath, U.K.
Distribution: SuSE 9.3, 10.2
Posts: 72

Original Poster
Rep: Reputation: 15
Hey Poetics

Thanks for your 10c worth, 'preciate it.
I have been doing that when necessary, but it's the viewing that's the biggest bind...

Weiss ich noch nicht was ich machen werde...
 
Old 07-18-2003, 07:03 AM   #4
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
I do know that you can change your keyboard layout to german, though I know not the command (we're all learning, aren't we!), or if there's an easy way to do it, but I know it's possible. You can find many keyboard maps auf Deutsch online (just graphics labelling what key is mapped where). As for reading pages in foreign languages; have you tried installing a german language pack?

I should mention that I'm not practiced in installing foreign languages into linux, but it's a hearty guess.

viel Gluek
 
Old 07-18-2003, 12:46 PM   #5
Bill_Tür
Member
 
Registered: Jul 2003
Location: Germany
Distribution: RedHat
Posts: 44

Rep: Reputation: 15
You better not change your keyboard layout to german. Everytime I change my keyboard to english (or forced to do so) typing ends in a mess.
Just add an 'e' to make an 'umlaut'. Looks strange but works!
 
Old 07-18-2003, 05:44 PM   #6
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
Can you give more specifics, Bill_Tür? You mean that you're just not used to the layout, or that the typing itself is messed up?

Quote:
Everytime I change my keyboard to english (or forced to do so) typing ends in a mess.
 
Old 07-19-2003, 05:22 AM   #7
Bill_Tür
Member
 
Registered: Jul 2003
Location: Germany
Distribution: RedHat
Posts: 44

Rep: Reputation: 15
Well the keys are on a different position. So if i would press the 'z' button a 'y' would appear. This ain't a big problem but typing special characters is nearly impossible if you don't know what button to be pressed. Following I list some examples:
# -> \
' -> =
+ -> ]
- -> /
} -> Still don't know what buttons to be pressed
" -> @
@ -> know idea

and so on...
 
Old 07-19-2003, 06:01 AM   #8
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
Hi
I have my keyboard set to standard US and i can make
perfect umlauts. Like this; üëï˙ etc etc.
How to do this; simple, first i hit the " and then the wanted vowel.
This will only work if your keyboard is set to use "dead keys"
read this;

http://www.redhat.com/docs/manuals/e...kbdconfig.html

So if you hit the " symbol once and you see it appear right after that,
then you 'll have to change your settings. Otherwise to get the " it's
made by typing " and then the space key .

Good luck
 
Old 07-19-2003, 10:37 AM   #9
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
Something else to read;

http://www.tldp.org/HOWTO/mini/Intkeyb/index.html

it has sample keyboardlayouts on it
and here;

http://sdb.suse.de/en/sdb/html/js_xmodmap.html

you can read how to easily switch between layouts

regards
 
Old 07-20-2003, 07:21 PM   #10
deleeuw
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9
Posts: 16

Rep: Reputation: 0
Poetics (or anyone),
ALthouhg "ae" or "oe" works, can one use "ss" instead of
ess-zet (the beta-looking character)?
I know about the ALT+### to make those characters. but the key doesn't seem to work in Linux (RH9).
 
Old 07-20-2003, 07:41 PM   #11
chris_i386
LQ Newbie
 
Registered: Feb 2003
Location: Europe
Distribution: Deb3.0,RH9
Posts: 15

Rep: Reputation: 0
Quote:
Originally posted by deleeuw
Poetics (or anyone),
ALthouhg "ae" or "oe" works, can one use "ss" instead of
ess-zet (the beta-looking character)?
Sure!
 
Old 07-20-2003, 08:02 PM   #12
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
Actually, a few years back (97?), it was decided by the German government to stop using the esset character, and to use "ss" instead. So, yes, you are very proper in such usage
 
Old 07-20-2003, 08:17 PM   #13
chris_i386
LQ Newbie
 
Registered: Feb 2003
Location: Europe
Distribution: Deb3.0,RH9
Posts: 15

Rep: Reputation: 0
In the late 90's a committee consisting of German and Austrian linguists (sp?) decided to reform German spelling rules, but they didn't totally abandon the use of the ß (Eszet).
(Now you still have it after long vowels, but use ss after
short vowels instead)
Some say they made it even worse, but I disagree.

</OffTopic>
 
Old 01-06-2006, 06:05 PM   #14
bakerbaz
LQ Newbie
 
Registered: Dec 2005
Location: Karlsruhe,S/W Krautland
Distribution: Open Suse 10
Posts: 4

Rep: Reputation: 0
Hi kaine,
do you want a german keyboard?
If so I have a few spares lying about ,which I will send you for the price of the postage.
The way I get round your problem(being an englishman in Karlsruhe!)is to have an english layout K/B going
in the PS/2 input and a german one in a USB slot,
works for me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VFAT partition no umlauts Marc L. Linux - Newbie 3 07-19-2005 05:40 PM
Amarok and special characters (umlauts) Fonk Linux - Software 0 03-13-2005 04:32 PM
SuSE 9.0, Wot no rc.config? tethysgods Linux - Networking 1 07-24-2004 08:12 PM
Umlauts! ichbindaswalros Linux - General 1 07-02-2004 10:48 PM
Question (donno wot to head it as) identikal General 2 10-08-2003 12:37 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration