LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2004, 11:14 AM   #1
Fear58
Member
 
Registered: Feb 2004
Location: Reno, Nevada
Distribution: Mandrake 9.2
Posts: 221

Rep: Reputation: 30
Wont boot into interactive startup HELP!


Hey all, Just got linux mandrake 9.2 installed on my system, and it was working fine just yesterday. I remember opening the konsole program and typing in the code to become root user ( I think) su, then login and password and such. Then I shut off my computer. Now when I try to dual boot into linux, a black screen comes up asking for localhost user and password, and I enter it and nothing really happensm it wont take me into the interactive startup! Please help, Im getting kinda stressed over it, and I dont know if I am screwed

Last edited by Fear58; 02-14-2004 at 11:51 AM.
 
Old 02-14-2004, 11:58 AM   #2
Dominik
Member
 
Registered: Nov 2003
Distribution: slackware9.1/freebsd5.2
Posts: 53

Rep: Reputation: 15
When you are logged in, you can type 'startx' to run your X desktop.

If you want to log in through the graphical interface, you must choose runlevel 4
in your /etc/inittab file.

If startx doesnt work, maybe the /etc/XF86config file need correct screen&graphic card settings.
 
Old 02-14-2004, 12:22 PM   #3
Fear58
Member
 
Registered: Feb 2004
Location: Reno, Nevada
Distribution: Mandrake 9.2
Posts: 221

Original Poster
Rep: Reputation: 30
Thanks you soooo much, that startx cmd worked.
I am so used to Windows, using their file explorer and all, how do I get to the file to change the level to 4? Thanks.
 
Old 02-14-2004, 01:48 PM   #4
Dominik
Member
 
Registered: Nov 2003
Distribution: slackware9.1/freebsd5.2
Posts: 53

Rep: Reputation: 15
log in as root

startx

run a terminal & write 'kate /etc /inittab &'

(kate can be replaced by any other text-editor )

at the top of the file you should find :
*****************
#0 :runlevels definition
#1 ...
#2
#3
#4
#5
#6 ...

#default runlevel
id:3:initdefault
***************
in the last above line the 3 must be replaced by a 4.
 
Old 02-14-2004, 02:20 PM   #5
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
In case you want to start in the graphical environment (X), put 5 instead of 3.
 
Old 02-15-2004, 02:49 AM   #6
Dominik
Member
 
Registered: Nov 2003
Distribution: slackware9.1/freebsd5.2
Posts: 53

Rep: Reputation: 15
Smile

Hi Redeye2,

Before answering i tested what i suggest on my pc.

with runlevel 4 you start up directly with X.

runlevel 5 is equivalent to the #3.

...check your inittab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo - interactive boot[?] Ph0enix2003 Linux - Distributions 3 09-20-2004 05:12 PM
Non-interactive LILO boot dibblethewrecke Linux - Newbie 7 11-08-2003 06:00 AM
slackware 9.0 isocd wont boot at startup crealkiller175 Slackware 8 03-25-2003 12:36 PM
redhat interactive startup aetengoku Linux - Newbie 1 03-20-2003 04:02 AM
press 'I' to enter interactive startup? xiaoxiao Linux - Software 3 04-06-2001 08:39 AM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration