LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2005, 12:58 AM   #16
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30

well this kinda goes against what everyone else said, but this is what happened when i used xmms (note, it is not my normal player) i opened it and right clicked and went to preferences, then clicked the cd audio player plugin (note #2, if this is not there you may need additional plugins) ten clicked configure. i pointed the device at /dev/hdd (that is where my cdrom drive is) then the directory /mnt/cdrom (cause although there is no filesystem per say on the cd, xmms needs a place to read the raw audio from) then i riht clicked on xmms and clicked play location, and i clicked /mnt/cdrom and voila. try that. i htink that xmms is the only player that needs to have you play the directory. try xine and check the settings. then click the cd button on the gui and see if it plays it. dont know y but that is just how things work sometimes.
 
Old 06-17-2005, 01:15 AM   #17
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
that should work.

check what;s going on in the terminal, you'll have to sort through a lot of crap to get to anything important.
 
Old 06-17-2005, 01:35 AM   #18
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
Not using XMMS

I'm using CD Player 2.8.0. A CD Player for GNOME. Written by Iain Holmes. It is the player that comes with the Distro. I tried to download and install XMMS but it wouldn't let me. The device is /dev/cdrom. I don't seem to be able to direct the player to a specific directory. I'm still in the dark here, but I'm learning.
 
Old 06-17-2005, 01:54 AM   #19
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
CD player run from terminal

[indinaveer@localhost ~]$ gnome-cd
** Message: Error opening CD


This is what I get when I run the app from the terminal.
 
Old 06-17-2005, 10:06 AM   #20
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
look at your cdrom plugin in xmms
it should have the device listed and the mount point
 
Old 06-17-2005, 08:21 PM   #21
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
try gnome-cd --device=/dev/hdc
if not gnome-cd --device=/dev/hdd
if not, what kernel version are you using? are you using ide-scsi?
what do you get if you ls -l /dev/hdc? ls -l /dev/hdd?
does it attempt to access the cd drive? you can usually tell cause the drive will light up and spin, so if it is not then i bet the first 2 things i told you wil help this is definately a problem of pointing. hell, man that player sucks anyway. y dont you try what everyone has said about xmms and all the others?
 
Old 06-18-2005, 11:51 PM   #22
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
it just occurred to me that I might not be using the correct name for my device. It is a CD RW/DVD combo drive (sony). Would that make the name of the location different in XMMS? I'm not sure that I know how to look into the XMMS plugin to see what the device is. It may have a different name than cdrom.
 
Old 06-19-2005, 02:58 AM   #23
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
according to your fstab, the device should be /dev/hdc

most combo drives are mounted as that
 
Old 06-19-2005, 10:51 AM   #24
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
I wonder what's up

You do not seem to have permission to access /dev/hdc.
Press 'Set device' to go to a dialog where you can set the device, or press 'Quit' to quit the CD player

This is what it tells me when I enter that device name in the cd player. I've tried it in xmms as well and it seems to just ignore that. Do I have to sign in as root to change device? I'll try that but this is what people have been telling me to do, and it doesn't seem to be working.
 
Old 06-20-2005, 02:43 PM   #25
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
hmm, you shouldn't have to log into root to do that
try to pass the user option to the /dev/hdc line in your fstab.

[code]/dev/hdc /media/cdrecorder auto,<b><i>users</b></i> pamconsole,fscontext=system_u[code]


try that, that worked for me...

or, you might have to add your user the the "optical" group, if Fedora uses that group for the optical drives.
 
Old 06-20-2005, 07:31 PM   #26
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
i think you can also chmod 666 /dev/hdc

i know it sounds evil but should give you access to it.
 
Old 06-23-2005, 12:14 AM   #27
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
I gave up

I gave up, and downloaded Ubuntu. Now the audio discs work fine, but I can't play DVDs. I guess if things worked well all the time, you'd have to pay for it, or know a whole lot more than I do about computers. I also made this reply to a previous thread, as I couldn't tell the difference. Thanks to all for helping. I'm too new to help, almost.
 
Old 06-23-2005, 01:56 AM   #28
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
well, lets see. if you gave the error you could probably be helped on the dvd thing. just in case you will need the libdvdcss package (i dont know anything about ubuntu) and maybe the libdvdread package. then just make sure you have a symlink to the dvd drive . if the dvd drive is /dev/hdc then you would need a symlink /dev/dvd---> /dev/hdc. just open xine and click dvd and see what happens. if it immediatly errors, then xine is pointed wrong. it is in the setting. if you right click on xine and go to setup, then change the experiance setting as appropriate to let you change the directory it looks for. it wont let you control all options in beginner.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
why i can't play my CD audio mamasmoe DamnSmallLinux 1 08-12-2004 08:31 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 05:23 AM
Can't play CD Audio morrolan Linux - Software 3 01-05-2004 09:55 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 08:52 AM
play audio cd bfkeats Linux - General 4 02-06-2002 01:19 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration