LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2005, 10:54 PM   #1
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Rep: Reputation: 15
Won't play audio disks


Have Fedora Core installed on a Shuttle AK32 Mobo Duron 1GHZ with 512 MB RAM. New Combodrive (DVD/CD RW) Sony. Can read data disks and generally no trouble, but when I try to play audio disks, it gives me "disk error" on the audio player. Did the same with a CD ROM that I replaced with the current combo drive. Must be a software problem. I've asked this problem before, but I've bought the new drive since then and I'm sure I can read data disks,. I can view pictures burned from my digital camera etc. Thanks.
 
Old 06-14-2005, 11:51 PM   #2
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
Can you be more specific about which CD player exactly you're using? There are many different CD players available on Linux. You might want to try a different one perhaps.

Also, if you run that same CD player from a terminal window (a shell), it might output extra error messages which can be quite handy.
 
Old 06-15-2005, 01:09 AM   #3
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
also, make sure the audio cable is connected to your sound card from the optical drive! (stupid, but it's an issue sometimes), and you might want to add your user to the optical group, if you haven't already done so.

Do you have the optical drive set-up properly in the fstab?
 
Old 06-15-2005, 01:15 AM   #4
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Rep: Reputation: 30
Quote:
Originally posted by sewer_monkey
Can you be more specific about which CD player exactly you're using? There are many different CD players available on Linux. You might want to try a different one perhaps.

Also, if you run that same CD player from a terminal window (a shell), it might output extra error messages which can be quite handy.
Micro$oft Windoze - 32-bit extensions and a graphical shell for a 16-bit patch to an 8-bit operating system originally coded for a 4-bit microprocessor, written by a 2-bit company!

dont mean to get of topic, but you should change it to Micro$oft Windoze ><64 edition -64-bit extensions to 32- bit extensions and a ... all the rest is the same.

Back to topic, seens like it might be an unsupported drive... (or bad support)
 
Old 06-15-2005, 09:44 AM   #5
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
you say it gives you a disk error ,what app tells you that ?
if U try xmms ,make sure you point it to the xmms_audio_cd in your media or mnt
more info please
 
Old 06-15-2005, 01:23 PM   #6
pintooo15
Member
 
Registered: May 2004
Location: India
Distribution: openSUSE Tumbleweed and SLED 12 SP2
Posts: 94

Rep: Reputation: 31
in linux, before hearing an audio cd you have to make sure that u DO have an audio cable and that sockets at both ends are perfectly alright. since windows doesn't require the audio cable, i had lost it and after somehow finding it, i found that during a hardware repair the delicate audio connector on the onboard sound chipset had one of the connecting pins broken, if i have to fix it, then i'll have to change entire mbd.

btw debian has this feature of "playing as ogg" that works for me
 
Old 06-15-2005, 04:39 PM   #7
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
arch has the same "play as ogg", bujt it also works as mp3 and wav.

xmms does have the digital audio extraction selection though.. if you have, say a laptop, and there's no audio cable, and there's nothing you can do about it.. it emulates the cable through software.
 
Old 06-15-2005, 11:16 PM   #8
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
does this help?

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,managed 0 0

There is a cable that goes from the CD reader to the motherboard, it inputs at CD in. Does this help, it's the fstab file or at least the text Let me know if I need something else. Thanks.
 
Old 06-15-2005, 11:28 PM   #9
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Your CDROM should have 3 diff cables on it... A flat ribbon cable (IDE), a power cable, (obvious), and analog audio, (small 4pin connector to Sound card). This is where CD's are piped to your soundcard. Check for those connections first. If you have installed a new CD you may have overlooked this cable connection.

KC
 
Old 06-15-2005, 11:33 PM   #10
moborichard
Member
 
Registered: Apr 2005
Location: columbus, oh
Distribution: fedora core
Posts: 30

Original Poster
Rep: Reputation: 15
I think I've got the hardware correctly configured

I've put together several computers and your description of the cables is accurate. I think I have things hooked up correctly. This is an onboard AC97 audio motherboard, so there is no sound card per se, but there is a CD in connector where the analog cable connects. Any clue about this fstab file? Someone asked for it before.
 
Old 06-16-2005, 12:10 AM   #11
edong23
Member
 
Registered: Apr 2005
Distribution: Slackware
Posts: 350

Rep: Reputation: 30
yeah. i agree with the others, you arent giving enough info. open a term and then open your player from there, also man your player to see if there are any extra verbosity options, but just opening the player from command line should work. see what the exact error is. is you player actually looking to your device? is you cdrom on /dev/hdc? is it /dev/hdd? maybe the player is looking for /dev/cdrom? if so your symlink could be wrong. ls -l /dev/cdrom and see if it is pointing at /dev/hdc (if that is indeed your drive) or change the cdrom directory setting on the player to /dev/hdc or whatever.
 
Old 06-16-2005, 04:13 AM   #12
pintooo15
Member
 
Registered: May 2004
Location: India
Distribution: openSUSE Tumbleweed and SLED 12 SP2
Posts: 94

Rep: Reputation: 31
i do agree with xmms being able to emulate audio cable and playing sound from audio cd's despite the absence of an audio cable as i tried with knoppix, but afaik since audio cd's don't have a filesystem to mount, if the player software is not able to detect we can't browse tracks and play them. moreover my system has 2 cdrom drives but the player only autodetects audio cd's from the master drive
 
Old 06-16-2005, 08:40 AM   #13
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
since you posted your fstab
I am wondering if you are tring to mount the disk?
don't do that
open a player and play it
 
Old 06-16-2005, 11:04 AM   #14
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
in your fstab (I think I was the one who asked for it...) it looks like your cdrom drive mounts at /media/cdburner. If you use XMMS, make sure to point it to the device that you are using (/dev/hdc) and not the mount folder.

As everyone has said, don't mount the cdrom, all you have to do is open the player and play it. If you try to mount it you'll get an error about the filesystem, as there is NO filesystem on the disc. Just make suer whatever player you use is pointed to your optical device.
 
Old 06-16-2005, 12:05 PM   #15
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
I was wondering about this myself? Would I just execute

Code:
xmms /dev/cdrom
?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
why i can't play my CD audio mamasmoe DamnSmallLinux 1 08-12-2004 07:31 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 04:23 AM
Can't play CD Audio morrolan Linux - Software 3 01-05-2004 08:55 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM
play audio cd bfkeats Linux - General 4 02-06-2002 12:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration