LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-09-2006, 02:49 PM   #1
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
Question wlassistant permission change


I am running PCLOS Jr. on a Toshiba Tecra Laptop. I have to start my wireless connection with each boot. [not re-install, just restart]. I don't really mind this, but I would like to be able to access the wlassist without using the root password each time. I have used chgrp and chown to change groups and ownership to me and the command line tells me this was done, but the root password box still comes up each time that I access wlassist.

Could someone please tell me what else I need to do?

Thanks, zoey
 
Old 12-10-2006, 12:02 PM   #2
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 23, 24, RHL 5.2
Posts: 560

Rep: Reputation: 56
I can think of two options:

1)Place the necessary commands to start up your wireless connection in your /etc/rc.d/rc.local. This way when you boot it will automatically be started.

2)If you tried that and still have troubles, take a look at sudo. You can make an entry in the sudoers file to allow your regular user access to the wlassist command.

Bill
 
Old 12-10-2006, 09:42 PM   #3
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Original Poster
Rep: Reputation: 15
Thanks Bill.

This is what I put in /etc/rc.d/rc/local;
iwconfig ath0 essid router
iwconfig ath0 ap xxxxxxxxx <-------mac address of router
iwconfig ath0 key xxxxxxxxxx <-----wep key
dhclient ath0
It didn't work, but I probably didn't use the correct commands. The message that I get when the boot spins for awhile trying to connect to ath0 is; 'determining IP info for ath0 failed'.

I got into the sudoers file and it sure looked like a foreign language to me. I hadn't a clue what I should be doing in there.

zoey
 
Old 12-11-2006, 09:26 PM   #4
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 23, 24, RHL 5.2
Posts: 560

Rep: Reputation: 56
I'm sorry that I don't have experience with setting up a wireless connection using a script at login. I'm sure their are other people around that have done it before and it would probably be the ideal solution.

The documentation for sudoers makes it look worse than it is to give you access for running a command for which a normal user doesn't have access to. I recently set up my regular user so it can use mount and umount. Here is an example:

As root, enter the command visudo. This will take you into a vi editor used to modify the sudoers file. The nice thing about doing it this way is that the syntax of your entries will be checked when you save the file. The file should be pretty empty with several commented sections. Go to the bottom of the file where the User priviledge specification section starts.

In my example I entered the following:
Code:
barney    ALL=NOPASSWD,/bin/mount,/bin/umount
This will allow user barney to use the mount and umount commands from any host without entering a password. barney is the username, ALL means from any host, NOPASSWD doesn't ask for a password, and the commands you want to allow follow. They must include the full pathnames in order to work.

To use the mount or umount command barney would do the following.
Code:
sudo mount /mnt/cdrom
Obviously there are a lot more options and things you can do with sudo. This should get you started the quick way. If you run into any problems with using sudo, just ask.

Bill
 
Old 12-11-2006, 10:56 PM   #5
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Original Poster
Rep: Reputation: 15
Unhappy Vi

I managed to get into Vi as root and even got the All=NOPASSWD command entered, but then I couldn't figure out how to exit with the command entered into the file. I found some Vi info on the net, so I need to see if I can figure it out. I have never tried to use it before. Which mode should I be in to edit sudoers is it 'insert mode' or one of the others?

I am going to remove ath0 from boot at least until after Christmas and just use wl assistant. I need to do some things not computer related!

Thanks, zoey

Last edited by ~zoey~; 12-12-2006 at 09:07 AM.
 
Old 12-12-2006, 06:21 PM   #6
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 23, 24, RHL 5.2
Posts: 560

Rep: Reputation: 56
Here is the quick and dirty on the vi editor. This editor was developed
when keyboards did not have arrow keys or a numeric keypad. It is a little
difficult to learn at first, but once learned I found that I can move faster
than a gui type editor because my hands never leave the keyboard.

There are two modes command mode and insert mode. While in command mode
you can move around the document using the h, j, k, and l keys.
h - go left
j - go down
k - go up
l - go right

To go into insert mode you type an i. You will then be able to enter
text beginning at the cursor location.

To get back into command mode hit the ESC key. If you want to delete a
character, go into command mode and position the cursor over the character,
then type an x. To replace a character, position the cursor, type r and
then the character you want to replace it with. To replace a bunch of
characters type R and start typing.

To save a document, be in command mode and enter :wq for write quit. If
you mess things up totally and just want to leave without making changes
enter :q!. Finally if you want to exit and haven't made any changes
use :q.

There are of course many other commands and ways to do things in vi. If
you are interested in learning the vi editor there is a book by O'Reilly &
and Associates called, you guessed it, "Learning the vi Editor".

Bill
 
Old 12-13-2006, 10:31 AM   #7
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Original Poster
Rep: Reputation: 15
Thanks!

Thank you very much Bill, for all of your help. I appreciate it.

zoey
 
Old 12-13-2006, 06:43 PM   #8
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,241

Rep: Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325Reputation: 2325
FYI, in a lot of modern distros, vi is aliased to vim (vi improved), so you can use the arrow keys etc.
http://www.vim.org/htmldoc/help.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wlassistant says I don't have admin rights hrp2171 Ubuntu 0 12-06-2006 12:20 PM
Ubuntu wifi works through ifup/down, not knetworkmanager, wlassistant moonburn Linux - Wireless Networking 0 11-30-2006 10:47 PM
wifi-radar or wlassistant connect to wrong access poin adamsjw2 Linux - Wireless Networking 0 08-26-2006 11:45 AM
Can't change permission karpa Linux - Newbie 29 03-15-2006 06:20 PM
Need ACCESS to change files! Every time I try to change a setting,"Permission Denied" Balarabay1 SUSE / openSUSE 2 03-06-2006 10:54 AM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration