LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-07-2010, 08:21 PM   #1
maierh
LQ Newbie
 
Registered: Jan 2010
Location: Germany
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
wlan-problems slackware


Greetings.

Two days ago I managed to install slackware (-spent most time finding out how to do it without CD-drive).

But now I'm stuck. I can't get my w-lan running.

Here's some Data:
- Acer Travelmate TM8371-352G16n
(wlan-card: WiFi Link 5100)
- Slackware 13 64
- AccessPoint uses WPA2 with AES

Everytime I have to use:
Code:
ifconfig wlan0 up
because without, the wifi-button does nothing. Took me some time to figure this one out.

But then I can use
Code:
iwlist wlan0 scanning
just fine. (typed per hand and shortened):
Quote:
wlan0 Scan completed:
Cell 01 - Address: 00:...:BB
ESSID "correct ESSID"
Mode: Master
Channel: 'correct channel'
Frequency 2.467 GHz (Channel 10)
....
Encryption key: on
IE: Unknown: 000B574C414E2D393631463932
IE: Unknown: 010882848B0C12961824
IE: Unknown: 03010A
IE: Unknown: 0...4 (~300 chars)
IE: IEEE 802.11i/WPA2 Version1
Group Cipher: CCMP
Pairwise Ciphers (1): CCMP
Authentication Suites (1): PSK
IE: Unknown: 2A0100
IE: Unknown: 32043048606C
IE: Unknown: ... (~80 chars)
Bit Rates: 1 Mb/s; 2 Mb/s; ... ; 54Mb/s
Extra: tsf=000000021c258a14
Extra: Last beacon: 1556ms ago
IE: Unknown: ...

Code:
ifconfig
returns:
Quote:
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:...
TX packets: ...
RX bytes:0 (0.0 B)...

wlan0 Link encap:Ethernet HWaddr 00:22:fb:73:1f:aa
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 ...
...

wmaster0 Link encap:UNSPEC HWaddr 00-22-FB-73-1F-AA-00-...-00
UP BROADCAST MULTICAST MTU:1500 Metric:1
...
Here is my rc.inet1.conf (well the important part):
Quote:
# Config information for eth0:
#IPADDR[0]=""
...

# Config information for wlan
IFNAME[1]="wlan_home"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
#DHCP_HOSTNAME[1]="router_home"
DHCP_KEEPRESOLV[1]="yes"
DHCP_KEEPNTP[1]="yes"
DHCP_KEEPGW[1]="yes"
#DHCP_IPADDR[1]=""
WLAN_ESSID[1]=WLAN-961F92
WLAN_MODE[1]=Managed
WLAN_RATE[1]="54M auto"
WLAN_CHANNEL[1]="auto"
WLAN_KEY[1]="my_key in plain text"
WLAN_IWPRIV[1]="set AuthMode=WPA"PSK | set EncrypType=AES | set WPAPSK=my_key encrypted"
WLAN_WPA[1]="wpa_supplicant"
#WLAN_WPADRIVER[1]="ndiswrapper"
WLAN_WPACONF[1]="/etc/wpa_supplicant.conf" # helps maybe(?)
...
So basically everthing is commented out, except the wlan-part.
I'm not sure, if I can enter my key in plain text under WLAN_KEY, but I think thats not the problem here. The last line were added after I read a post, mentioning the "Failed to connect to wpa supplicant"-problem - didn't help.
EDIT: linuxquestions.org/questions/slackware-14/failed-to-connect-to-wpasupplicant-wpactrlopen-no-such-file-or-directory-611577/

Code:
wpa_cli
Quote:
Could not connect to wpa_supplicant -retrying
It takes for ever. So tryed crtl+alt+Esc, but finaly had to reboot.
(Makes it complicated, when you have to look up how to scroll up, restart,... but I'm getting the drift )

Quote:
wpa_cli wlan0
works fine, but:
Quote:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
So I searched a lot for "wpa_supplicant not found" and such, but did not come across something usefull.

I still don't get the whole plan, so I'm not even sure where to begin. I imagine something like this: The hardware was found and works fine with the preinstalled driver (e.g. no problems with scanning). Now the configuration for my network has to be looked up. Thats why I had to edit rc.inet1.conf .
But
Code:
ifconfig wlan_home
displays:
Quote:
error fetching interface information: Device not found
On the other hand wlan0 works.
Although I wrote IFNAME[1]="wlan_home" . I'm not sure how it is determined wich description is selected ([0] or [1] ...). First working one wins?
Anyway, I also added my key and ssid in /etc/wpa_supplicant.conf today, but the problem remains the same.

In KDE: System settings -> Network settings
No devices are detected/listed. Instead an error pops up: "Could not parse XML()." Maybe not 1:1 but something like this.

Found 'WPA_GUI' right now. Looks nice, but also no adapter I could choose.


Well... thats quite a first post.

Guidance is always appreciated.

PS.: alien.slackbook.org/dokuwiki/doku.php?id=slackware:network
was very helpful so far

Last edited by maierh; 01-08-2010 at 06:00 AM.
 
Old 01-07-2010, 08:48 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Hi, welcome to LQ!

Have a look at your /etc/wpasupplicant.conf ... I may be able to
give you more input once i get home to my notebook...



Cheers,
Tink
 
1 members found this post helpful.
Old 01-07-2010, 09:09 PM   #3
maierh
LQ Newbie
 
Registered: Jan 2010
Location: Germany
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Here is my etc/wpa_supplicant.conf (shortened)

Quote:
#This line enables the use of wpa_cli...
ctrl_interface=/var/run/wpa_supplicant
#by default only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapool_version=1
ap_scan=1
fast_reauth=1
#country=US

#WPA protected network, supply your own ESSID and WPAPSK here:
network={
scan_ssid=0
ssid="WLAN-961F92"
proto=WPA RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKP WEP104 WEP40
psk=0123456789abcdef...(64 hex-digits)
priority=10
}

#Plaintext connection...
network={
key_mgmt=none
priority=0
}
Thanks so far.
I'm going to bed, but you will hear from me tomrrow.

EDIT: Indeed, there is no /var/run/wpa_supplicant !


EDIT2:
Code:
wpa_supplicant -Dwext -wlan0 -c/etc/wpa_supplicant.conf -d
Quote:
Initializing interface 'wlan0' conf 'etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interaface='/var/run/wpa_supplicant'
ctrl_interface_group='0'
eapol_version=1
ap_scan=1
fast_reauth=1
Line 21: invalid cipher 'TKP'
Line 21: failed to parse group 'CCMP TKP WEP104 WEP40'.
Line 24: failed to parse network block.
Priority group 0
id=1 ssid=##
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
Failed to add interface wlan0
Cancelling scan request
Cancelling authentication timeout
It looks the same, when using 'wlan_home' instead of 'wlan0'.

EDIT3:
Well, it was a typo. (TKP ? obviously TKIP)
Now "wpa_supplicant -Dwext" takes a LOT of time at
Quote:
...interface 'wlan0' added
EAPOL: startWhen --> 0
EAPOL: disable timer tick
Had to reboot.

Last edited by maierh; 01-08-2010 at 08:03 PM.
 
Old 01-08-2010, 08:02 PM   #4
maierh
LQ Newbie
 
Registered: Jan 2010
Location: Germany
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Lightbulb

Out of curiosity I tried to run wpa_supplicant after startx in the terminal. It worked. WPA-GUI detected it right away. Feels like avoiding the problem; But hey! - internet \°u°/

Still can't configure anything under 'System Settings' -> 'Network Settings' ("Could not parse the XML file()."). I have to use wlan0 - no matter what (instead of wlan_home). Some issues with the display after logout (Maybe resolution?). Backspace in vi behaves strangly.

For now I will try to fix these on my own, but I have a feeling I'm not posting the last time. : D

'Till then a good time.

Last edited by maierh; 01-08-2010 at 08:23 PM.
 
Old 01-09-2010, 07:18 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Just a suggestion, but many people find wicd a much easier wireless manager to deal with than most others. You'll find a package in the Slackware /extra directory of your install disc.

Quote:
Backspace in vi behaves strangly.
Have a look at nano as an alternative text editor.
 
1 members found this post helpful.
Old 01-09-2010, 08:38 AM   #6
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,204
Blog Entries: 3

Rep: Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433
Hi,

Just curious? Why do you insist on using 'IFNAME[1]="wlan_home" ' as the device name?

The norm would be IFNAME[1]="wlan".

As to the 'KDE' GUI, I would rely on the 'cli' as it would be less trouble when setting up system devices.

 
Old 01-10-2010, 05:45 AM   #7
maierh
LQ Newbie
 
Registered: Jan 2010
Location: Germany
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
A second setting was planned: wlan_uni (-versity). So I thought, it might be a good idea to differ from beginning.
Well, Since I do not reside on campus, I could keep it the way it is. But the very fact, that it's not as I wanted to be, makes me to do it. Especially when there is a feature IFNAME.
But for now I focus on my display-issues.
 
Old 01-10-2010, 08:20 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,204
Blog Entries: 3

Rep: Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433
Hi,

I suggest that you give 'wicd-1.6.2.2_x86_64' a try. This will allow you to control switch between networks without modifying your basic system. If you do decide to use 'wicd' then be sure to revert the '/etc/rc.d/rc.inet1.conf' to the original install state.


The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware 10.1 wlan ding Linux - Wireless Networking 2 06-23-2005 12:44 PM
wlan and slackware 10 zyrtech Slackware 0 06-26-2004 01:29 PM
wlan-ng problems (senao/engenius wlan usb adapter) poo bear Linux - Wireless Networking 6 05-05-2004 05:54 PM
Newbie's slackware 9.0 and wlan problems mpapet Linux - Wireless Networking 1 11-19-2003 06:56 AM
WLAN in Slackware 9.1. Help! chump_ Linux - Wireless Networking 3 11-07-2003 04:16 PM


All times are GMT -5. The time now is 10:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration