LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   wlan-problems slackware (http://www.linuxquestions.org/questions/linux-newbie-8/wlan-problems-slackware-780729/)

maierh 01-07-2010 08:21 PM

wlan-problems slackware
 
Greetings. :hattip:

Two days ago I managed to install slackware (-spent most time finding out how to do it without CD-drive).

But now I'm stuck. I can't get my w-lan running.

Here's some Data:
- Acer Travelmate TM8371-352G16n
(wlan-card: WiFi Link 5100)
- Slackware 13 64
- AccessPoint uses WPA2 with AES

Everytime I have to use:
Code:

ifconfig wlan0 up
because without, the wifi-button does nothing. Took me some time to figure this one out.

But then I can use
Code:

iwlist wlan0 scanning
just fine. (typed per hand and shortened):
Quote:

wlan0 Scan completed:
Cell 01 - Address: 00:...:BB
ESSID "correct ESSID"
Mode: Master
Channel: 'correct channel'
Frequency 2.467 GHz (Channel 10)
....
Encryption key: on
IE: Unknown: 000B574C414E2D393631463932
IE: Unknown: 010882848B0C12961824
IE: Unknown: 03010A
IE: Unknown: 0...4 (~300 chars)
IE: IEEE 802.11i/WPA2 Version1
Group Cipher: CCMP
Pairwise Ciphers (1): CCMP
Authentication Suites (1): PSK
IE: Unknown: 2A0100
IE: Unknown: 32043048606C
IE: Unknown: ... (~80 chars)
Bit Rates: 1 Mb/s; 2 Mb/s; ... ; 54Mb/s
Extra: tsf=000000021c258a14
Extra: Last beacon: 1556ms ago
IE: Unknown: ... :scratch:

Code:

ifconfig
returns:
Quote:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:...
TX packets: ...
RX bytes:0 (0.0 B)...

wlan0 Link encap:Ethernet HWaddr 00:22:fb:73:1f:aa
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 ...
...

wmaster0 Link encap:UNSPEC HWaddr 00-22-FB-73-1F-AA-00-...-00
UP BROADCAST MULTICAST MTU:1500 Metric:1
...
Here is my rc.inet1.conf (well the important part):
Quote:

# Config information for eth0:
#IPADDR[0]=""
...

# Config information for wlan
IFNAME[1]="wlan_home"
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
#DHCP_HOSTNAME[1]="router_home"
DHCP_KEEPRESOLV[1]="yes"
DHCP_KEEPNTP[1]="yes"
DHCP_KEEPGW[1]="yes"
#DHCP_IPADDR[1]=""
WLAN_ESSID[1]=WLAN-961F92
WLAN_MODE[1]=Managed
WLAN_RATE[1]="54M auto"
WLAN_CHANNEL[1]="auto"
WLAN_KEY[1]="my_key in plain text"
WLAN_IWPRIV[1]="set AuthMode=WPA"PSK | set EncrypType=AES | set WPAPSK=my_key encrypted"
WLAN_WPA[1]="wpa_supplicant"
#WLAN_WPADRIVER[1]="ndiswrapper"
WLAN_WPACONF[1]="/etc/wpa_supplicant.conf" # helps maybe(?)
...
So basically everthing is commented out, except the wlan-part.
I'm not sure, if I can enter my key in plain text under WLAN_KEY, but I think thats not the problem here. The last line were added after I read a post, mentioning the "Failed to connect to wpa supplicant"-problem - didn't help.
EDIT: linuxquestions.org/questions/slackware-14/failed-to-connect-to-wpasupplicant-wpactrlopen-no-such-file-or-directory-611577/

Code:

wpa_cli
Quote:

Could not connect to wpa_supplicant -retrying
It takes for ever. So tryed crtl+alt+Esc, but finaly had to reboot.
(Makes it complicated, when you have to look up how to scroll up, restart,... but I'm getting the drift :))

Quote:

wpa_cli wlan0
works fine, but:
Quote:

Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
So I searched a lot for "wpa_supplicant not found" and such, but did not come across something usefull.

I still don't get the whole plan, so I'm not even sure where to begin. I imagine something like this: The hardware was found and works fine with the preinstalled driver (e.g. no problems with scanning). Now the configuration for my network has to be looked up. Thats why I had to edit rc.inet1.conf .
But
Code:

ifconfig wlan_home
displays:
Quote:

error fetching interface information: Device not found
On the other hand wlan0 works.
Although I wrote IFNAME[1]="wlan_home" . I'm not sure how it is determined wich description is selected ([0] or [1] ...). First working one wins?
Anyway, I also added my key and ssid in /etc/wpa_supplicant.conf today, but the problem remains the same.

In KDE: System settings -> Network settings
No devices are detected/listed. Instead an error pops up: "Could not parse XML()." Maybe not 1:1 but something like this.

Found 'WPA_GUI' right now. Looks nice, but also no adapter I could choose.


Well... thats quite a first post. :)

Guidance is always appreciated.

PS.: alien.slackbook.org/dokuwiki/doku.php?id=slackware:network
was very helpful so far

Tinkster 01-07-2010 08:48 PM

Hi, welcome to LQ!

Have a look at your /etc/wpasupplicant.conf ... I may be able to
give you more input once i get home to my notebook...



Cheers,
Tink

maierh 01-07-2010 09:09 PM

Here is my etc/wpa_supplicant.conf (shortened)

Quote:

#This line enables the use of wpa_cli...
ctrl_interface=/var/run/wpa_supplicant
#by default only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapool_version=1
ap_scan=1
fast_reauth=1
#country=US

#WPA protected network, supply your own ESSID and WPAPSK here:
network={
scan_ssid=0
ssid="WLAN-961F92"
proto=WPA RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKP WEP104 WEP40
psk=0123456789abcdef...(64 hex-digits)
priority=10
}

#Plaintext connection...
network={
key_mgmt=none
priority=0
}
Thanks so far.
I'm going to bed, but you will hear from me tomrrow. :)

EDIT: Indeed, there is no /var/run/wpa_supplicant !


EDIT2:
Code:

wpa_supplicant -Dwext -wlan0 -c/etc/wpa_supplicant.conf -d
Quote:

Initializing interface 'wlan0' conf 'etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interaface='/var/run/wpa_supplicant'
ctrl_interface_group='0'
eapol_version=1
ap_scan=1
fast_reauth=1
Line 21: invalid cipher 'TKP'
Line 21: failed to parse group 'CCMP TKP WEP104 WEP40'.
Line 24: failed to parse network block.
Priority group 0
id=1 ssid=##
Failed to read or parse configuration '/etc/wpa_supplicant.conf'.
Failed to add interface wlan0
Cancelling scan request
Cancelling authentication timeout
It looks the same, when using 'wlan_home' instead of 'wlan0'.

EDIT3:
Well, it was a typo. (TKP ? obviously TKIP) :doh:
Now "wpa_supplicant -Dwext" takes a LOT of time at
Quote:

...interface 'wlan0' added
EAPOL: startWhen --> 0
EAPOL: disable timer tick
Had to reboot.

maierh 01-08-2010 08:02 PM

Out of curiosity I tried to run wpa_supplicant after startx in the terminal. It worked. WPA-GUI detected it right away. Feels like avoiding the problem; But hey! - internet \°u°/

Still can't configure anything under 'System Settings' -> 'Network Settings' ("Could not parse the XML file()."). I have to use wlan0 - no matter what (instead of wlan_home). Some issues with the display after logout (Maybe resolution?). Backspace in vi behaves strangly.

For now I will try to fix these on my own, but I have a feeling I'm not posting the last time. : D

'Till then a good time. :hattip:

Hangdog42 01-09-2010 07:18 AM

Just a suggestion, but many people find wicd a much easier wireless manager to deal with than most others. You'll find a package in the Slackware /extra directory of your install disc.

Quote:

Backspace in vi behaves strangly.
Have a look at nano as an alternative text editor.

onebuck 01-09-2010 08:38 AM

Hi,

Just curious? Why do you insist on using 'IFNAME[1]="wlan_home" ' as the device name?

The norm would be IFNAME[1]="wlan".

As to the 'KDE' GUI, I would rely on the 'cli' as it would be less trouble when setting up system devices.

:hattip:

maierh 01-10-2010 05:45 AM

A second setting was planned: wlan_uni (-versity). So I thought, it might be a good idea to differ from beginning.
Well, Since I do not reside on campus, I could keep it the way it is. But the very fact, that it's not as I wanted to be, makes me to do it. Especially when there is a feature IFNAME.
But for now I focus on my display-issues.

onebuck 01-10-2010 08:20 AM

Hi,

I suggest that you give 'wicd-1.6.2.2_x86_64' a try. This will allow you to control switch between networks without modifying your basic system. If you do decide to use 'wicd' then be sure to revert the '/etc/rc.d/rc.inet1.conf' to the original install state.

:hattip:
The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!


All times are GMT -5. The time now is 08:18 AM.