LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2007, 05:15 AM   #1
mckheuneedshelp
Member
 
Registered: Oct 2007
Posts: 52

Rep: Reputation: 15
Arrow "WLAN interface" [FAILED] @ boot


every time i boot up , it takes ages .
How can i (replace,disable,repair) "wlan interface"

thnx
 
Old 12-29-2007, 06:36 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Putting your distro in the User CP would help. You may have your wireless configured for "on boot" and booting doesn't finish until it times out. Post the entry for "sudo /sbin/lspci" for your wireless device. That info is needed to find out which controller you wireless device uses. This will determine the driver you need. "sudo /sbin/lsmod" will show the modules loaded, one or more of which are related to wireless. If the device is configured and working "/usr/sbin/iwlist scan" should list APs that are in range. If you see a list of Access Points, then you may just need to configure the wpa_psk encryption. But your error message indicates a problem with the device.
 
Old 12-29-2007, 08:22 AM   #3
mckheuneedshelp
Member
 
Registered: Oct 2007
Posts: 52

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
Putting your distro in the User CP would help. You may have your wireless configured for "on boot" and booting doesn't finish until it times out. Post the entry for "sudo /sbin/lspci" for your wireless device. That info is needed to find out which controller you wireless device uses. This will determine the driver you need. "sudo /sbin/lsmod" will show the modules loaded, one or more of which are related to wireless. If the device is configured and working "/usr/sbin/iwlist scan" should list APs that are in range. If you see a list of Access Points, then you may just need to configure the wpa_psk encryption. But your error message indicates a problem with the device.
sudo /sbin/lspci
Code:
sudo: /sbin/lspci: command not found
sudo /sbin/lsmod
Code:
Module                  Size  Used by
parport_pc             27652  0
ppdev                   9380  0
parport                36392  2 parport_pc,ppdev
nls_iso8859_1           4288  1
nls_cp437               5952  1
vfat                   13280  1
fat                    53148  1 vfat
fuse                   44404  1
ndiswrapper           190384  0
forcedeth              41220  0
snd_seq_dummy           3908  0
snd_seq_oss            32512  0
snd_seq_midi_event      7616  1 snd_seq_oss
snd_seq                52272  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          8268  3 snd_seq_dummy,snd_seq_oss,snd_seq
af_packet              22120  2
snd_pcm_oss            43072  0
ipv6                  257888  12
snd_mixer_oss          16608  1 snd_pcm_oss
snd_hda_intel          19320  2
snd_hda_codec         163072  1 snd_hda_intel
snd_pcm                76868  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              22884  2 snd_seq,snd_pcm
snd_page_alloc         10152  2 snd_hda_intel,snd_pcm
snd                    52708  13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,
snd_mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
soundcore               9824  1 snd
video                  15108  0
thermal                13544  0
sbs                    14372  0
i2c_ec                  5120  1 sbs
fan                     4804  0
container               4448  0
button                  6640  0
battery                 9636  0
ac                      5188  0
ide_cd                 39712  0
cdrom                  36928  1 ide_cd
binfmt_misc            11912  1
loop                   16328  0
dm_mirror              21616  0
dm_mod                 56440  1 dm_mirror
cpufreq_ondemand        6956  0
cpufreq_conservative     7592  0
cpufreq_powersave       1920  0
powernow_k8            14880  0
freq_table              4960  1 powernow_k8
processor              28776  2 thermal,powernow_k8
amd64_agp              12644  0
agpgart                32424  1 amd64_agp
nvram                   9000  0
martian_dev            19156  0
mmc_block               8136  0
sdhci                  18476  0
mmc_core               24448  2 mmc_block,sdhci
8250_pci               21120  0
ohci1394               35152  0
ieee1394              297848  1 ohci1394
bttv                  172308  0
video_buf              25220  1 bttv
ir_common              28196  1 bttv
compat_ioctl32          1472  1 bttv
i2c_algo_bit            9288  1 bttv
btcx_risc               5096  1 bttv
tveeprom               15056  1 bttv
i2c_core               21376  4 i2c_ec,bttv,i2c_algo_bit,tveeprom
videodev               24960  1 bttv
v4l1_compat            14148  1 videodev
v4l2_common            23328  2 bttv,videodev
usbmouse                5696  0
usbhid                 51712  0
pcmcia                 37580  0
firmware_class         10112  2 bttv,pcmcia
yenta_socket           26700  1
rsrc_nonstatic         13792  1 yenta_socket
pcmcia_core            40244  3 pcmcia,yenta_socket,rsrc_nonstatic
capability              5000  0
commoncap               7360  1 capability
ehci_hcd               32488  0
ohci_hcd               20516  0
usbcore               127364  6 ndiswrapper,usbmouse,usbhid,ehci_hcd,ohci_hcd
evdev                   9888  2
joydev                  9920  0
sd_mod                 21024  4
sata_nv                11172  3
libata                100468  1 sata_nv
scsi_mod              133928  2 sd_mod,libata
*****************

and my internet works fine ... its just the booting that takes too long ...

Could i change the timeout time to 15sec ?
(that should be long enough for the other processes)
 
Old 12-29-2007, 02:31 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
I don't know which distro you are using. Look in the "man ifcfg" manpage under startmode.
Code:
       STARTMODE {manual*|auto|hotplug|ifplugd|nfsroot|off}
              Choose when the interface should be set up.
              manual Interface will be set up if ifup is called manually (without option boot or hotplug)
              auto   Interface will be set up as soon as it is available (and service network was started).  This  either  happens  at
                     boot  time when network is starting or via hotplug when a interface is added to the system (by adding a device or
                     loading a driver). To be backward compliant onboot, on and boot are aliases for auto.
              hotplug
                     This mode is nearly the same as auto.  The difference between auto and hotplug is that the latter does  not  make
                     rcnetwork fail if the interface cannot be brought up.
              ifplugd
                     The  interface  will  be controlled from ifplugd. At initial ifup only iflugd will be started for this interface.
                     Then if ifplugd detects a link if calls ifup again which  finally  sets  the  interface  up.  See  also  variable
                     IFPLUGD_PRIORITY below.
              nfsroot
                     Nearly  like auto, but interfaces with this startmode will never be shut down via rcnetwork stop.  ifdown <inter‐
                     face> still works. Use this when you use a root filesystem via network.
              off    Will never be activated.
Also, if you have a network mount in /etc/fstab, add the _netdev option to defer an attempt to mount it until after the network is started. I don't know how you would change the timeout. Maybe study your ifup script.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ORiNOCO WLAN card not working - "failed to allocate resource" hauneboo Linux - Laptop and Netbook 1 11-29-2005 10:08 AM
boot process freezes at "Probing IDE interface ide0..." drowstar Mandriva 8 11-03-2004 02:43 AM
Virtual PC 2004 and VWware Workstation - "interface eth0 [failed]" abijahboaz Linux - Newbie 8 10-16-2004 08:53 PM
"Bringing up interface eth0: failed" pikatu Linux - Networking 7 10-03-2004 03:25 AM
"Bringing up interface eth0: failed" on 3com NIC zoinkedzonker Linux - Networking 3 08-17-2004 01:18 AM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration