LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2009, 10:35 PM   #1
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Rep: Reputation: Disabled
Question Wireless wont connect


my wireless card is 0c:00.0 Network controller: Atheros Communications Inc. AR928X Wireless NetworkAdapter (PCI-Express) (rev 01) and I have kubuntu 9.04 on a Inspiron 1545 Dell. I can seen my wireless connection but when I go to connect to it it fails, this happens to me when theres no security or security. I've only been on linux for a few monthis now so I'm not sure what other information to give to you so feel free to ask.

Thanks for your time.
 
Old 05-02-2009, 03:50 AM   #2
kb2tfa
Member
 
Registered: Oct 2006
Location: Philadelphia PA
Posts: 154

Rep: Reputation: 16
i'm not sure if I can help. I have the same OS with a dell laptop.

Mine goes in and out, but it did it under windows.

some quick questions although might sound dumb, but bear with me.

Has it ever worked? ( mine didn't until i upgraded to 9.04, but you're running the upgrade )

You have no security, I assume you don't have any MAC filter on then, so that shouldn't be it.

If it does or has worked but at times you can't connect, it might be interference. for example my router is the same MHz as my landline cordless, and everytime the phone rings my wireless kicks out.

I assume you can log into your router with a wire lan.

I guess a lot for me would be if it's ever worked with your linux, or just went out on you.
 
Old 05-02-2009, 04:58 AM   #3
amishtechie
Member
 
Registered: Apr 2004
Location: Oberlin, OH
Distribution: Slackware
Posts: 119

Rep: Reputation: 16
Could you post the output from the following command?
Code:
dmesg | grep -e ath
 
Old 05-02-2009, 07:14 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,766
Blog Entries: 27

Rep: Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081
Hi,

Quote:
Originally Posted by kb2tfa View Post
<snip>
If it does or has worked but at times you can't connect, it might be interference. for example my router is the same MHz as my landline cordless, and everytime the phone rings my wireless kicks out.
<snip>

Switch channels for router and WLAN equipment.
 
Old 05-02-2009, 07:21 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,766
Blog Entries: 27

Rep: Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081
Hi,
Quote:
Originally Posted by TweakedEh View Post
my wireless card is 0c:00.0 Network controller: Atheros Communications Inc. AR928X Wireless NetworkAdapter (PCI-Express) (rev 01) and I have kubuntu 9.04 on a Inspiron 1545 Dell. I can seen my wireless connection but when I go to connect to it it fails, this happens to me when theres no security or security. I've only been on linux for a few monthis now so I'm not sure what other information to give to you so feel free to ask.

Thanks for your time.
Post from the cli (console/terminal) as root the output for 'ifconfig -a', iwlist [your_device] scan. If your are using security then no need to post your security information.
 
Old 05-02-2009, 11:37 AM   #6
zedmelon
Member
 
Registered: Jun 2004
Location: colorado, USA
Distribution: slack, oBSD
Posts: 119

Rep: Reputation: 22
amishtechie (one of the coolest nicks I've seen in a long time)

Last edited by zedmelon; 05-02-2009 at 01:58 PM. Reason: oops device name was reason for grep. removing technical confusion
 
Old 05-02-2009, 01:14 PM   #7
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: Disabled
@ kb2tfa: I just took Vista off and installed kubuntu Jaunty 64Bit. Wireless hasn't worked what so ever with me, though it worked just fine in Vista. I've been looking on Google for the past 3 days and it's led me to four reinstalls and a lot of headaches.

Quote:
Originally Posted by amishtechie View Post
Could you post the output from the following command?
Code:
dmesg | grep -e ath
Code:
andrews@Lappy:~$ dmesg | grep -e ath
[    3.292331] device-mapper: multipath: version 1.0.5 loaded
[    3.292334] device-mapper: multipath round-robin: version 1.0.0 loaded
[   10.395472] ath9k: 0.1
[   10.395517] ath9k 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   10.395529] ath9k 0000:0c:00.0: setting latency timer to 64
[   10.829103] phy0: Selected rate control algorithm 'ath9k_rate_control'
[   11.075521] Registered led device: ath9k-phy0:radio
[   11.075540] Registered led device: ath9k-phy0:assoc
[   11.075553] Registered led device: ath9k-phy0:tx
[   11.075566] Registered led device: ath9k-phy0:rx
andrews@Lappy:~$
Quote:
Originally Posted by onebuck View Post
Hi,


Post from the cli (console/terminal) as root the output for 'ifconfig -a', iwlist [your_device] scan. If your are using security then no need to post your security information.

$ sudo ifconfig -a
Code:
[sudo] password for andrews:     
eth0      Link encap:Ethernet  HWaddr 00:23:ae:2e:32:4b  
          inet addr:192.168.1.75  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:aeff:fe2e:324b/64 Scope:Link             
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1             
          RX packets:2255 errors:0 dropped:0 overruns:0 frame:0          
          TX packets:1872 errors:0 dropped:0 overruns:0 carrier:0        
          collisions:0 txqueuelen:1000                                   
          RX bytes:1558833 (1.5 MB)  TX bytes:292721 (292.7 KB)          
          Interrupt:18                                                   

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host     
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                            
          RX bytes:2980 (2.9 KB)  TX bytes:2980 (2.9 KB)       

pan0      Link encap:Ethernet  HWaddr 9a:77:61:3e:02:b7  
          BROADCAST MULTICAST  MTU:1500  Metric:1        
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                           
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wlan0     Link encap:Ethernet  HWaddr 00:22:5f:7c:72:2b  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                        
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wmaster0  Link encap:UNSPEC  HWaddr 00-22-5F-7C-72-2B-00-00-00-00-00-00-00-00-00-00                                                                             
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                    
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                    
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                  
          collisions:0 txqueuelen:1000                                          
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
$ sudo iwlist wlan0 scan
Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:1B:5B:75:A1:31
                    ESSID:"humm"
                    Mode:Master
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/100  Signal level:-50 dBm  Noise level=-95 dBm
                    Encryption key:on
                    IE: Unknown: 000468756D6D
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 0706555320010B14
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000001ff4595c6c
                    Extra: Last beacon: 2448ms ago

Last edited by TweakedEh; 05-02-2009 at 01:29 PM. Reason: Add another reply
 
Old 05-02-2009, 02:14 PM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,766
Blog Entries: 27

Rep: Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081
Hi,

Your 'Wlan' device is there. How are you attempting to get your IP for the Wlan device? Your eth0 does get an IP assignment.
 
Old 05-02-2009, 05:31 PM   #9
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by onebuck View Post
Hi,

Your 'Wlan' device is there. How are you attempting to get your IP for the Wlan device? Your eth0 does get an IP assignment.
um, doesn't it do it all by it's self or do I have to fill in the IP, MAC address and all that?

What I do is I just click on the plug and it shows my wireless connection 'humm' once I click on that it takes me to the "wireless Security" tab. The other two tabs are called "Wireless" and "IP Address" but I have just been ignoring them. Could my problem be a human error or a driver error?

Last edited by TweakedEh; 05-02-2009 at 05:42 PM. Reason: Add links
 
Old 05-03-2009, 07:11 AM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,766
Blog Entries: 27

Rep: Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081
Hi,

Any system changes for any distribution should be performed as root. The kernel has recognized the device.

I would setup a static IP first, do as root from cli;

Code:
~#ifconfig -a                      #get recognized devices
~#ifconfig wlan0 192.168.1.10      #set to a available IP
~#route add default gw 192.168.1.1 #set to your gateway
~#route -n                         #show the route table
~#ifconfig wlan0 up                #should be up already
~#ping 192.168.1.1                 #ping your gateway
~#ping 208.69.32.130               #google.com IP
~#ping google.com                  #test DNS, if fail then
                                   #check /etc/resolv.conf
You should have your '/etc/resolv.conf' setup with your 'ISP DNS' nameservers.

Code:
 sample '/etc/resolv.conf';

search 192.168.1.1           #     

nameserver xxx.xxx.xxx.xxx   #ISP DNS 'replace xxx.xxx.xxx.xxx
                             #with IP from your ISP
nameserver 4.2.2.1           #Verizon third level DNS
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
You should now be able to work with the Internet & LAN. To save the configuration you will need to setup your config files for your distribution. If you want 'DHCP' then you will need to setup the network as such.
 
Old 05-03-2009, 04:56 PM   #11
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: Disabled
I tried that and all it did was mess up my wired connection and wireless was still no good. So I reset and now my wired connection works but wireless still wont connect but I don't get an error message. I'll try again but I don't think it will work.


Code:
andrews@Lappy:~$ sudo ifconfig -a
[sudo] password for andrews:     
eth0      Link encap:Ethernet  HWaddr 00:23:ae:2e:32:4b  
          inet addr:192.168.1.75  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:aeff:fe2e:324b/64 Scope:Link             
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1             
          RX packets:2470 errors:0 dropped:0 overruns:0 frame:0          
          TX packets:1807 errors:0 dropped:0 overruns:0 carrier:0        
          collisions:0 txqueuelen:1000                                   
          RX bytes:1512933 (1.5 MB)  TX bytes:292945 (292.9 KB)          
          Interrupt:18                                                   

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host     
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:334 errors:0 dropped:0 overruns:0 frame:0
          TX packets:334 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                             
          RX bytes:22860 (22.8 KB)  TX bytes:22860 (22.8 KB)    

pan0      Link encap:Ethernet  HWaddr ae:18:a3:fa:46:34  
          BROADCAST MULTICAST  MTU:1500  Metric:1        
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                           
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wlan0     Link encap:Ethernet  HWaddr 00:22:5f:7c:72:2b  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                        
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wmaster0  Link encap:UNSPEC  HWaddr 00-22-5F-7C-72-2B-00-00-00-00-00-00-00-00-00-00                                                                               
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                     
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                   
          collisions:0 txqueuelen:1000                                           
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                                 

andrews@Lappy:~$ ifconfig wlan0 192.168.1.20
SIOCSIFADDR: Permission denied
SIOCSIFFLAGS: Permission denied
andrews@Lappy:~$ sudo ifconfig wlan0 192.168.1.20
andrews@Lappy:~$ sudo route add default gw 192.168.1.254
andrews@Lappy:~$ sudo route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 wlan0
andrews@Lappy:~$ sudo ifconfig wlan0 up
andrews@Lappy:~$ sudo ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
From 192.168.1.20 icmp_seq=1 Destination Host Unreachable
From 192.168.1.20 icmp_seq=2 Destination Host Unreachable
From 192.168.1.20 icmp_seq=3 Destination Host Unreachable
^Z
[1]+  Stopped                 sudo ping 192.168.1.254
andrews@Lappy:~$

Last edited by TweakedEh; 05-03-2009 at 05:36 PM.
 
Old 05-03-2009, 05:53 PM   #12
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,766
Blog Entries: 27

Rep: Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081Reputation: 2081
Hi,

You need to be root whenever you make system changes.
 
Old 05-03-2009, 06:38 PM   #13
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: Disabled
Code:
andrews@Lappy:/etc/apt$ su root                                                 
Password:                                                                       
root@Lappy:/etc/apt# ifconfig -a                                                
eth0      Link encap:Ethernet  HWaddr 00:23:ae:2e:32:4b                         
          inet6 addr: fe80::223:aeff:fe2e:324b/64 Scope:Link                    
          UP BROADCAST MULTICAST  MTU:1500  Metric:1                            
          RX packets:18512 errors:0 dropped:0 overruns:0 frame:0                
          TX packets:12195 errors:0 dropped:0 overruns:0 carrier:0              
          collisions:0 txqueuelen:1000                                          
          RX bytes:12692098 (12.6 MB)  TX bytes:1877654 (1.8 MB)                
          Interrupt:18                                                          

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host     
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:752 errors:0 dropped:0 overruns:0 frame:0
          TX packets:752 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                             
          RX bytes:52328 (52.3 KB)  TX bytes:52328 (52.3 KB)    

pan0      Link encap:Ethernet  HWaddr 9e:dc:c4:1e:2e:58  
          BROADCAST MULTICAST  MTU:1500  Metric:1        
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0                           
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wlan0     Link encap:Ethernet  HWaddr 00:22:5f:7c:72:2b  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                        
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)              

wmaster0  Link encap:UNSPEC  HWaddr 00-22-5F-7C-72-2B-00-00-00-00-00-00-00-00-00-00                                                                               
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                     
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0                   
          collisions:0 txqueuelen:1000                                           
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)                                 

root@Lappy:/etc/apt#
root@Lappy:/etc/apt# ifconfig wlan0 192.168.1.10
root@Lappy:/etc/apt# route add default gw 192.168.1.254
root@Lappy:/etc/apt# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 wlan0
root@Lappy:/etc/apt# ifconfig wlan0 up
root@Lappy:/etc/apt# ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
From 192.168.1.10 icmp_seq=1 Destination Host Unreachable
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable
From 192.168.1.10 icmp_seq=3 Destination Host Unreachable
From 192.168.1.10 icmp_seq=4 Destination Host Unreachable
From 192.168.1.10 icmp_seq=5 Destination Host Unreachable
From 192.168.1.10 icmp_seq=6 Destination Host Unreachable
^Z
[1]+  Stopped                 ping 192.168.1.254
root@Lappy:/etc/apt#
Wired connection gave out and still no wireless.
 
Old 05-04-2009, 01:31 AM   #14
amishtechie
Member
 
Registered: Apr 2004
Location: Oberlin, OH
Distribution: Slackware
Posts: 119

Rep: Reputation: 16
Is you router configured to assign ip addresses via dhcp? It is typically the default setting. If so, you are assigning a static ip to your wireless device.

Last edited by amishtechie; 05-04-2009 at 01:34 AM. Reason: more info
 
Old 05-04-2009, 05:35 PM   #15
TweakedEh
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by amishtechie View Post
Is you router configured to assign ip addresses via dhcp? It is typically the default setting. If so, you are assigning a static ip to your wireless device.

Connection Type: Direct IP (DHCP or Static)
Internet Address: XX.XXX.XXX.XXX
Subnet Mask: 255.255.192.0
Default Gateway: 75.157.64.254
Primary Domain Name Server: 75.154.133.100
Secondary Domain Name Server: 75.154.133.68
Domain:
Maximum Transmission Unit (MTU): 1500
Gateway Ping: Successful
DNS Communication: Successful
Configuration Server Post: Successful
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless issue with T61-sees network but wont connect Viper Chief Mandriva 1 07-28-2008 07:52 PM
wireless driver wont install,ethernet wont work Reanimator Linux - Newbie 4 05-05-2008 08:22 AM
wireless wont connect sid ibm T61 GhostCow Debian 0 10-30-2007 05:25 PM
Gaim wont connect with wireless? Cereal765 Linux - Software 4 05-10-2007 09:23 PM
Wireless drops and wont re-connect anibis Linux - Wireless Networking 1 07-20-2006 07:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration