LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-13-2008, 07:39 PM   #1
rover8898
LQ Newbie
 
Registered: Dec 2008
Posts: 7

Rep: Reputation: 0
Wireless usb key not recognized by Linux


Hello all (again)

I have now ndiswrapper working fine, however I am still unable to get my usb wireless key working.
For some reason, I think linux is not recognizing the device.

Here is what I did do far:

1. Installed ndiswrapper 1.53 - worked fine
2. Installed the WinXP driver for my usb wireless key (worked fine)
3. Problem! : hardware not recognized!


Code:
[root@localhost ~]# lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 002: ID 22b8:4810 Motorola PCS Triplet GSM Phone (storage)
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 2001:3704 D-Link Corp. [hex] DWL-G122 802.11g rev. A2
[root@localhost ~]#

Code:
[root@localhost ~]# ndiswrapper -l
prisma02 : driver installed
        device (2001:3704) present
[root@localhost ~]#
As can be seen by the "ndiswrapper -l" command, only the driver is listed as present. The hardware is not mentioned to be present. According to the ndiswrapper's INSTALL how-to file, the "hardware present" message should be also be outputted with the "ndiswrapper -l" command.

Any help in figuring out why the hardware is not being detected will be much appreciated.

USB key: DWL-G122 rev A2
Linux distro: RHEL 5.1 client

Thanks
-Roger



Other data that might prove useful for debugging:

After much frustration, I realized that the hardware must not be seen when I tried to change the essid of my wlan0 wireless network without any sucess. That was what prompted me to go over again the ndiswrapper INSTALL file and made me realize that the "hardware present" message had never gotten displayed.

Code:
[root@localhost ~]# iwconfig wlan0 essid default
[root@localhost ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Bit Rate:2 Mb/s   Tx-Power:32 dBm   
          RTS thr:2432 B   Fragment thr:2432 B   
          Encryption key:8012-ABF5-AA   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@localhost ~]#
--> the essid did not change

(P.S the encryption key was manually changed by me)


Also, the "dmesg" command's output is as following

Code:
[root@localhost ~]# dmesg
Linux version 2.6.18-53.el5 (brewbuilder@hs20-bc2-3.build.redhat.com) (gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)) #1 SMP Wed Oct 10 16:34:02 EDT 2007
BIOS-provided physical RAM map:
...
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] writeback test succeeded in 1 usecs
ndiswrapper version 1.53 loaded (smp=yes, preempt=no)
usb 2-2: reset full speed USB device using uhci_hcd and address 2
ndiswrapper: driver prisma02 (D-Link,08/05/2004, 3.00.22.0) loaded
wlan0: ethernet device 00:11:95:c3:dd:27 using NDIS driver: prisma02, version: 0x30016, NDIS version: 0x501, vendor: 'D-Link AirPlus G DWL-G122 Wireless USB Adapter(rev.A2)', 2001:3704.F.conf
wlan0: encryption modes supported: WEP; TKIP with WPA; AES/CCMP with WPA
usbcore: registered new driver ndiswrapper
SELinux: initialized (dev sda1, type vfat), uses genfs_contexts
ADDRCONF(NETDEV_UP): wlan0: link is not ready
[root@localhost ~]#
I truncated the output for purposes of clarity. Also, once again I see that the wlan0 is not functioning.


BTW, the LEDS on my usb key blink once every ~3-5 minutes. I imagine that means there is some activity on the usb key hardware side, but it may just be a side-effect of it having power. But at least the blinking indicates that the usb port must be functional.

Sidenote: If I recall correctly, the usb-key is usb-port specific on Windows XP. By usb-port specific, I mean that if I change the wireless usb-key's usb port to another one, I am prompted to re-install the driver. Can that perhaps shed some light on the problem?
 
Old 12-13-2008, 08:02 PM   #2
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
If you have access to the wireless router, it really helps to turn off security until you can get a basic open connection established, then work on the WPA or WEP or whatever.

It appears that there is a driver installed and functioning, but you have zero signal strength and no router association. Try iwlist scan (man iwlist) as root. This should show the access points detected. If you don't see yours, that's obviously a problem.

I assume you've checked for a native Linux driver for this wireless dongle. The USB devices tend to be more trouble than the PCMCIA or PCI type.
 
Old 12-13-2008, 08:39 PM   #3
rover8898
LQ Newbie
 
Registered: Dec 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Hello,

Thanks for the reply

Quote:
It appears that there is a driver installed and functioning, but you have zero signal strength and no router association. Try iwlist scan (man iwlist) as root. This should show the access points detected. If you don't see yours, that's obviously a problem.
Ok, here goes:

Code:
[root@localhost ~]# iwlist scan 
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

sit0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:13:46:08:0C:24
                    ESSID:"default"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:28/100  Signal level:-78 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=1
          Cell 02 - Address: 00:1E:C7:76:21:A1
                    ESSID:"BELL190"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.412 GHz (Channel 1)
                    Quality:7/100  Signal level:-91 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=1

[root@localhost ~]#
The "default" network is my wireless router's network. BELL190 is my neighbor's network.
So now I am utterly confused; it seems that the usb key is capable of prompting the available networks but Linux is unable to see it.


Quote:
I assume you've checked for a native Linux driver for this wireless dongle. The USB devices tend to be more trouble than the PCMCIA or PCI type.
There is no wireless driver for the Dlink DWL-G122 rev A2 wireless usb key. There is however linux drivers for the C1 and D1 revs.

-Roger
 
Old 12-14-2008, 04:27 AM   #4
padhi.sssu
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
i am new to the LINUX..i have wireless usb adaptor (Netgear WG 111v3) i downloaded ndiswrapper from sourceforce.net. using
make
make install
i tried to install the ndiswrapper 1.53.
i failed to make out whether it is installed or not.
i am using fedora 8;
using " /sbin/lsusb " i findout that usb device is connected & the chipset is rtl8187B(this i found from net).
tell me how to use this wirelss usb adapter...(using ndiswrapper & any other methods)
 
Old 12-14-2008, 04:33 AM   #5
padhi.sssu
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
plz explain

hello brother....you wrote that you successfully installed ndiswrapper 1.53.can you explain me step by step procedure how to install that in fedora 8.
 
Old 12-14-2008, 12:43 PM   #6
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
As I said in my first post, my best recommendation is to turn off security on your router and see if you can connect. The driver is installed and working.

You don't bother to tell us what Linux distro you are running, so it's hard to give specific advice. For Debian-derived distros, like Ubuntu, you will have a file in /etc/network/ called interfaces. This may need to be edited to bring the interface up automatically. man interfaces for more info, or just take a look at the file.

Turn off router security, read up at man iwconfig and man ifconfig and see if you can get a connection going through the command line. You may need to run your DHCP client to get an IP address.
 
Old 12-14-2008, 01:10 PM   #7
rover8898
LQ Newbie
 
Registered: Dec 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Distro info

Quote:
As I said in my first post, my best recommendation is to turn off security on your router and see if you can connect. The driver is installed and working.
Glad to hear that it's working. Also I will turn off the security.

Quote:
You don't bother to tell us what Linux distro you are running, so it's hard to give specific advice.
Sorry, about that. Distro: RHEL 5.1 client


Will try that.
Thanks for the advice

-Roger
 
Old 01-03-2009, 09:32 PM   #8
magpie05
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Rep: Reputation: 0
Hi,

Thanks for this thread. I'm facing a very similar set of circumstances trying to get my wireless usb adapter to work. I'm very new to Linux and using the Fedora dist. of Linux.

I used ndiswrapper to install the driver for my wireless usb which seems to have worked OK. The driver is installed and the device is associated with it. My iwlist scan can find my wireless network.

However when trying to set up the wireless connection through the network configuration manager, Linux does not seem to be able to find my wireless adapter. I'm selecting (from the menu) System > Administration > Network. Then at Network Configuration manager - New - Wireless Connection. Under the Wireless Card list only "Other Wireless Card" is displayed. It should display my card right?

Any solution to this? As I'm new to Linux I'm not sure of how to troubleshoot this through the command line.

Any help much appreciated.

Cheers.

BTW - for others who are also going through the procedure I found some pretty good doco (albeit related to the Ubuntu dist) at https://help.ubuntu.com/community/Wi...er/Ndiswrapper

Last edited by magpie05; 01-03-2009 at 09:35 PM.
 
Old 01-04-2009, 01:20 AM   #9
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
If you see your network in iwlist scan, your drivers are installed and working. It sounds more like a security/permissions issue, or a problem with network manager.

run ifconfig or iwconfig (as root) and see if you have an IP address assigned. If not, try running dhclient (or whatever Fedora uses) to try to get an IP address.

To be honest, I'm not a big fan of the Network Manager application. It's caused me a lot of problems and I generally set up the wireless configuration in /etc/network/interfaces file. But I'm running Debian and not Fedora.
 
Old 01-04-2009, 11:21 AM   #10
magpie05
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Rep: Reputation: 0
Thanks a lot for your advice!

I tried the iwconfig and ifconfig commands and didn't see any IP Address there. After running dhclient however I did eventually see an ip address in the ifconfig output for wlan0. However, I was still not able to connect through my browser.

Then I noticed that the configuration for wlan0 doesn't seem to be getting saved to the /etc/../.. directories (eth0 and lo are). I tried rebooting to see if the configuration was saved but it wasn't and I completely lost the wlan0 setup in ifconfig and iwconfig. I had to start back at running "modprobe ndiswrapper". Unfortunately now wlan0 doesn't appear at all in my ifconfig output, even after running dhclient.

I notice in my dhclient output that I get:
sbin/dhclient-script: configuration for wlan0 not found. Continuing with defaults.
/etc/sysconfig/network-scripts/network-functions: line 78: wlan0: No such file or directory.

I believe this is because the shell script can't find an ifcfg-wlan0 file in /etc/sysconfig/network-scripts. There is an ifcfg-eth0 and an ifcfg-lo file.

Could this be related to the permissioning you mentioned? Or do I need to manually create the configuration file for wlan0? Or am I missing out a setup step that's causing the config file to not be created?

NB. The listing for the network-scripts directory is:
drwxr-xr-x 2 root root 4096 2009-01-03 15:09 network-scripts

Thanks again!

Last edited by magpie05; 01-04-2009 at 11:23 AM.
 
Old 01-04-2009, 12:41 PM   #11
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Since I'm not familiar with Fedora network configuration, I can't help you much, I'm afraid. If you review man ifconfig and man iwconfig, you will see that you can configure the interface from the command line. This would at least allow you to experiment to get a working interface. Then you would need to set up the configuration or scripting file in Fedora that will automagically do the same thing every time the computer is started.

Actually, learning how to do configuration from the command line will help you a lot in the long run.
 
Old 01-04-2009, 08:06 PM   #12
magpie05
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Rep: Reputation: 0
Absolutely. Thanks for your help. You've definitely put me on the right track. I'll start there and see how I go.

Cheers!
 
Old 01-06-2009, 11:12 AM   #13
magpie05
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Rep: Reputation: 0
I finally had some success. Thanks to all.

The following commands (put in my /etc/rc.d/rc.local file) bring up the connection everytime I log in.

depmod -a
modprobe ndiswrapper
/sbin/iwconfig wlan0 key restricted MYHEXKEY essid "MY SSID"
/sbin/ifconfig wlan0 up
/sbin/dhclient wlan0

What's strange is that after a lot of different tries at this, I was able to set up Network Manager correctly, however it never seems to load the details to memory when I log in. So the above lines need to run in rc.local everytime. Don't know if that's normal, but right now I'm happy it works.

BTW - I recommend trying this in the command line first before putting in rc.local file to make sure it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Wireless NIC not recognized cmtsailor Linux - Wireless Networking 5 10-09-2007 09:11 AM
Airnet AWU154 Wireless USB key drivers/installation 3p1ph4ny Linux - Wireless Networking 1 09-07-2007 09:31 PM
Dlink DWG-122 USB Wireless Key Majnuun Linux - Wireless Networking 1 03-07-2007 03:06 PM
LXer: Using the Belkin USB Wireless G key under Linux LXer Syndicated Linux News 0 05-19-2006 02:03 PM
Wireless usb wg111 not recognized ? gonzojd7 Linux - Newbie 1 10-14-2005 03:23 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration