LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2008, 11:54 AM   #1
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Rep: Reputation: 15
Wireless Signal Selection


There are several wireless signals within reach of my laptop. I only want to use my wireless router, not the neighbors'. But my laptop always selects someone else's signal when I first power it on. How can I limit it to just my wireless signal? Ubuntu Feisty, Dell Ispiron. Thank you much. R-
 
Old 10-21-2008, 01:52 PM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
You need to set an SSID in your router, then configure the wireless to connect to that SSID.

Beyond that, have you any security set? If not, you need to do that also. It all depends on what your router supports. Change the default password and user to something you know, and not easily guessed. Take a look at your documentation, set up keys, they may be wep or wpa. If not, you are asking to be abused.

You need to set up your system to use the same keys. Lock out those that are not supposed to use your internet access.

You can also change things like the channel, however this is not secure. It just takes some one a few seconds to try different channels to get in, without keys.

If you need more help, post the make, model of the router. The doc is usually on a CD or DVD that came with the unit. You can usually find the doc online if you can not find it otherwise.
 
Old 10-21-2008, 02:08 PM   #3
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
It's a Linksys router. I have the password (WEP) set. It is secure.

In this neighborhood, some people have NON-secured routers. I used one of those (with the permission of the neighbor) while I was waiting for my ISP to connect my DSL. I have my own DSL now, and when I turn on the laptop, it connects to the neighbor's signal, instead of mine. I have to disconnect from the neighbor's and connect to mine. That's what I'm trying to change - have it connect to mine when I power on.

I had a similar problem at a coffee shop. I chose the signal of the coffee shop, but could not connect. Then I chose a different, unsecured, signal, and it did work. Whenever I went to that coffee shop again, it chose the first signal (the one of the coffee shop that did not work) instead of the second one I selected.

It's in the way this laptop chooses which signal to connect to. That's what I'd like to control.

R-
 
Old 10-21-2008, 04:53 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I would think that somewhere in NetworkManager you should be able to set a "default" SSID. If there isn't anything obvious, you might consider replacing it with wicd, which does allow you to set default SSIDs to connect to. In fact, you can set several.

Quote:
I have the password (WEP) set. It is secure.
If you're not already aware, WEP is not really secure. It keeps out the brain-dead idiots, but even the skiddies have pre-packaged tools to crack it these days.
 
Old 10-21-2008, 08:04 PM   #5
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Have you got the documentation for the router? If not, post the exact model.

Do you know how to connect to the router and configure it? SSID should be on one of the pages in the router.
 
Old 10-21-2008, 09:22 PM   #6
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
I have no documentation for it. None came with it. I won't be able to read the model number until tomorrow when I can take it outside into the sunlight, because the number is so small I can't see it.

I remember though, it is a WRxxxx something. Linsys.

I went to the basic setup website and changed it to WPA Personal. It assigned a password, a long text string. I copied the text string and then pasted it into the text box when I tried to log on. But it will not log on. The little clock-wheel spins and spins, and eventually gives up. It will not log on, or connect, or whatever you call it, to the wireless router. A light flashes on the router for some while as it tries to connect, but then the light goes solid and the connection gives up.

So, I went back to the basic setup website to change it back to how I had it, but now I can not access the website. I must access that website via the router, I am guessing.

I's all fowled up now. I'm on the wired connection. Maybe it's too complex for me to accomplish via a forum.

Anyone want to call me on Skype and try walking me through it?

R-
 
Old 10-22-2008, 08:28 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
I went to the basic setup website and changed it to WPA Personal. It assigned a password, a long text string
You don't have to accept the password that it gives you. In fact you're much better off if you can use a phrase you can easily remember. As long as you toss a number or two and change the case of a couple of the letters, you should be fairly safe from dictionary attacks.
Quote:
I copied the text string and then pasted it into the text box when I tried to log on. But it will not log on. The little clock-wheel spins and spins, and eventually gives up. It will not log on, or connect, or whatever you call it, to the wireless router. A light flashes on the router for some while as it tries to connect, but then the light goes solid and the connection gives up.
I'm assuming you're talking about NetworkManager here. Make sure that it knows it is a WPA passphrase.

Quote:
So, I went back to the basic setup website to change it back to how I had it, but now I can not access the website. I must access that website via the router, I am guessing.
Yes, that "website" is the router's controlling software. Try accessing it through a wired connection, which will bypass all the wireless encryption and should allow you to reset it. If that fails almost all routers have a reset button that allows you to restore the factory defaults, which should be no wireless encryption. You're router documentation should tell you how to reset it.


@camorri

Why do you keep asking about the router? His original problem had nothing to do with the router.
 
Old 10-22-2008, 08:41 AM   #8
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
I found the linksys website, which has the instructions. And I am accessing the router via the cable. The rest is very confusing to me. I'll work on it today, and post more specific questions later if I can't get it to work. Thank you again for your help.

R-
 
Old 10-22-2008, 09:13 AM   #9
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
It's working again. Yea! And now it does default to my wireless router when I power on the laptop.

However, I'm using WEP security. It won't work with WPA. (have tried several ways) Don't know why not. Do you think this is a linux issue, or a linksys/router issue?
 
Old 10-22-2008, 12:33 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Well, there have been bug reports that NetworkManager in Ubuntu has a problem with WPA networks, but I thought it was a relatively recent development (as in it showed up in Hardy). At this point I would suspect Ubuntu rather than the router.

As for your original problem, I'm still suggesting you look into replacing NetworkManager with wicd. You might be able to kill two birds with one stone.
 
Old 10-22-2008, 01:24 PM   #11
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
However, I'm using WEP security. It won't work with WPA. (have tried several ways) Don't know why not. Do you think this is a linux issue, or a linksys/router issue?
If you get connected to the correct router with WEP, then basic communication is working.

WPA is more difficult to set up. I don't have a router that supports WPA, (going to buy one shortly).
As far as I know, you need WPA Supplicant installed to make WPA work. It is a dameon that runs in the background, and is involved it setting up and changing keys. See this link for an explanation.

http://wiki.archlinux.org/index.php/Wpa_supplicant
 
Old 10-22-2008, 03:26 PM   #12
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu 14.04
Posts: 183
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Great advice, again. Thank you immensely.
R-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strength of Wireless Network Signal nlavon Linux - Wireless Networking 4 06-06-2008 08:19 AM
wireless -no signal sycamorex Linux - Networking 2 03-17-2008 03:49 PM
can't get wireless signal in some rooms jwn7 Linux - Wireless Networking 1 09-27-2004 11:59 AM
Suse Wireless has signal but no ip PlatinumRik Linux - Wireless Networking 6 02-18-2004 04:23 PM
Wireless device selection jmadsen Linux - Wireless Networking 1 05-16-2003 12:59 PM


All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration