LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2008, 02:26 PM   #1
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Rep: Reputation: 0
Wireless Problems


I have a Trendnet Wireless TEW-441Pl card with an Atheros chipset. I installed madwifi and got nothing, I tried using the ndiswrapper and got nothing. The card lights up on the back, but when I use iwconfig I get sit0 no wireless extensions, and eth0, lo no wireless extensions. I tried the card in a Windows (crap) system and it worked with no problems. lspci shows the card as being recognized. Does anyone have this card working? I'm using Debian 4.01r with Kernel 2.18.5-686. Thanks.
 
Old 01-06-2008, 02:46 PM   #2
Scorpion_Linux
LQ Newbie
 
Registered: Oct 2007
Location: Sweden
Distribution: Slackware 12
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by er0c13 View Post
I have a Trendnet Wireless TEW-441Pl card with an Atheros chipset. I installed madwifi and got nothing, I tried using the ndiswrapper and got nothing. The card lights up on the back, but when I use iwconfig I get sit0 no wireless extensions, and eth0, lo no wireless extensions. I tried the card in a Windows (crap) system and it worked with no problems. lspci shows the card as being recognized. Does anyone have this card working? I'm using Debian 4.01r with Kernel 2.18.5-686. Thanks.
Hi, I'm not an expert but you should try to look up your wireless-card on the internet and se what suport if has in Linux. Some wifi-card are not suported from start and you may ned to add a moudule to the kernel of something in that way... I have read about if and I think that you either have to recomplie the kernal or you "just" have to add the moudule... I haven't done it myself but I have read about it.. :P My worked out of the box from start in slack.. =)
 
Old 01-06-2008, 03:05 PM   #3
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Post output on the nic from the command ' /sbin/lspci -v '

Brian
 
Old 01-06-2008, 09:55 PM   #4
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
RE

I used the lspci command and got this for the wireless.

00.0a.0 Ethernet Controllers: Atheros Communications, Inc
AR5212 802.11abg NIC (Rev 01) Subsystem: Atheros Communications, Inc Unknown device 2051
Flags: Bus Master, medium devsel, latency 32 IRQ 5
Memory at feb0000 (32 bit, non prefetchable) size=64k
Capability [44] Power Management version 2

I'm kind of new to Linux and haven't used any distro in a while. On my older system I could never get the wireless to work either. Is there something I'm missing? Thanks.
 
Old 01-07-2008, 02:43 PM   #5
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Not a Debain user but you installed madwifi. When you run the command ' /sbin/modprobe ath_pci ' I assume no errors. Did it load? To check use command ' /sbin/lsmod '.

Brian
 
Old 01-07-2008, 08:45 PM   #6
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
i did get an error with the modprobe command.
FATAL: module ath_pci not found

I really don't know what's going on. I have madwifi installed, however I have no idea how to use it or what it is. The LED on the back blinks once every three or four seconds and I know the card is being recognized by the system from the lspci command. I have no idea what to do with this. I'm ready to give the WUSB54GS linksys card a shot with the ndiswrapper. Is there a specific module other than madwifi that I need for the atheros chipset? Man this is a pain. Thanks.
 
Old 01-08-2008, 03:09 PM   #7
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
I had no idea about the m-a a-i command. I tried that and got the card to register properly. Im using a linksys wireless router with an encryption key. I tried to use the key through various methods and I keep getting an error during connection. Under terminal with the iwconfig command i get the following.

lo no wireless extensions

eth0 no wireless extensions

wifi0 no wireless extensions

ath0 IEEE 802.11g ESSID:"(My routers name)"
Mode:Managed Frequency:2.442 GHz Access Point: 00:15:E9:7e:Ea:62
Bit Rate:36 Mb/s Tx-Power:16 dbm Sensitivity=0/3
Retry=off RTS thrff
Power Management=off
Link Quality=127/94 Signal level=-223 dbm Noise level=-94 dbm
Rx invalid nwid:1733 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions


And here is my /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For mor information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow hotplug ath0
iface ath0 inet static
address 192.168.2.101
wireless-essid (my routers name)
netmask 255.255.255.0

auto eth0
iface eth0 inet dhcp
wireless-essid idiot


I think it has something to do with my /etc/network/interfaces file, however I have absolutely NO idea what to do with it. I tried a few walkthroughs thus the wireless-essid idiot section. I don't know how to configure the interfaces file to work correctly. My wpa_supplicant file is as follows also.

#
# File: wpa_supplicant
#
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
network={
ssid="(my ssid)"
key=mgmt=WPA-PSK
psk=(my wpa key)
}


The router is either WPA or WEP I don't remember. And my roomate forgot the login to check and he's lana retentive about rebooting it to default. I used the same key under windows and it worked with this card. So I tried configuring the /etc/network/interfaces file for the WEP key, and when that didn't work I used the wpa_supplicant file for the WPA key. Neither one worked. Here is what i get with ifconfig.

ath0 Link encap:ethernet HWaddr 00:18:E7:0b:XX:XX
inet addr:192.168.2.105 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80:218:e7ff:fe0b:bd17/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
Rx packets:1 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carriers:0
collisions:0 txqueuelen:0
Rx bytes:288 (288.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:ethernet HWaddr 00:13:8F:46:XX:XX
UP BROADCAST MULTICAST MTU:1500 Metric:1
Rx packets:1 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carriers:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:185 Base address:0xd400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
Rx packets:1 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carriers:0
collisions:0 txqueuelen:1000
RX bytes:209589 (204.6 Kib) TX bytes:209589 (204.06 Kib)

sit0 Link encap:IPv6-in-IPv4
inet addr:192.168.2.105 Mask:255.255.255.0
inet6 adr: ::192.168.2.105/96 Scope:Compat
inet6 addr: ::127.0.0.1/96 Scope:Unknown
UP RUNNING NOARP MTU:1480 Metric:1
Rx packets:1 errors:0 dropped:0 overruns:0 frame:0
Tx packets:0 errors:0 dropped:0 overruns:0 carriers:0
collisions:0 txqueuelen:0

wifi0 Link encap UNSPEC HWaddr 00-18-E7-0B-BD-17-30-3A-00-00-00-00-00-00
-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Rx packets:29292 errors:0 dropped:0 overruns:0 frame:142342
TX packets:63644 erorrs:6 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:3176802 (3.0 Mib)
Interrupt:201 Memory:dcb40000-dcb50000

Can someone give me a hand before I lose my temper and throw the computer out the window again? I appreciate the help in advance. Thanks.
 
Old 01-08-2008, 03:38 PM   #8
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Well if it is a key of say 10 characters for 64bit to I think 22 characters for 128bit then I would say it is WEP. Other I would say WPA or WPA2. Either one has certain changes to the wpa_supplicant setup. Now one other thing is if he has say mac filtering setup then you would not be able to connnect to added to mac filtering table. What I would do is either go somewhere to an open wireless and connect with no security. The best way to see if madwifi is working fine is connect to a plain unsecured router.

Brian
 
Old 01-08-2008, 05:31 PM   #9
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Looks like the ath_pci module is installed and working. Your ath0 interface is running.

But, where did you get that IP address in your interface file? It doesn't match what ifconfig reports anyway.

Try iwconfig and see if the wireless NIC is associating with the router. This will be MUCH simpler if you can turn off security for a few minutes to get connected to the router, then try to sort out the security.

You're going to have to determine the security configuration of the router and WEP or WPA key. If you have a functioning Windows machine that can connect to this router, you can get some of the info from the Windows interface configuration settings.
 
Old 01-09-2008, 10:27 AM   #10
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
I thought it was WEP, but its WPA-TKIP. I have the interfaces file set up for a static IP. I used the card and connected fine to a router without security, can't seem to figure out how to connect with WPA-TKIP. Is there a command that I put in the interfaces file to link that file to my wpa_supplicant file that shows the key? I really wish I knew what I was doing with this, it would be much easier.
 
Old 01-09-2008, 03:46 PM   #11
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Don't know Debian setup just Redhat type distros. Only thing I see if using wpa and not wpa is add this line to wpa_supplicant.conf. proto=WPA
#
# File: wpa_supplicant
#
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
network={
ssid="(my ssid)"
key=mgmt=WPA-PSK
psk=(my wpa key)
proto=WPA
}

Brian
 
Old 01-10-2008, 07:20 PM   #12
er0c13
LQ Newbie
 
Registered: Jan 2008
Posts: 10

Original Poster
Rep: Reputation: 0
FINALLY got it working. The problem was the I was a tool and wasn't setting a passphrase. Thanks for all the help guys!
 
  


Reply

Tags
debian, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom Wireless (BCM4306) Wireless problems: modprobe ndiswrapper freezes HP Laptop shthap3ns Linux - Hardware 11 02-11-2007 12:53 PM
Wireless (Intel PRO/Wireless 2200BG) network problems using FC5 kernel 2.6.17 TempleOwl1999 Linux - Laptop and Netbook 14 08-26-2006 02:57 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 06:25 AM
wireless problems; Broadcom 802.11G Mini PCI Wireless with redhat WS surfbass Linux - Laptop and Netbook 1 12-17-2004 12:48 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration