LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-22-2015, 12:50 PM   #1
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Rep: Reputation: Disabled
Wireless networks not showing up after change to interfaces file


Hi everyone,

This is my first post in any Q&A site

Yesterday I tried to clone my wiress NIC MAC so I edited /etc/network/interfaces. I didn't checked if it worked because I was able to clone my MAC through the GUI. The next time I booted my machine I tried to connect to a Wireless network, but when I checked the list of available networks I didn't see one, while there are. I undo the changes to the file and rebooted my computer, still I'm not able to see any.
I am using Debian 8 with Gnome 3.

This is the content of my interfaces file:
/etc/network/interfaces
source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
iface wlan0 inet dhcp



Here is some information that might be useful:
lshw -class network

*-network DISABLED
description: Wireless interface
product: RTL8188EE Wireless Network Adapter
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 48:d2:24:53:c5:a4
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl8188ee driverversion=3.16.0-4-amd64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
resources: irq:17 ioport:2000(size=256) memory:c8400000-c8403fff



ifconfig -a

wlan0 Link encap:Ethernet HWaddr 48:d2:24:53:c5:a4
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Please let me know if I can add some additional information.
Any help would be very much appreciated
 
Old 06-22-2015, 01:05 PM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Try this:
Code:
# rfkill unblock all
If that doesn't work, post the output of:
Code:
rfkill list all
Check that any keyboard controls or firmware (BIOS) options for your wireless card are activated
 
Old 06-22-2015, 01:11 PM   #3
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi,

rfkill unblock all didnt't work.

Here's the output of rfkill list all

Code:
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
EDIT:
Checked the BIOS, the wireless card is activated.

Last edited by jetty; 06-22-2015 at 01:17 PM. Reason: Adding info
 
Old 06-22-2015, 01:15 PM   #4
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by Head_on_a_Stick View Post
Check that any keyboard controls or firmware (BIOS) options for your wireless card are activated
↑ How about this?

If that doesn't work, post the output of:
Code:
ip l
lspci -knn|grep -iA2 net
 
Old 06-22-2015, 01:22 PM   #5
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thanks for your replies,

The NIC is not hardware disabled. I double checked.

Here is the output of the commands:

Code:
# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:8c:fa:69:30:5f brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 48:d2:24:53:c5:a4 brd ff:ff:ff:ff:ff:ff


# lspci -knn|grep -iA2 net
01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8162 Fast Ethernet [1969:1090] (rev 10)
    Subsystem: Toshiba America Info Systems Device [1179:ff1e]
    Kernel driver in use: alx
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:0181]
    Kernel driver in use: rtl8188ee
 
Old 06-22-2015, 01:26 PM   #6
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Try this:
Code:
# ip l set wlan0 up
 
Old 06-22-2015, 01:28 PM   #7
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
I tried it, didn't work.
 
Old 06-22-2015, 01:44 PM   #8
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
What is the ouptut of `ip l` now?
 
Old 06-22-2015, 01:56 PM   #9
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Code:
# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:8c:fa:69:30:5f brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 48:d2:24:53:c5:a4 brd ff:ff:ff:ff:ff:ff
 
Old 06-22-2015, 02:08 PM   #10
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by jetty View Post
/etc/network/interfaces
source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
iface wlan0 inet dhcp
Either set up wlan0 in this file (ie, add an "auto wlan0" line and the "wpa-ssid" & "wpa-psk" lines) or remove the wlan0 line completely.
 
1 members found this post helpful.
Old 06-22-2015, 02:12 PM   #11
jetty
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
I removed the line wlan0 from the file and everything works properly now
Thank you so much.
 
Old 06-22-2015, 02:13 PM   #12
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
You're welcome -- I should have spotted that straight away really...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Two networks on two interfaces Sigg3.net Linux - Networking 6 10-02-2012 01:51 PM
How do I change wireless networks? njbrubaker Ubuntu 1 04-18-2006 08:13 PM
Example needed of a Debian -interfaces file with wireless settings slewis1972 Linux - Wireless Networking 2 09-14-2003 03:44 PM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration