LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-13-2010, 06:12 PM   #1
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Rep: Reputation: 17
Wireless networking in Debian Problems


I have an intel 3945ABG wireless card.
I installed "firmware-iwlwifi" with apt-get but I cannot enter in my network's SSID and wep.

On GNOME, I click system, preferences, and networking, and I get that nice network menu, but it doesn't do anything!
It detects my wireless and wired card. I click on wireless, enter in my ssid, click WEP (hexadecimal), enter in my code. I choose auto DHCP.

Then in the terminal I type iwconfig. It shows "wlan0" but the SSID field is blank.

The wired works but I can't get wireless.

Any help would be appreciated.
 
Old 01-13-2010, 06:47 PM   #2
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
We need more information to help you solve your issue


Go to Applications -> Accessories -> Terminal.

Type in
Code:
lspci
, press [ENTER], and copy/paste the output here in CODE tags.

Type in
Code:
ifconfig wlan0 up
, press [ENTER]. Post any error messages.

Type in
Code:
iwlist wlan0 scan
, press [ENTER]. Do you see your wireless network here?

Type in
Code:
iwconfig <interface> essid <youressid> key <yourwepkey>
, press [ENTER]. Post any error messages.

Type in
Code:
dhcpcd wlan0
, press [ENTER], Post any error messages.

For this command, unplug your Ethernet cable.

Type in
Code:
ping www.yahoo.com
, press [ENTER]: Does it result in an error message, e.g. "unknown host" or does it get many responses?
 
Old 01-13-2010, 07:39 PM   #3
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
We need more information to help you solve your issue


Go to Applications -> Accessories -> Terminal.

Type in
Code:
lspci
, press [ENTER], and copy/paste the output here in CODE tags.

Code:
 # lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GS (rev a1)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
07:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
07:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
07:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
07:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
07:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
Quote:
Type in
Code:
ifconfig wlan0 up
, press [ENTER]. Post any error messages.

Type in
Code:
iwlist wlan0 scan
, press [ENTER]. Do you see your wireless network here?

Type in
Code:
iwconfig <interface> essid <youressid> key <yourwepkey>
, press [ENTER]. Post any error messages.

Type in
Code:
dhcpcd wlan0
, press [ENTER], Post any error messages.
This took a second and then assigned me 10.0.0.9.

Quote:
For this command, unplug your Ethernet cable.

Type in
Code:
ping www.yahoo.com
, press [ENTER]: Does it result in an error message, e.g. "unknown host" or does it get many responses?
With these commands, the network light on the laptop finally turned blue ("connected"), but I disconnected the ethernet and still could not ping.
 
Old 01-13-2010, 11:50 PM   #4
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Hmm...A few more questions...

So you are able to associate with target network?

Has this wireless card worked previously, on another install?

After you have "connected" to the target network; Type this command
Code:
ifconfig -a
, press [ENTER] and post back the output. Be sure to not post your real IP address. (e.g. xx.xx.xx.xx)

Could you post the exact message of the error received when pinging yahoo.com?

What are your firewall settings? If you have one, be sure to "allow" your IP address, subnet mask, and gateway, DNS servers and broadcast address. Perhaps if you have one you can temporarily turn it off to test if thats the problem.

For the record, i don't think you should be getting a 10.xx.xx.xx IP address. Perhaps you use a static IP?
 
Old 01-14-2010, 12:24 AM   #5
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
Hmm...A few more questions...

So you are able to associate with target network?
On wired only. I'm on only if I connect it directly to the router with an ethernet cable.
I can use wireless in windows vista with no problems.

Quote:
Has this wireless card worked previously, on another install?
I haven't ever set up debian on a laptop, but this computer is dual booting with vista which can connect to the network wirelessly.
Also, I've used puppy linux on this laptop, and it went wirelessly without any drivers at all.

Quote:
After you have "connected" to the target network; Type this command
Code:
ifconfig -a
, press [ENTER] and post back the output. Be sure to not post your real IP address. (e.g. xx.xx.xx.xx)
Code:
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx 
          inet addr:10.0.0.13  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: xxxx::xxx:xxxx:xxxx:xx/xx Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1165 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1150 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:894234 (873.2 KiB)  TX bytes:212080 (207.1 KiB)
          Interrupt:219 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:648 (648.0 B)  TX bytes:648 (648.0 B)

wlan0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr xx-xx-xx-xx-xx-xx-xx-xx-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
(I replaced HWaddr with xx's, it returned a bunch of hexidecimal, I don't know if I should post that. I know that 127.0.0.1 is local)

10.0.0.x is my router. Our previous dlink router used the typical 192.68.0.1.1 or whatever.

Quote:
Could you post the exact message of the error received when pinging yahoo.com?
Code:
# ping www.yahoo.com
ping: unknown host www.yahoo.com
Quote:
What are your firewall settings? If you have one, be sure to "allow" your IP address, subnet mask, and gateway, DNS servers and broadcast address. Perhaps if you have one you can temporarily turn it off to test if thats the problem.
I have no hardware firewall, only the router and WEP.

Quote:
For the record, i don't think you should be getting a 10.xx.xx.xx IP address. Perhaps you use a static IP?

Windows/linux both report that my ip is 10.0.0.xx when I connect. (windows says the same ip for wireless and wired.)
Going to whatismyipaddress.com reports the same IP from any computer in this house.
The ISP has changed it before in the past so I don't think I have a static. If I enter in 10.0.0.1 in my browser then that's how I can log into my router.

The wlan0 scan command DOES show my router and its name in the list, but even after I enter in the ssid/wep it won't let me connect. I even tried turning off wep temporarally to see if I was putting in the wrong pass (even though I entered it exactly from the router login page). No luck.
 
Old 01-14-2010, 12:30 AM   #6
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Does Windows report your IP address as assigned by DHCP?
 
Old 01-14-2010, 12:36 AM   #7
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Here is an update.

This guy looks like he had a similar problem.

Try:
Quote:
sudo sed 's/, interface-mtu//' /etc/dhcpd3/dhclient.conf
(<If you don't have/use sudo, perform it as root>)
in a Terminal. Then repeat above and see if that gets you connected.

Last edited by lupusarcanus; 01-14-2010 at 12:40 AM. Reason: "loooks" is not a word :)
 
Old 01-14-2010, 12:40 AM   #8
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
Does Windows report your IP address as assigned by DHCP?
The IP settings are set to "Obtain an IP automatically.", and "Obtain a DNS server automatically." Using the default settings in my router (besides WEP added), all I did on windows was click "Connect to network", picked my ssid, and entered in the wep.

Click image for larger version

Name:	dhcp.jpg
Views:	10
Size:	20.7 KB
ID:	2487
 
Old 01-14-2010, 12:44 AM   #9
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by orangesky View Post
The IP settings are set to "Obtain an IP automatically.", and "Obtain a DNS server automatically." Using the default settings in my router (besides WEP added), all I did on windows was click "Connect to network", picked my ssid, and entered in the wep.

Attachment 2487
Ok, well, it;'s definitely DHCP.

Try the command above from the Ubuntu forums and see if that fixes it.
 
Old 01-14-2010, 12:53 AM   #10
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
Ok, well, it;'s definitely DHCP.

Try the command above from the Ubuntu forums and see if that fixes it.
After running that command, it seems as though I have no /dhcpd3/ in /etc/ and no dhclient.conf.

I installed the dhcp client using apt-get before I even made this thread.
 
Old 01-14-2010, 01:02 AM   #11
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Huh. Weird. It seemed like the quick fix for that guy.

Look at this how-to. I know you installed the firmware, but have you properly loaded it?
 
Old 01-14-2010, 01:45 AM   #12
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
Huh. Weird. It seemed like the quick fix for that guy.

Look at this how-to. I know you installed the firmware, but have you properly loaded it?
It works now, but only when I disable wep.
What am I doing wrong?

My router asks for a "passphrase" when making the wep.
After I enter in a phrase (let's use "foobar" for example) it then generates four hex codes all with 10 digits/letters each. I entered the first one in windows and it took it.

I went to gnome's network manager, entered in ssid, chose WEP key (hexadecimal) and entered in the 10 digits/numbers but it won't work no matter what.
 
Old 01-14-2010, 02:03 AM   #13
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
At least we have it working somewhat.

Go ahead and put this into a Terminal after enabling WEP.

Quote:
ifconfig wlan0 up; sudo iwconfig wlan0 essid "WHATEVER" key TheHexKey; dhcpcd wlan0
Perhaps that might work now?

Last edited by lupusarcanus; 01-14-2010 at 02:05 AM.
 
Old 01-14-2010, 11:10 PM   #14
orangesky
Member
 
Registered: Jun 2009
Posts: 87

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by leopard View Post
At least we have it working somewhat.

Go ahead and put this into a Terminal after enabling WEP.


Perhaps that might work now?

SUCCESS!

Thank you so very much.


One final question...
When I am starting debian, before I even get to X, sometimes it halts at DHCPCD and says like
Code:
DHCPDISCOVER ON 255.255.255.0 interval 3
DHCPDISCOVER ON 255.255.255.0 interval 7
DHCPDISCOVER ON 255.255.255.0 interval 18
DHCPDISCOVER ON 255.255.255.0 interval 4
DHCPDISCOVER ON 255.255.255.0 interval 1
Could not set IP
That's not the exact ouptut, but I'm assuming it's dhcp trying to find a connection. How can I disable network configuration until I get into X, everything is loaded, etc, because this seriously goes through that for like 5 mins, forever to boot.
 
Old 01-14-2010, 11:20 PM   #15
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
Well, if you want, you could make a bash script and include
Quote:
iwconfig wlan0 retry <value>
and have it execute on start-up.

that seems to be a common problem, in one of the above links.

Oh, and if I helped you, it's very nice to hit the "Thanks" button on my post.
If and when the issue gets solved to your liking you can got to Thread Tools at the top of the webpage and mark it as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Networking With Debian 5 Question sefarlow Linux - Newbie 6 03-04-2009 09:41 AM
I need help setting up wireless networking on Debian Bakuba Linux - Wireless Networking 3 08-03-2007 06:09 PM
Debian wireless networking problems Harpoontang Linux - Wireless Networking 1 03-19-2006 10:30 AM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration