LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2009, 07:27 PM   #16
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43

type iwconfig if you don't have it get wireless-tools I believe it's 'apt-get install iw', then you can run iwconfig and post the output.
 
Old 09-05-2009, 02:50 AM   #17
tke1384
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Rep: Reputation: 1
I'm glad to hear your hardwire is working again. This should make things easier to troubleshoot. I'm going to have to take a closer look at your hardware in the morning because as of this moment I'm a little drunk, but I will have another look at it in the morning. I don't believe wicd is what we should be concentrating on that the moment. It's just a software to make it more convenient to connect to wireless networks. We are going to get you online fist using nothing but command line and then we will look into a nice GUI for you.
 
Old 09-06-2009, 07:01 AM   #18
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
tke1384 - I have realised that after restarting my ubuntu computer that I lose my wired connection again however if I enter the commands you suggested earlier:-

$ sudo ifconfig eth0 up
$ sudo dhclient eth0
$ ifconfig eth0

my wired connection works again immediately.

I have removed wicd and also run update manager but whenever I restart I lose the wired connection until I enter the settings in terminal again.

Do you have any ideas how to make the changes I am doing in terminal permanant?

I'm still concerned with the instructions I followed which caused me to lose my wired connection originally. These are the instructions I followed below:-

3.1. Disable Free Drivers
Firstly, all releases since Ubuntu 6.06 have the open source bcm43xx driver, which was replaced in 8.04 by b43 and b43legacy, see WifiDocs/Driver/bcm43xx. If this driver doesn't work for you, then you should disable it, because it will conflict with ndiswrapper. To disable it, add blacklist bcm43xx lines for each driver to the modprobe blacklist.
echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist


Do you have any ideas how to undo these changes I made?

Last edited by Rainbowserpant; 09-06-2009 at 07:03 AM.
 
Old 09-06-2009, 07:04 AM   #19
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Do you have any ideas how to make the changes I am doing in terminal permanant?
You can put the commands in
/etc/rc.local
Code:
ifconfig eth0 up
dhclient eth0
ifconfig eth0
 
Old 09-06-2009, 07:27 AM   #20
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
repo - I found the folder you suggested but not sure where to enter the commands.

Here's what rc.local contains when I open the file in display mode:-

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

Where should I enter the commands?
 
Old 09-06-2009, 07:32 AM   #21
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
After the line
# By default this script does nothing.
Code:
# By default this script does nothing.
ifconfig eth0 up
dhclient eth0
ifconfig eth0
exit 0
Then
Code:
sudo chmod +x /etc/rc.local
 
Old 09-06-2009, 07:40 AM   #22
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
repo - When I enter the commands as you describe I am not able to save the file as it states I do not have permission to save the file?

Am I entering them correctly as below?

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
ifconfig eth0 up
dhclient eth0
ifconfig eth0
exit 0
sudo chmod +x /etc/rc.local
 
Old 09-06-2009, 07:43 AM   #23
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
You need to edit the file as root

You need to add
Code:
ifconfig eth0 up
dhclient eth0
ifconfig eth0
Then save the file
Then make the file executable
In a terminal type
Code:
sudo chmod +x /etc/rc.local
 
Old 09-06-2009, 07:53 AM   #24
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
repo - Thank you. I just followed your instructions and wired connection works after restart!!!

Do you have any ideas on how to start to get my wireless connection working?
 
Old 09-06-2009, 08:09 AM   #25
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
What is the output from
Code:
sudo iwconfig
What have ou tried until now?
Sorry, to lazy to read the whole thread :-)

Last edited by repo; 09-06-2009 at 08:10 AM.
 
Old 09-06-2009, 08:33 AM   #26
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
repo - Here's the results of sudo iwconfig:-

steve@dharma-ubuntu-desktop:~$ sudo iwconfig
[sudo] password for steve:
lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

steve@dharma-ubuntu-desktop:~$

After installing ubuntu I could not establish any connection with network manager.

I then uninstalled network manager and installed wicd which allowed me to connect via wired connection (I had selected manual settings for static ip address to be assigned as I have a home network) which worked fine until I disabled drivers following instructions how to us nsdwrapper at ubuntu website. Not sure what I was doing and got lost really, but my connection stopped and wicd stopped working as soon as I disabled the drivers as per the instructions below:-

3.1. Disable Free Drivers
Firstly, all releases since Ubuntu 6.06 have the open source bcm43xx driver, which was replaced in 8.04 by b43 and b43legacy, see WifiDocs/Driver/bcm43xx. If this driver doesn't work for you, then you should disable it, because it will conflict with ndiswrapper. To disable it, add blacklist bcm43xx lines for each driver to the modprobe blacklist.
echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist


Before this wicd was able to detect my wireless connection but I could not connect wirelessly after entering the wireless network settings and password. Wicd would just freeze. Earlier in this thread I was advised to use nsdwrapper but couldn't work out how or what to do.

My wireless network card is netgear wg311v2
 
Old 09-06-2009, 08:40 AM   #27
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
echo -e "blacklist bcm43xx\nblacklist b43\nblacklist b43legacy\nblacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist
as root edit
Code:
/etc/modprobe.d/blacklist
remove the following lines

Code:
blacklist bcm43xx
blacklist b43
blacklist b43legacy
blacklist ssb
Reboot, and see if wicd works
 
Old 09-06-2009, 09:08 AM   #28
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
Repo - I removed those lines, reinstalled wicd and rebooted but wicd still dosen't work. It pops open for a second then disappears.
 
Old 09-06-2009, 09:18 AM   #29
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Try
Code:
apt-get --purge remove wicd
sudo apt-get install wicd
If that doesn't work, try to reinstall network manager

Code:
sudo apt-get instal network-manager-gnome

Once networkmanager or wicd works, try to see if the wireless connection is recognized.

If not you will need to use ndiswrapper.
 
Old 09-06-2009, 09:37 AM   #30
Rainbowserpant
LQ Newbie
 
Registered: Jul 2009
Posts: 27

Original Poster
Rep: Reputation: 15
repo - I tried:-

apt-get --purge remove wicd
sudo apt-get install wicd

but wicd still shows up in applications but wont start.

when I

sudo apt-get instal network-manager-gnome

I get this message

root@dharma-ubuntu-desktop:/home/steve# sudo apt-get instal network-manager-gnome
E: Invalid operation instal
root@dharma-ubuntu-desktop:/home/steve#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Connection Problems canada_eh Linux - Networking 2 03-11-2008 12:22 AM
Wireless connection problems James4coffee Linux - Wireless Networking 3 04-02-2007 05:25 PM
Wireless Connection problems Benchwarmer969 SUSE / openSUSE 1 10-09-2006 11:46 PM
wireless connection problems. PSBP753 Linux - Newbie 5 07-26-2006 01:27 AM
Wireless card..Wireless router.. Slackware 10.2 ..Problems with Internet Connection. Storm Bringer Linux - Wireless Networking 4 03-23-2006 07:25 AM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration