LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2009, 01:34 PM   #1
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Rep: Reputation: 15
Wireless connection in Opensuse


This is the first time I am using Opensuse. I have used Ubutnu 9.04 before.
I am unable to connect to the internet wired or wirelessly.
System:Dual Boot :Vista Home premiumand Opensuse 11.0Opensuse 11.0(i586) kernel 2.6.25.5-1.1 , Kde 3 desktop
Wireless driver is Atheros 242x.
Laptop: ASus F5RL laptop.
-I have checked the Network Settings on Yast and on the Overview tab, it says
L2 100Mbit Ethernet Adapter -- Not configured
AR242x 802.11abg Wireless PCI Express Adapter -- Not configured.
The notes for Wireless says' Unable to configure the network card because of kernel device(eth0, wlan0) is not present. This is mostly caused by missing firmware(for wlan0 devices). Check dmesg
I have checked and found thatlinux-c9xx firmware.sh[0980]. cannot find firmware file 'intel-ucode /06-0f-od'.
-I searched for 'intel-ucode /06-0f-od' on google and yahoo . did not find anything concrete.-I have unchecked IPV6 on Network settings.

I can see ath0 and my network. But Firefox or Opera cannot access internet.
What is to be done

Bamtoy
 
Old 09-10-2009, 09:34 PM   #2
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

using root powers try

Code:
modprobe ath5k
I do not have your hw...but based on this post.
http://bbs.archlinux.org/viewtopic.php?id=75883

if your system then works...you can either put that module into a modules.conf or preload file if Opensuse uses such or /etc/modules or if you can't find such beasts....add a line to rc.local...but if rc.local specify the full pathway not just the module name

so its either

ath5k.....added with root powers to a modules file under /etc or /etc/modulule?/(filename)

or

/sbin/modprobe ath5k ...added with root powers to /etc/rc.local

Last edited by aus9; 09-10-2009 at 09:35 PM.
 
Old 09-11-2009, 06:32 AM   #3
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Wireless connection in Opensuse

I have used these commands
[QUOTE]modprobe -rv ath5k
echo "blacklist ath5k" >> /etc/modprobe.d/blacklist.local
rm /etc/udev/rules.d/70-persistent-net.rules
udevadm trigger[/QUOTE
and got the wireless connection 'ath0'.
I still cant get to any website.
Maybe to do with Network Manager?

Bamtoy
 
Old 09-11-2009, 07:06 AM   #4
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

why did you add ath5k module to a blacklist? I was hoping you would add it to a modules preload list or did you not understand what a blacklist was?

2) did you make a copy of your udev rule before deleting it?
I would hope you move it ...mv if you thought it was interfering?
Can you recall its contents?

mine is not going to help as I am wired.

suggest you open a terminal and su again
modprobe ath5k and report it loads or has error if no error you can run

lsmod | grep ath5k.....and post the results

3) loading the module is a start then you still have to configure the wireless setup
 
Old 09-11-2009, 07:26 AM   #5
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Wireless connection in Opensuse

Quote:
why did you add ath5k module to a blacklist? I was hoping you would add it to a modules preload list or did you not understand what a blacklist was?
I was told to do so in the opensuse forum. I am a beginner.

Quote:
did you make a copy of your udev rule before deleting it?
I would hope you move it ...mv if you thought it was interfering?
Can you recall its contents?
No I did not make a copy nor do I recall its contents.

Quote:
suggest you open a terminal and su again
modprobe ath5k and report it loads or has error if no error you can run
lsmod | grep ath5k.....and post the results
I will log in to suse box and do that .Will post results.

bamtoy

Last edited by bamtoy; 09-11-2009 at 07:37 AM.
 
Old 09-12-2009, 07:48 AM   #6
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Wireless connection in opensuse

I have reinstalled the whole thing.
So now how do I install software? I am not connect by wires nor wirelessly.
Now how do I go about it?
 
Old 09-12-2009, 10:19 AM   #7
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
hi

There is not normally a need to do a clean install unless you felt frustrated.

But we have still to resolve your first question and mine.

I am suggesting you load a module called ath5k based on the success the person in the link had. For someone in the opensuse forum to tell you to add it to a blacklist and not explain what happens next may be not so good.....was that the only advice?

could it be they wanted you to blacklist it from cold boot then run it manually...by a modprobe command?

2) yes it is difficult if a new to Linux etc.

Maybe....in the meantime....as the ath5k does not appear to help you start to get networking working .....you might like to get a second opinion and go for a live cd....where that wireless card...works out of the box?
 
Old 09-12-2009, 01:34 PM   #8
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
=aus9;3680006]hi
There is not normally a need to do a clean install unless you felt frustrated.
But we have still to resolve your first question and mine.
I am suggesting you load a module called ath5k based on the success the person in the link had.
Yes I will load ath5k from the dvd. I suppose I have to add DVD.

Quote:
For someone in the opensuse forum to tell you to add it to a blacklist and not explain what happens next may be not so good.....was that the only advice?could it be they wanted you to blacklist it from cold boot then run it manually...by a modprobe command?
The following commands were given and I had done exactly that. I could see wireless networks ath0. However the ext3 partition has been deleted and a new one installed "modprobe -rv ath5k
echo "blacklist ath5k" >> /etc/modprobe.d/blacklist.local
rm /etc/udev/rules.d/70-persistent-net.rules
udevadm trigger"

Quote:
2) yes it is difficult if a new to Linux etc.
Maybe....in the meantime....as the ath5k does not appear to help you start to get networking working .....you might like to get a second opinion and go for a live cd....where that wireless card...works out of the box?
I am looking for how to configure the network settings because the wired and wireless show as 'Not configured'.

bamtoy
 
Old 09-12-2009, 08:45 PM   #9
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
ok

lets go back a step.

did they explain why they wanted your ath5k module blacklisted?

if not, why not? Did you tell them you were a beginner?
if not, what alternative did they offer you?

2) since you have already done a clean install....what I am suggesting to you...since you can get on the net ...you have notes howto do it the opensuse way....so no harm in following my suggestions (for now)

3) use root powers to open a text editor and remove the ath5k from the blacklist file

ath5k is not on the dvd.....its a kernel module..you can load kernel modules manually....have the system load modules using a kernel module file....such as /etc/modules.conf or the system can load modules on demand.

so I would like you to try manually first.

Open a terminal and get root power....if you use sudo then the next bit becomes

sudo modprobe ath5k instead of what I have written

Code:
su
modprobe ath5k
4) but assuming that module loads....its only available while you do not shut down or reboot.

I do not have your hardware so can not help there but assuming it loads....we can test it has loaded.

if it reports module not found......----> I have failed you
if no error report we can check if it has loaded by running another command in the terminal which I would like you to keep open

lsmod | grep ath5k


5) You then need to use your network manager to configure the wireless settings.

I do not use Opensuse so not sure how you do it.

but these might help?

http://en.opensuse.org/Tracking_down_wireless_problems

http://en.opensuse.org/WiFi_HOWTO

Be aware the next link...competes against ath5k....it uses a windows driver
http://en.opensuse.org/Wireless_Netw...d_Installation


6) at just to attempt to confuse you more?

your network manager should have only one setting...meaning remove any WIRED or ethernet settings as you are using wifi.

the same is true of old dial up versus wifi versus ethernet.


good luck

ps the first link indicates some succeeded without needing windows drivers thru ndiswrapper...and not using madwifi

you do have options but I have attempted to be more verbose so if you want to use the opensuse forums....ask them politely that they need to explain why they want you to do something.

provide a link please so others can assist?
 
Old 09-13-2009, 08:56 AM   #10
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by aus9 View Post
ok
since you have already done a clean install....what I am suggesting to you...since you can get on the net ...you have notes howto do it the opensuse way....so no harm in following my suggestions (for now)
I cannot get on the net wires or no wires.
Quote:
Open a terminal and get root power....if you use sudo then the next bit becomes
sudo modprobe ath5k instead of what I have written
Code:
su
modprobe ath5k
I have done it No output shown and so I presume it loads.

Quote:
4) but assuming that module loads....its only available while you do not shut down or reboot.
I do not have your hardware so can not help there but assuming it loads....we can test it has loaded.
if it reports module not found......----> I have failed you
if no error report we can check if it has loaded by running another command in the terminal which I would like you to keep open
lsmod | grep ath5k
Output of
Code:
lsmod | grep ath5k
ath5k 109572 0
mac80211 190484 | ath5k
Quote:
5) You then need to use your network manager to configure the wireless settings.
I do not use Opensuse so not sure how you do it.
but these might help?
I cannot configure Network cards wired and wireless.
In Yast --> Network settings , Overview tab.
Both wired L2.100 and Ar242x wireless have the 'EDIT' blanked out.
The error says 'firmware not found'
I will read the instructions given in the links provided .

6) at just to attempt to confuse you more?
Quote:
your network manager should have only one setting...meaning remove any WIRED or ethernet settings as you are using wifi.
the same is true of old dial up versus wifi versus ethernet.
I have 2 both not configured. I will read all that you have given.
yes i have posted on the suse forums (where I was told to blacklist ath5k)

bamtoy
 
Old 09-13-2009, 10:19 AM   #11
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
thankyou for your patience

but I beg you to ask that forum....if they want you to blacklist...what module or system are they offering as an alternative.
 
Old 09-13-2009, 11:00 AM   #12
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
With the ath5k kernel module loaded,

please run "sudo /sbin/lspci -v" | sed -n '/Atheros/,/^$/p'
and "sudo /sbin/lspci -n".
The second command will list the manufactures code. We can search the ath5k.c source code and see if it is supported.

Post the results. Also post the results of "uname -r".

The ath5k module does not need firmware cut out.

When I installed openSuSE 11.1 on my Gateway netbook, I couldn't configure it's Atheros wireless device. In my case, the device was too new for the version of the ath5k driver I had, and updating to a newer kernel fixed the problem.

Last edited by jschiwal; 09-13-2009 at 11:02 AM.
 
Old 09-13-2009, 02:28 PM   #13
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Wirelesss connection in suse

Quote:
Originally Posted by aus9 View Post
thankyou for your patience
but I beg you to ask that forum....if they want you to blacklist...what module or system are they offering as an alternative.
Hello aus9,
I was asked to blacklist ath5k and install madwifi.
I had a few posts from that person after that he has not answered.

I also get instructions to install wicd. You see how confusing it is.

Thank you,
bamtoy
 
Old 09-13-2009, 02:32 PM   #14
bamtoy
Member
 
Registered: Jul 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
With the ath5k kernel module loaded,
please run "sudo /sbin/lspci -v" | sed -n '/Atheros/,/^$/p'
and "sudo /sbin/lspci -n".
The second command will list the manufactures code. We can search the ath5k.c source code and see if it is supported.
Post the results. Also post the results of "uname -r".
The ath5k module does not need firmware cut out.
When I installed openSuSE 11.1 on my Gateway netbook, I couldn't configure it's Atheros wireless device. In my case, the device was too new for the version of the ath5k driver I had, and updating to a newer kernel fixed the problem.
I have to get ath5k loaded first. I am told that the driver is not available as a package. I must download the source code and compile it.
So let me check how to do that.

thank you.
bamtoy
 
Old 09-13-2009, 11:48 PM   #15
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
it is a kernel module...check your /boot/config-(some kernel version name)...mine is shown under # Wireless LAN
CONFIG_ATH5K=m

the m means its a module...if it is a y you have it at boot up...if its n for no then you need to re-compile your kernel....and if that is the case...maybe you need to change your distro...joke
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 06:55 PM
wireless connection dosn't work on dell inspirion 6400 after installing opensuse 10.3 doronkimchi Linux - Laptop and Netbook 2 05-03-2008 04:51 AM
opensuse 10.2 no wireless internet connection jettwa2001 Linux - Newbie 4 12-22-2007 12:58 PM
wireless connection ok with knoppix dvd , no connection with installed fedora 4 docharmony Linux - Wireless Networking 2 11-27-2005 05:33 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration