LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2011, 03:49 PM   #1
sgysin
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Rep: Reputation: Disabled
Wireless connected but not web browsing


Hi

I have ubuntu 10.10. I am connected through wireless (connection established) but I can not browse the internet on firefox. It works with out a problem when connected through the wire.
 
Old 02-26-2011, 03:56 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Verify your DNS servers, firewall, proxy....
If you have a firewall, you need to change eth0 to wlan0
Please post the output from
Code:
ping 212.100.160.51
ping google.com
Kind regards
 
Old 02-27-2011, 01:31 PM   #3
sgysin
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi

Thank you for your message:

Here is the output of the 2 commands. Please, let me know if I made something wrong. Also, could you tell me how I can check whether I have a firewall installed?

best wishes

stephan@stephan-1015PEM:~$ ping 212.100.160.51
PING 212.100.160.51 (212.100.160.51) 56(84) bytes of data.
64 bytes from 212.100.160.51: icmp_req=1 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=2 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=3 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=4 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=5 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=6 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=7 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=8 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=9 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=10 ttl=51 time=173 ms
64 bytes from 212.100.160.51: icmp_req=11 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=12 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=13 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=14 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=15 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=16 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=17 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=18 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=19 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=20 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=21 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=22 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=23 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=24 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=25 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=26 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=27 ttl=51 time=181 ms
64 bytes from 212.100.160.51: icmp_req=28 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=29 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=30 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=31 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=32 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=33 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=34 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=35 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=36 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=37 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=38 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=39 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=40 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=41 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=42 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=43 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=44 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=45 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=46 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=47 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=48 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=49 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=50 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=51 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=52 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=53 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=54 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=55 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=56 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=57 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=58 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=59 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=60 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=61 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=62 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=63 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=64 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=65 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=66 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=67 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=68 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=69 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=70 ttl=51 time=176 ms
64 bytes from 212.100.160.51: icmp_req=71 ttl=51 time=175 ms
64 bytes from 212.100.160.51: icmp_req=72 ttl=51 time=174 ms
64 bytes from 212.100.160.51: icmp_req=73 ttl=51 time=174 ms
^C
--- 212.100.160.51 ping statistics ---
73 packets transmitted, 73 received, 0% packet loss, time 72090ms
rtt min/avg/max/mdev = 173.998/175.480/181.939/1.053 ms
stephan@stephan-1015PEM:~$ ping google.com
PING google.com (74.125.224.49) 56(84) bytes of data.
64 bytes from 74.125.224.49: icmp_req=1 ttl=55 time=17.0 ms
64 bytes from 74.125.224.49: icmp_req=2 ttl=55 time=18.1 ms
64 bytes from 74.125.224.49: icmp_req=3 ttl=55 time=17.2 ms
64 bytes from 74.125.224.49: icmp_req=4 ttl=55 time=22.9 ms
64 bytes from 74.125.224.49: icmp_req=5 ttl=55 time=17.6 ms
64 bytes from 74.125.224.49: icmp_req=6 ttl=55 time=17.0 ms
64 bytes from 74.125.224.49: icmp_req=7 ttl=55 time=22.6 ms
64 bytes from 74.125.224.49: icmp_req=8 ttl=55 time=15.9 ms
64 bytes from 74.125.224.49: icmp_req=9 ttl=55 time=17.9 ms
64 bytes from 74.125.224.49: icmp_req=10 ttl=55 time=15.8 ms
64 bytes from 74.125.224.49: icmp_req=11 ttl=55 time=17.9 ms
64 bytes from 74.125.224.49: icmp_req=12 ttl=55 time=16.8 ms
64 bytes from 74.125.224.49: icmp_req=13 ttl=55 time=18.3 ms
64 bytes from 74.125.224.49: icmp_req=14 ttl=55 time=17.0 ms
64 bytes from 74.125.224.49: icmp_req=15 ttl=55 time=17.8 ms
^C64 bytes from 74.125.224.49: icmp_req=16 ttl=55 time=16.3 ms

--- google.com ping statistics ---
16 packets transmitted, 16 received, 0% packet loss, time 76439ms
rtt min/avg/max/mdev = 15.864/17.923/22.907/1.974 ms
stephan@stephan-1015PEM:~$
 
Old 02-27-2011, 09:39 PM   #4
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
Quote:
Originally Posted by repo View Post
Verify your DNS servers, firewall, proxy....
If you have a firewall, you need to change eth0 to wlan0
Please post the output from
Code:
ping 212.100.160.51
ping google.com
Kind regards
Yes, I can testify to that (if you are using firestarter for a firewall)

Code:
#-----------( Firestarter Configuration File )-----------#

# --(External Interface)--
# Name of external network interface
IF="eth1"
# Network interface is a PPP link
EXT_PPP="off"

# --(Internal Interface--)
# Name of internal network interface
INIF="tunl0"
The configuration file needs to know the interface when it starts. When you switch interfaces you will lose internet connection, but you will still be able to ping outside addresses as ICMP is probably set to allow from all connections. I know it is a pain in the neck for it to work that way, it should have been made so that it world work with network manager or ifup/ifdown to detect which interface you are switching to and pass that to the firestarter script when it starts. I used acl to give myself nonroot permission to change the firestarter configuration file and sudo permission to the firestart control applet to make it a little easier to change interfaces with out using root all the time.
 
Old 02-28-2011, 12:05 AM   #5
fair_is_fair
Member
 
Registered: May 2005
Posts: 516

Rep: Reputation: 52
Are you using wep or wpa wireless connections? If so, try to connect without encryption and see how that works.
Some wireless hardware can be stubborn with wpa. For instance, I have been able to connect to wpa wireless and not go anywhere with rt2500usb.

Open a terminal and issue the following commands:

sudo ifconfig
sudo iwconfig

These commands will give the experts a little more to go on.
 
Old 02-28-2011, 04:16 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
The output from ping is when you are connected with the wireless, right?
I means the connection is working.
Could you please post the error message when you try to surf?
Did you configured any proxy in your browser?
Try to disable ipv6 in your browser
http://thedaneshproject.com/posts/di...-in-firefox-3/

Kind regards
 
Old 03-01-2011, 09:10 PM   #7
sgysin
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi

I am sorry I think I made it wrong last time. I used the ping commands when I was on wire. Here are the commands when just wireless:

stephan@stephan-1015PEM:~$ ping 212.100.160.51
connect: Network is unreachable
stephan@stephan-1015PEM:~$ ping google.com
ping: unknown host google.com
stephan@stephan-1015PEM:~$

and here are the commands iwconfig and ifconfig

stephan@stephan-1015PEM:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11 ESSID:"salazar"
Mode:Ad-Hoc Frequency:2.412 GHz Cell: 56:61:A9:BAB:AB
Bit Rate=8 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=5/5 Signal level=-57 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

stephan@stephan-1015PEM:~$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr 20:cf:30:49:a4:3b
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::22cf:30ff:fe49:a43b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:20983873 errors:0 dropped:0 overruns:0 frame:0
TX packets:2818 errors:0 dropped:0 overruns:0 carrier:3
collisions:0 txqueuelen:1000
RX bytes:3940328 (3.9 MB) TX bytes:297243 (297.2 KB)
Interrupt:45

eth1 Link encap:Ethernet HWaddr 74:f0:6d:7e:83:c4
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1200 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:44440
TX packets:12 errors:16 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:2890 (2.8 KB)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1424 errors:0 dropped:0 overruns:0 frame:0
TX packets:1424 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:113088 (113.0 KB) TX bytes:113088 (113.0 KB)

stephan@stephan-1015PEM:~$

I have WEP 128bit

Thank you for your help.
 
Old 03-01-2011, 09:53 PM   #8
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,835

Rep: Reputation: 260Reputation: 260Reputation: 260
You probably don't have the chassis software--firmware--properly loaded in the wireless card. Usually if you can get the card to work with XP, afterward it will work in Linux. What card is it?
 
Old 03-01-2011, 10:23 PM   #9
tailieucauhinh
LQ Newbie
 
Registered: Feb 2011
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by sgysin View Post
Hi

I have ubuntu 10.10. I am connected through wireless (connection established) but I can not browse the internet on firefox. It works with out a problem when connected through the wire.
You watch configure Proxy or connection on browse
 
Old 03-01-2011, 10:27 PM   #10
fair_is_fair
Member
 
Registered: May 2005
Posts: 516

Rep: Reputation: 52
Ok. I assume you are trying to connect via a wireless router or modem.

Your info shows an adhoc connection with encryption "off".

I would try editing "network connections" in preferences, your specific connection.
1. Change 'adhoc' to 'infastructure'.
2. MTU should read "automatic".
3. IPv4 settings should read method "automatic(DHCP)".
4. IPv6 should be set to "ignore".
5. wireless security should be set to one of the wep settings. These you will have try one by one. Most likely wep 40/128.

See if that does anything for you.
 
Old 03-02-2011, 05:50 AM   #11
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
inet addr:10.42.43.1 Bcast:10.42.43.255 Mask:255.255.255.0
Are you using DHCP?
What is the ip from the router?
Are you using the same router for wireless and wired?
Why do you have 192.x.x.x for wired, and 10.x.x.x for wireless?
Please post the output from
Code:
route -n
Try to disable the firewall.

Kind regards
 
Old 03-02-2011, 06:26 PM   #12
sgysin
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi

I think you might be right that I actually have not the appropriate driver installed. I have a BCM4313 card installed and the linux driver is broadcom sta but it does not specify BCM4313 cards. I found another more recent driver from broadcom here: http://www.broadcom.com/support/802.11/linux_sta.php. I would like to install this one and see whether it works. However, I am not really sure how to install it properly. I downloaded the file and extracted it but I don't even know exactly in which directory it went.

Maybe somebody could give me more detailed instructions on how to install the driver.
Thank you very much for your help.
 
Old 03-03-2011, 01:44 AM   #13
sgysin
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
I use the same router for wire and wireless. I don't know why there are different numbers.

route-n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.42.43.0 0.0.0.0 255.255.255.0 U 2 0 0 eth1
192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth1
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Thank you.
 
Old 03-03-2011, 05:02 AM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
What is the ip from the router?
If the ip is
Quote:
192.168.1.1
you need to change the ip from your linux to the
Quote:
192.168.1.x
range, and set the default gateway to
Quote:
192.168.1.1
Do you use dhcp for the wireless?

Kind regards
 
Old 03-03-2011, 05:25 AM   #15
ryoken31
LQ Newbie
 
Registered: Apr 2007
Location: Ontario
Posts: 6

Rep: Reputation: 2
I hate to ask the obvious, but no one else has yet. Are you sure you're connected to the wireless network from YOUR router? Given that 1) The IP addressing scheme is different and 2) iwconfig indicates there's no encryption on the network you're connected to while you say you're using 128-bit WEP, it makes me wonder if maybe you're trying to connect to a neighbour's wireless network.

I'd recommend doing the following:
-Check the settings in your router when you're wired in, make sure you know the SSID, Encryption type, and Password
-Delete the wireless connection from your Network Manager
-Scan for networks and connect to the wireless network with the same SSID you pulled from your router

Hopefully this helps.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Network Connected, But Firefox Not Browsing kanodiapawan Linux - Networking 3 02-02-2010 08:00 AM
Web-browsing keys on Intellipoint 3.1 Optical Mouse (NOT wireless) henrywm Linux - Hardware 4 11-17-2006 06:11 PM
access web on a laptop connected to a web-connected desktop bluesmanu Linux - Networking 2 04-16-2006 01:38 PM
Web browsing... ade Linux - General 3 01-11-2003 08:58 AM
Web browsing question Avatar2U Linux - General 1 01-16-2002 05:46 AM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration