LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Wireless card will not obtain an ip address. Card has functioning driver and firmware (http://www.linuxquestions.org/questions/linux-newbie-8/wireless-card-will-not-obtain-an-ip-address-card-has-functioning-driver-and-firmware-565206/)

tuffstuff 06-28-2007 05:45 PM

Wireless card will not obtain an ip address. Card has functioning driver and firmware
 
I've looked far and wide and I've read many pages I could barely understand. Yet I have not been able to properly configure my wireless card in Debian Etch. The lights blink and my KWiFi Manager receives a single from my router, but I cannot connect to it nor can I obtain an ip address. It has come to my attention that there is a possibility that my Ethernet card could be a conflicting factor but I do not know how I might amend this. Here is my ifconfig and my iwconfig. Any hint or help is appreciated.

Code:

eth0      Link encap:Ethernet  HWaddr 00:15:F2:9D:23:70
          inet addr:192.168.8.21  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::215:f2ff:fe9d:2370/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:73805 errors:0 dropped:0 overruns:0 frame:0
          TX packets:62562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:62483475 (59.5 MiB)  TX bytes:54935809 (52.3 MiB)
          Interrupt:169

eth1      Link encap:Ethernet  HWaddr 00:0C:E5:53:12:F4
          inet6 addr: fe80::20c:e5ff:fe53:12f4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:53 overruns:0 frame:0
          TX packets:100 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:14630 (14.2 KiB)
          Interrupt:3 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3944 (3.8 KiB)  TX bytes:3944 (3.8 KiB)

Code:

debian:/home/house# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:"ACTIONTEC"  Nickname:"Broadcom 4306"
          Mode:Managed  Frequency=2.452 GHz  Access Point: 00:0F:B3:54:1E:B3
          Bit Rate=11 Mb/s  Tx-Power=19 dBm
          RTS thr:off  Fragment thr:off
          Encryption key:B100-0000-00  Security mode:open
          Link Quality=100/100  Signal level=3/3  Noise level=186/100
          Rx invalid nwid:0  Rx invalid crypt:53  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

sit0      no wireless extensions.


Agrouf 06-28-2007 06:47 PM

did you try "dhclient eth1"?

Junior Hacker 06-28-2007 07:00 PM

Kwifi could not obtain an IP address for me neither when the AP had no encryption, I have to go through network manager and highlight the interface in administrator mode and select "configure interface", click on "manual", then back on "auto", and click OK, then click on Apply in the main network manager window for it to get an IP. Then every time after when in range of that network, kwifi links up, but once I go through network manager to set up for another AP when in a different location, settings will now be automatic for the second, not the first AP I configured. You could setup profiles for kwifi and just activate the profile for the AP you are trying to access.
You should also rean man interfaces to see how to setup /etc/network/interfaces


All times are GMT -5. The time now is 03:26 AM.