LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-16-2004, 05:17 PM   #1
hawk1982
LQ Newbie
 
Registered: May 2004
Location: Kissimmee, FL
Distribution: Slackware 10.0
Posts: 2

Rep: Reputation: 0
wine: relocation error: /usr/local/lib/libntdll.so


Hi,

I use Slackware 10 and have installed the Wine-20040716-i686-S10nodebug.tgz package for slack.

I have the following question: wine comes up with the following error:
wine: relocation error: /usr/local/lib/libntdll.so: undefined symbol: casemap_lower

Although I usally find it a challange to solve these problems I cannot find the sollution for this one.

I have tried the following: Uninstall, Reinstall same package. Use an older package. Use rpm2tgz to convert a RPM package to tgz and install it. Didi not mak ea difference. I Did a whereis on libntdll.so and it is in the correct location. I have tried to overwrite the new .wine dir with an older working .wine backup I had made this also did not work.

I have also searched the web, but could not find any anwers
I am a newbie and do not know if there are further steps I should try

If someone has the time to help

Thank you in advance
 
Old 08-17-2004, 07:18 AM   #2
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Install from the source, it seems you have a broken package.
 
Old 08-17-2004, 10:08 AM   #3
hawk1982
LQ Newbie
 
Registered: May 2004
Location: Kissimmee, FL
Distribution: Slackware 10.0
Posts: 2

Original Poster
Rep: Reputation: 0
Works...only wrong version

Thanks,

It now works. I had a problem with my Nvidia card which also gave an error in wine so it changed the X config file and now it works.

There is however a small problem, although I removed any traces, packages, etc of any other version of wine I had before it still uses an older version of wine after compiling and installing a new one, but at least it works. I'll try and figure out how to get the new version to install and work.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 06:07 PM
Installing software, /usr/lib directory and /usr/local millertime Linux - Software 2 07-10-2004 10:21 AM
/usr/lib and /usr/local/lib doxxan Slackware 5 06-15-2004 01:58 AM
KDE 3.2 and relocation error: /usr/lib/libkdeui.so.4 pradsy90 Linux - Security 2 03-11-2004 02:12 AM
dcgui-qt: relocation error: /usr/lib/libqt-mt.so.3: undefined symbol: glXGetConfig akqw Linux - Software 0 10-05-2003 11:30 AM


All times are GMT -5. The time now is 03:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration