LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2006, 01:54 AM   #1
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Rep: Reputation: 30
Wine problem in SUSE 10.0


I had no problems installing wine and tested sol.exe fine. I have a 850 mhz computer with 256 mb ram, 8 mb ati video and maestro3 sound. The games ran fine in windows which I dual booted the computer with. The thing is older games ran but skipped in wine with these messages in the terminal:

fixme:dsoundSOUND_MixOne problem with underrun detection (mixlen=8820 < primary_done=13294)
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x403baa58)->(0x10024,00000008)
fixme:d3d_surface:IWineGDISurfaceImpl_Blt Can't handle DDBLT_WAIT flag right now.
fixme:d3d_surface:IWineGDISurfaceImpl_Blt Can't handle DDBLT_ASYNC flag right now.
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
err:dsoundSOUND_MixOne underrun on sound buffer 0x4042cc38
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x403baa58)->(0x10024,00000008)
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x403baa58)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock

This happened on different games I ran. I assume that it has something to do with direct x. Is the computer too old to run emulated games? Please help me.
Thanks, bhert

Last edited by bhert; 07-30-2006 at 05:34 AM.
 
Old 07-30-2006, 05:16 PM   #2
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Original Poster
Rep: Reputation: 30
Hello, Doesn't anyone know?
 
Old 07-31-2006, 08:03 AM   #3
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
First thing: What version of Wine are you using?

Suse 10.0 comes with a pretty old alpha version, and they don't update it to the latest version using Yast.

If you're still using the version Suse provides, you should hunt down a Suse-compatible RPM of the latest version.

Quote:
This happened on different games I ran. I assume that it has something to do with direct x. Is the computer too old to run emulated games? Please help me.
It certainly isn't a speed issue. If the computer is fast enough to run the game under Windows, then it's fast enough to run it under Wine. Wine may have its faults, but being slow isn't usually one of them.

It could be to do with DirectX. That is a definite issue you'll have running games under the standard version of Wine. Getting the latest Wine version will help, but to run some games (even some fairly old ones), it's possible you'll need Cedega (which is a commercial version of Wine, with their own enhancements specifically aimed at improving game compatibility).

The Wine website has a section for software compatibility where you can check specific games to see how well they work. If you're having problems with particular games, that would be a good place to look.

Hope that helps
 
Old 07-31-2006, 03:59 PM   #4
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Original Poster
Rep: Reputation: 30
Thanks for the tip spudley! I had a guy at work that uses Cedega at home and he plays the latest games with no problems. I will give it a try. BTW, I was using the latest version of wine with rpm Thanks anyways.

Last edited by bhert; 07-31-2006 at 04:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 10, Wine, Install Problem david.dales Linux - Software 1 03-01-2006 01:46 PM
Suse 10.0 _ Wine problem ? tetracilin Linux - Hardware 0 02-24-2006 08:17 AM
Link targets - problems with Wine (Though not Wine specific - Wine site doesn't help) Kevjml Linux - Newbie 1 01-13-2006 08:53 AM
Problem with Wine on SuSE Tears Of Blood Linux - Software 11 12-12-2004 02:56 PM
wine problem with suse shamz Linux - Software 2 09-07-2003 05:38 PM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration