LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-20-2005, 07:15 AM   #1
Jan_W
LQ Newbie
 
Registered: Mar 2003
Location: Leuven/Belgium
Distribution: Fedora Core 3
Posts: 16

Rep: Reputation: 0
Wine/glibc failed dependencies


Hi,

I have a problem installing Wine (actually upgrading glibc, but let's start with the beginning :-)). I downloaded the latest i686.rpm file and tried to install it.
It gave an error:
Failed dependencies:
glibc >= 2.3.2-27.9.7 is needed by wine-20050211.1rh9winehq

So i tried to upgrade glibc to this version. I downloaded glibc-2.3.2-27.97.i686.rpm, glibc-common-2.3.2-27.9.7.i686.rpm and glibc-devel-2.3.2-27.9.7.i368.rpm (I didn't find an rpm for the i686 structure. Can i use the x86_64.rpms, or are those only for the athlon 64?)
and tried to instal it (rpm -Uvh glibc-2.3.2-27.97.i686.rpm glibc-common-2.3.2-27.9.7.i686.rpm glibc-devel-2.3.2-27.9.7.i368.rpm)
This also gave an error:
Failed dependencies:
glibc = 2.3.2-11.9 is needed by...
glibc-devel = 2.3.2-11.9 is needed by...

So I downloaded glibc-2.3.2-11.9.i386.rpm, glibc-common-2.3.2-11.9.i386.rpm and glibc-devel-2.3.2-11.9.i368.rpm (again, no rpms for the i686 structure). I installed it and it worked. I, again tried to upgrade it to version 27.9.7.
Again, it gave me an error:
Failed dependencies
glibc = 2.3.2-11.9 is needed by (installed) glibc-debug-2.3.2-11.9
glibc = 2.3.2-11.9 is needed by (installed) glibc-utils-2.3.2-11.9
glibc-devel = 2.3.2-11.9 is needed by (installed) glibc-debug-2.3.2-11.9
glibc-devel = 2.3.2-11.9 is needed by (installed) nptl-devel-2.3.2-11.9

I tried to install the 2.3.2-11.9 version again (maybe it didn't install correct), but i received a message that it already was installed. Now I'm out of ideas. Anyone who knows what the problem is?
Thanks,

Jan

Last edited by Jan_W; 03-20-2005 at 07:47 AM.
 
Old 03-20-2005, 05:13 PM   #2
mjuhannus
Member
 
Registered: Sep 2004
Location: Finland
Distribution: Ubuntu 10.04, Debian 5, OpenSUSE 11.3
Posts: 60

Rep: Reputation: 15
You just have to update all the packages with failed dependencies. Or is there a particular reason for you not to update nptl-devel?

So, get new versions of nptl-devel and glibc-debug. Then add them to your
rpm -Uvh ....

Also I want to mention tools called apt and synaptic, they save you a lot trouble and carries you out of the 'rpm dependency hell'.

And about the packages i386 will work just fine, which I believe 64-bit versions will not do.

Last edited by mjuhannus; 03-20-2005 at 05:15 PM.
 
Old 10-28-2005, 10:07 PM   #3
amumu
LQ Newbie
 
Registered: Oct 2003
Location: Shanghai, China
Distribution: RedHat9.0
Posts: 18

Rep: Reputation: 0
I have the same problem

Hi,
I have the same problem as you met, did you solve it?
Pls let me know: feng.w.qin@gmail.com

Thanks in advance!
 
Old 10-29-2005, 09:25 AM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
glibc is the core library everything is linked to and includes even the linker itself
the only way to upgrade it is to use apt or something and esentially upgrade everything
it would be easier to just compile your own new wine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare Suse/Novell 3 11-29-2004 02:13 PM
sash glibc circular dependencies twosider Mandriva 2 08-09-2004 03:58 AM
failed dependencies david2 Linux - Newbie 2 04-08-2004 06:16 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM
Intel Fortran Compiler - glibc dependencies bad damien Linux - Software 1 12-02-2003 11:19 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration