LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2004, 11:18 AM   #1
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
Angry wine + arts = no sound?


I've recently read that to make multiple programs play sounds at one time I could use arts driver. I've configured arts and it seems to be working - xmms and frozen bubble both play music at the same time. But when I want wine or wineX to use arts sound driver (by changing in the winmm section the driver to winearts) I'm getting no sound. What's the problem?
I have Creative AudioPCI 128 with ens-1371 driver and, as it seems to be, mu SuSE 9.0 uses ALSA, although wine or winex' WineOSS driver works too (but then I can't play multiple sounds).
 
Old 05-10-2004, 11:55 AM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
arts.....
its fine for knocking out one off pings and pongs on your desktop manager.

but awfull at the type of continuous and multi chanel stuff you need for games.

arts is a kde program.... use the proper kernel driver.... either OSS or ALSA.

2.4 kernels tend to use OSS
2.6 kernels tend to use ALSA.

alsa is replacing OSS, and is available for 2.4 kernels.

but either are far better than arts.

oops, just saw you said you are using ALSA.

great, kill arts and let your games access alsa directly, without arts getting in the way.
 
Old 05-10-2004, 12:37 PM   #3
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
A decent way of shutting arts will be:
artsshell -q terminate

then run ur wine/wineX stuff, also try to avoid all kinds of sound servers (daemons) since they create a lot of latency problems!!
 
Old 05-10-2004, 03:01 PM   #4
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by vinay_s_s
A decent way of shutting arts will be:
artsshell -q terminate



killall artsd works as well
I've been doing so already, and it works. But I can't play background music at the same time I play games, while arts allows multi-sounding. Is it possible to use "multi-sounding" without arts?
 
Old 05-11-2004, 02:26 AM   #5
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
Well if ur snd card doesnt support hardware mixing, then u'll have to struggle.
since i noticed that u have a ens1371, i can help u in a simple way:
1) use xmms to play background music (or u can use mplayer, which supports ALSA)
2) in xmms, choose o/p plugin as alsa, then click on configure, then choose audio device as hw:0,1
3) say yes , then start playing in xmms,
4) then start ur games in wine , u will be able to hear it all
 
Old 05-11-2004, 02:32 PM   #6
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Original Poster
Rep: Reputation: 30
Thanx, I'll try it out at weekend, only then I have access to my home pc where the problem is. I hope I'll be able to use winamp as well as xmms.


Should I use winealsa.drv in wine or wineoss? For now it works with wineoss (it's strange because when I type in lsmod I get snd-xxxx drivers, that's why I said I have ALSA, and in KDE control center all devices are marked as ALSA devices - I didn't install ALSA drivers myself, they must 've been automatically installed when I installed SuSE)
 
Old 05-12-2004, 02:26 AM   #7
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
yes suse comes with ALSA, and use xmms, not winamp, alsa comes with oss emulation (meaning oss apps can run as usual)
 
Old 06-07-2004, 04:22 PM   #8
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
just a thought - stop being so brutal with your arts server, 'artsshell -q supend' will release the BIO devices without killing artsd. it makes it a lot faster.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Server, ArTs, no sound FC4 javb Fedora 7 09-22-2005 01:30 PM
sound working, aRts is not MuSHi Linux - Hardware 1 01-13-2005 06:32 PM
arts sound server darkleaf Linux - Software 3 11-19-2004 10:12 AM
arts freezes! Sound only with mplayer + arts disabled metgorna Mandriva 0 09-18-2004 10:21 AM
ARTS sound under fvwm95 is it possible? mortal Slackware 0 03-20-2004 05:59 PM


All times are GMT -5. The time now is 12:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration