LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2008, 04:19 PM   #1
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Rep: Reputation: 15
windows xp + debian etch thunderbird help


Hi
I followed the tutorial called the Perfect Setup for Debian Etch and all seemed ok. My network consists of the Debian server 192.168.0.102 (static) and an XP box 192.168.0.101 (static) behind a Dlink router. My ISP address is static. I opened ports to allow pop 110 and smtp 25 to my server. I have a user account I'll call 'newbie' on my server. I can log in with user 'newbie' and read mail in var/log/newbie. I downloaded Thunderbird on my xp box because I do not like outlook. My ISP is earthlink and i have made the changes to main.cf in Postfix to use earthlinks smtp server. I've also created sasl_passwd and added my ISP username and password. I configured Thunderbird to use smtpauth.earthlink.net but when I click on 'Get Mail' I receive a window with 'please enter your password for user newbie for 192.168.0.102 but the password does not work. Can someone please tell me why? At the moment that is my main problem pulling user newbie mail from my debian server with a mail client on my xp box.

thank you
 
Old 03-18-2008, 04:44 PM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Don't you have to configure thunderbird to use Debian server and not your ISP mail server?
 
Old 03-18-2008, 05:07 PM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I'm kind of lost as well. You typically either use your ISP mail or your run your own mail server, but you typically don't use one through the other (but you can). Some people forward messages to their ISPs mail server and then from there they get delivered. However some ISPs (and my guess is that earthlink would fall into this category) will not allow that configuration, it feels too much like allowing spam through. So if you are going to be running your own mail server and not route traffic through your ISPs mail server, then you don't need your ISP mail settings in your Postfix conf files. Postfix is your mail server. You send mail directly to other mail servers (depending on the recipients @DOMAIN.TLD).

HTH

-Chad
 
Old 03-18-2008, 05:09 PM   #4
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
thanks for the reply alan_ri ...I made changes to thunderbird still getting the same error message 'sending of password did not succeed. Mail server 192.168.0.102 responded: chdir Maildir failed. What other info can i give you to help troubleshoot this?
 
Old 03-18-2008, 05:20 PM   #5
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
I have to log out,I will talk to you tomorow,did you configured Debian server properly to accept XP connections,whatever they are?

Last edited by alan_ri; 03-18-2008 at 05:22 PM.
 
Old 03-18-2008, 05:25 PM   #6
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
thanks for the reply MasterC I changed the settings in thunderbird but still get the same error message (see previous post). Why can't I log onto my mail server from my windows box with the user account that is setup on my server? I had used successfully (old server)used smtpauth with sendmail to relay my mail through earthlinks mail server. I'm trying to accomplish the same scenario but I'm still green to Debian and Postfix.
 
Old 03-18-2008, 05:38 PM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, I think it makes a little more sense now after I read it a couple more times. Can you post up your postconf -n output? Ensure pop (or imap depending on which one you are trying to use) is running on your debian box (I prefer courier-imap, and generally IMAP overall). Also you can try telnetting to your debian box from a Windows command prompt on port 110 (or 143) to see if you get a response.

-Chad
 
Old 03-18-2008, 05:49 PM   #8
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_command =
mailbox_size_limit = 0
mydestination = docean.selfip.net, localhost.selfip.net, localhost.localdomain, localhost
myhostname = docean.selfip.net
mynetworks = 127.0.0.0/8,192.168.0.100/8
myorigin = $mydomain
recipient_delimiter = +
relayhost = [smtpauth.earthlink.net]
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom


telnet docean.selfip.net 110..+OK Hello there
 
Old 03-18-2008, 06:10 PM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You have Maildir in the above config but in your first post you refer to /var/mail/user Check your pop settings to ensure you are trying to retrieve mail from the correct location.

Other than this I would guess it's some sort of PAM issue? But my first guess is that the above 2 discrepancies are causing your problem.

-Chad
 
Old 03-18-2008, 06:46 PM   #10
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
so home_mailbox = Mailbox? I've tried ip address and dns name in pop settings
 
Old 03-18-2008, 06:57 PM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
It depends on the type of mail (mbox vs maildir). Maildir is fine, you just have to set it up that way. It can be /home/user/awesomeness if you want. You just have to configure it that way throughout your mail applications (your pop and postfix servers in this case).

-Chad
 
Old 03-18-2008, 07:03 PM   #12
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
thanks the tutorial i followed specified maildir but i'm still puzzled why I cannot log onto my server from my mail client?
 
Old 03-19-2008, 06:22 AM   #13
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
You should find your answer on this link; http://workaround.org/articles/ispmail-etch/#step-2-create-the-database-and-user
 
Old 03-19-2008, 02:11 PM   #14
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
I already followed that tutorial thanks alan_ri...I fail to understand how that relates to logging onto a mail server within a lan with the user account that is setup on the server? I thought about MasterC posts and I do not need to use earthlinks smtp server as a relay since I've setup an 'ISP' style server I have the backend components in place...the tutorial I followed states that I have to send an email first to a new account before I can fetch mails. Maildir is created automatically once the first email arrives. I sent one last night from my hotmail account and got this reply:

This is an automatically generated Delivery Status Notification.

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipients has been delayed.

daniel@docean.selfip.net

I made the necessary change to thunderbird and I still cannot log onto the server with username daniel and password. I've checked pop settings and hostname..everything ..when I ran a slackware server with sendmail all i had to do was make changes to /etc/hosts.allow which i've done in debian..any suggestions would be greatly appreciated
 
Old 03-19-2008, 02:34 PM   #15
Raidmax
Member
 
Registered: Nov 2005
Distribution: Mandrake 10.0
Posts: 53

Original Poster
Rep: Reputation: 15
I can telnet from my WINDOWS box to port 110 +OK Hello there, but when I try port 25 i get nothing...checked my firewall same setting for both...telnet 25 on my server

telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 docean.selfip.net ESMTP Postfix (Debian/GNU)
ehlo 25
250-docean.selfip.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows in VMWare on Debian Etch: any Gotchas? oldtlhingan Linux - Newbie 7 02-18-2008 01:06 PM
Windows XP -> Debian Etch = Best thing I ever did Virtuality General 6 12-16-2007 11:26 AM
LXer: Installing Debian Etch From A Windows System With "Debian-Installer Loader" LXer Syndicated Linux News 0 09-28-2007 01:41 AM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 11:02 PM
Debian Sarge to Etch Upgrade Caused X Windows to Not Start sabot Debian 1 04-11-2006 05:24 PM


All times are GMT -5. The time now is 09:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration