LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2014, 09:59 AM   #1
Train
Member
 
Registered: Mar 2014
Distribution: Crunchbang
Posts: 44

Rep: Reputation: Disabled
Question Windows Time Changes


On one of my computers, I have Windows 7 and Linux.

When I boot into Linux and then reboot (later on) into Windows 7, my time in Windows 7 changes to around 6 hours in the future.


Is this a problem with Windows, or something else?
 
Old 06-03-2014, 10:22 AM   #2
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,099

Rep: Reputation: 343Reputation: 343Reputation: 343Reputation: 343
Hi there,

Quote:
Originally Posted by Train View Post
On one of my computers, I have Windows 7 and Linux.
When I boot into Linux and then reboot (later on) into Windows 7, my time in Windows 7 changes to around 6 hours in the future.
so I guess your location is 90 west of the Greenwich meridian, perhaps somewhere in the eastern third of the USA?
The point is that Windows assumes the real-time-clock to be running on local time, while Linux usually has it on UTC.

However, I'm dimly aware that you can change this behavior in Linux, so that it treats the clock the same way as Windows.

[X] Doc CPU
 
Old 06-03-2014, 11:24 AM   #3
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
I think it is because your Linux is set up to UTC time and Windows is set up to Local time.

Make them match and you wouldnt have that problem any more
If you want Linux to be in the local time you can try as root

Quote:
Code:
 date --set "5 Aug 2012 12:54 IST"
Obviously in the above command you must set your date, time and time zone correctly.

Now as root, synchronize the hardware clock to the current system time as local time.

Code:
 hwclock --systohc --localtime
That is from our friends at the Slackware site, in your distro it might work the same way or you have to search the topic for your distro.

Last edited by TroN-0074; 06-03-2014 at 11:33 AM.
 
Old 06-04-2014, 10:15 PM   #4
maples
Member
 
Registered: Oct 2013
Location: IN, USA
Distribution: Arch, Debian Jessie
Posts: 810

Rep: Reputation: 264Reputation: 264Reputation: 264
I recently had the same problem with my Win8 laptop. During the install, I set the hardware clock to localtime. Apparently, though, Windows 8 keeps the hardware clock in UTC. So if setting the clock to local time doesn't fix it, try setting it to utc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP time sync with windows 2000 AD time csghosh Linux - Enterprise 7 02-24-2012 04:46 PM
how to understand user time, sys time, wait time, idle time of CPU guixingyi Linux - Server 1 08-24-2010 11:10 AM
why does time of windows chnages when linux time is set ankitp Linux - Newbie 3 08-04-2008 04:02 PM
Long time Windows users, first time Linux user Towjam LinuxQuestions.org Member Intro 1 06-21-2008 01:08 PM


All times are GMT -5. The time now is 02:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration