LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2005, 03:05 AM   #1
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Rep: Reputation: 15
Windows Partition


Hey.

I have a mounted windows partition full of music. I want to be able to play these as the current user and not have to log into root.

When i go to access it i get

Code:
-bash: cd: /win/music: Permission denied
I tried changing the owner with

Code:
chown -R me music/
And i still cant access it

Any help?
 
Old 10-09-2005, 03:51 AM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora
Posts: 1,829

Rep: Reputation: 257Reputation: 257Reputation: 257
in /etc/fstab


Windows Partition Mount Point File System
/dev/sda3 /win/music NTFS

Options fsck order
ro,users,noauto,umask=0555,gid=users,nls=utf8 0 0

Then, as root

chmod a+rx /win/music

Then, as root

mount /win/music

The mount command is all you have to use after that. If you take "noauto" out of the /etc/fstab options for that drive it will automount.

See how that works for you. I have every confidence in you.
 
Old 10-09-2005, 03:53 AM   #3
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Try this chown command (run as root):
Code:
chown -R <user>:users /media
Where <user> is your username. Is the Windows partition FAT32 or NTFS? This might be of some help if it's NTFS, if it's FAT32 then making sure your user has read access to the mountpoint should be all that is required.
 
Old 10-09-2005, 03:56 AM   #4
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Beaten And that's a much better answer anyway, it came from somebody who has actually mounted an NTFS partition under linux clearly
 
Old 10-09-2005, 04:23 AM   #5
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Hey.

I did that, but it didnt work.

So i unmounted /win/music and attempted to mount it again but got:

Code:
mount: unknown filesystem type 'nls=utf8'
 
Old 10-09-2005, 06:06 AM   #6
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
my fstab reds:

/dev/hda7 /mnt/windows/f fat uid=501,gid=501,umask=000,utf8,exec,dev,suid,rw 0 0

The umask options are the opposite of permission codes 777 equals 000 - if that makes any sense), so my windows partition is set to be accessible to all. However I had to set some user specific ownership options (uid and gid) in order to make amule stop complaining.
 
Old 10-09-2005, 07:27 AM   #7
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks for that.

However, i still cant run it under anything other then root

I tried chown(ing) to my user but it didnt do anything, the owner is still root
 
Old 10-09-2005, 07:32 AM   #8
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
did you check you users gid and put it in fstab?

chown will not work as the fat file system doesn't support file permissions.
 
Old 10-09-2005, 07:38 AM   #9
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Quote:
chown will not work as the fat file system doesn't support file permissions.
However the user does need permission to access the mount point itself so the chown is necessary. The -R flag is kinda redundant but a little for good measure never hurt anything. The FAT32 filesystem isn't the one in question though, care to read the original post?
 
Old 10-09-2005, 07:57 AM   #10
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
let me rephrase that:

chown will not work on the FAT file system
it will (if such is the case) on the mount point or folder

(I imagine you refer you your original post as the threads original post doesn't even mention a filsystem type)
 
Old 10-09-2005, 08:52 AM   #11
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Quote:
Originally posted by linmix
(I imagine you refer you your original post as the threads original post doesn't even mention a filsystem type) [/B]
Ahh, you're right. I apologise, I was thinking of another thread around here on a similar topic. Similar questions being asked all the time, I got confused. Sorry
 
Old 10-10-2005, 03:57 AM   #12
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Yeah yeah my bad.

FS = NTFS
 
Old 10-10-2005, 11:29 AM   #13
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
So you gotr it working then? Good for you!
 
Old 10-11-2005, 04:17 AM   #14
Casket
Member
 
Registered: Jul 2005
Location: Australia
Distribution: Slackware 10.1 - 2.4.29
Posts: 79

Original Poster
Rep: Reputation: 15
Naw, unfortuantly it can still only be accessed from root.

Thanks anyway though guys
 
Old 10-11-2005, 05:40 PM   #15
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Doesn't make sense. If it can be done as root there must be a way to do it as a normal user.
What is your exact fstab line at the moment?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
moving files from windows partition to linux partition M O L8ingN2dust Linux - Newbie 11 01-08-2006 10:11 PM
How can I access files in my Windows 98 partition from my Linux partition, /w BASH? Fabyfakid Linux - Newbie 4 09-18-2004 12:05 AM
I want to increase my Linux partition.Should I take space from a Windows partition? PrinceBalak Linux - General 1 06-25-2004 06:44 PM
What is the code to copy a file from my windows partition to my linux partition? THEBIGFISH Linux - Newbie 3 03-15-2004 11:14 PM
How do I install slackware on a partition made by partition magic in windows bling bling Slackware 4 06-29-2003 12:16 AM


All times are GMT -5. The time now is 10:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration