LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2004, 12:33 AM   #1
ScottUT
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Rep: Reputation: 0
windows mount not staying after reboot - fstab looks OK


windows mount not staying after reboot - fstab looks OK

Running the mount manually:

mount /dev/hda1 /windows/C -t ntfs -r-o umask-0222

and then a "ls -l /windows/C" works fine.

After shutdown or restart the /var/log/messages, /var/log/boot.msg files and "dmeg | greb NTFS" shows several similar errors.

messages:

NTFS-fs error (device 03:01): parse_options(): Unrecognized mount option code
NTFS-fs error (device 03:01): parse_options(): Option iocharset is deprecated. Please use the "nls=<charsetname> in the future.
NTFS-fs error (device 03:01): parse_options(): Unrecognized mount option code

boot.msg:

<6>NTFS driver 2.1.4a [Flags: R/O MODULE]
<3>NTFS-fs warning (device 03:01): parse_options(): Option iocharset is deprecated. Please use the "nls=<charsetname> in the future.
<3>NTFS-fs error (device 03:01): parse_options(): Unrecognized mount option code

dmesg | greb NTFS:

NTFS-fs error (device 03:01): parse_options(): Unrecognized mount option code
NTFS-fs error (device 03:01): parse_options(): Option iocharset is deprecated. Please use the "nls=<charsetname> in the future.

"fstab" file looks like this:

/dev/hda3 / reiserfs defaults 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/dvd /media/dvd auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

Something about either a "unrecognized mount option code" or the "nls" character set that is attempted to be read from the fstab file may be the problem, but the man pages don't seem to speak to that very well.

Thanks in advance for the help.
 
Old 01-21-2004, 12:57 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

change that to

/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002 0 0
 
Old 01-21-2004, 08:56 AM   #3
ScottUT
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
I've entered the syntax as instructed and from the messages file I get "NTFS-fs error (device 03:01): parse_options(): Unrecognized mount option code 0"

At least it's indicating it doesn't understand what mount option code it is having an issue with (0).

Another suggestion on a alternate code type to try? (thx)
 
Old 01-21-2004, 09:04 AM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
try umask=002
that's the only place i see zero's in what's above.

this is what's in your options column in fstab?
ro,users,gid=users,umask=0002

maybe you accidently put a space after umask= 0002 or something

i was just taking the iso junk out of the options
 
Old 01-21-2004, 01:37 PM   #5
ScottUT
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
And the answers are:

/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=002
or
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002

Removed everything past the "=002" or "0002" and it worked

Thank you whansard
 
Old 01-21-2004, 07:01 PM   #6
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
those last 2 0's on the line after the umask are for other things.
the first one is for whether dump should backup the drive, and
the last one is for whether the drive should be checked at boot
and in what order.

the umask number is octal, if you know what that is.

since the drive is ntfs, you don't want to check it, and you can't
dump it, so the last 2 columns don't matter anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
permissions not staying using chmod after reboot dr_zayus69 Linux - Software 6 08-20-2005 03:34 AM
/etc/fstab can't mount Windows XP Zeppelin_ii Linux - Software 4 07-21-2005 12:12 PM
using fstab to mount windows xp shares yeateke Linux - Networking 4 03-01-2004 08:19 AM
windows mnt not staying Mad Mardigan Linux - Software 2 01-20-2004 11:29 PM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration