LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-07-2005, 11:20 AM   #1
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Rep: Reputation: 0
Unhappy Windows loads instead of Mandrake!?!


I probably didn't set something up righ, but when i boot my computer no boot-menu comes up to choose between Mandrake and Windows, so it boots directly to Windows. I set up linux so i have the / partion on the hard drive with windows. What could I have done wrong( and what is ACPI)?

Plz help
and Thank You in advance!!!
 
Old 05-07-2005, 11:29 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Did you choose to not install lilo? If you didn't, did you make a boot floppy?

Use your install (or any Linux Live CD, a copy of Knoppix if very handy to have) in the rescue mode and run lilo to install it to the mbr of the hard drive.

If you have a boot floppy, just boot into mandrake, su - to become root and run /sbin/lilo. Make sure your /etc/lilo.conf (I think) is set up correctly.

# ARRGH! I hosed my box!
LILO fails: Error messages and their interpretation
LILO mini HOWTO
Multiboot with LILO HOWTO
LILO, Linux Crash Rescue HOW-TO
Installing a bootloader

# Mandrake links
Mandrake home page
Mandrake Users website (needs money to access now)
Software management configuration: Easy urpmi config for Mandrake
Software management: urpmi mini-HOWTO
Software management: All You Ever Wanted to Know About Urpmi But Never Dared Asking Before
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page
 
Old 05-07-2005, 11:46 AM   #3
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Ummm, IM using Mandrake 10.1, so i never saw anything about lilo. Im still confused...
 
Old 05-07-2005, 12:03 PM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Boy, you really read those links really, really fast. Are you sure you did the clickys?

Upon install, did you make a boot floppy? If so, set your bios to boot first from floppy, insert boot floppy and reboot.

1. Log in user account
2. open an x terminal
3. type su - then enter
4. type root password, then enter
5. examine /etc/lilo.conf and make sure it is correct
6. type lilo then enter.

Then install lilo, making sure that /etc/lilo.conf is correct.

Last edited by fancypiper; 05-07-2005 at 12:05 PM.
 
Old 05-07-2005, 12:06 PM   #5
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
I didnt make boot floppy.
 
Old 05-07-2005, 12:14 PM   #6
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
...and i want to use GRUB, i've never heard of lilo before... i think...
 
Old 05-07-2005, 12:15 PM   #7
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Perhaps one of these Linux Google hits will help.

Last edited by fancypiper; 05-07-2005 at 12:22 PM.
 
Old 05-07-2005, 12:16 PM   #8
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Grub stuff:

Installing a bootloader
Multiboot with GRUB Mini-HOWTO
Linux+Win9x+Grub HOWTO
KNOPPIX Linux Live CD
 
Old 05-07-2005, 12:26 PM   #9
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Re: Windows loads instead of Mandrake!?!

Quote:
Originally posted by K0K0NUT_h3lmut
and what is ACPI?
ACPI - Advanced Configuration and Power Interface
 
Old 05-07-2005, 02:20 PM   #10
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
OK, I got mandrake up and running, BUT when i boot to Mandrake i see this nice pretty status bar and then some colored words showing the system startup and asking me for file sytem check or not. After that when what appears to be a succesful boot-up appears a black screen with these words:


Mandrakelinux release 10.1 (Community) for i586
Kernal 2.6.8.1-10mdk on an i686 / ttyl
localhost login:_


Ummm...ok... where's KDE, where's wonderful GNOME. Where are the GRAPHICS?!?!
 
Old 05-07-2005, 02:24 PM   #11
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,276

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Perhaps you didn't set your machine to start the X server on boot. Anyhow, you can go ahead and login and type "startx" (no quotes) at the command prompt to bring up the GUI. If it works, open up /etc/inittab and change the line that looks like:

id:3:initdefault:

to

id:5:initdefault:

If typing startx doesn't work, then that explains the issue, and something is borked with your X configuration. You can try re-running xorgconfig to generate a usable X configuration, but there may be a better way in Mandrake (which I don't personally use).
 
Old 05-07-2005, 02:34 PM   #12
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Don't forget to login first.

Type in your user name and give the password when asked for it.

The GUI can then be started by the command startx.

You may wish to create an .xinitrc file and put it in your home directory.
Code:
# Duron 950 box "tinwhistle" user fancy .xinitrc file
# Start the stuff I want to run when I startx
                                                                                                                     
# The artwiz-fonts sometimes conflict with your locale settings. To get
# them to work you may have to put the following at the beginning of your
# .xinitrc file
export LC=C
export LC_ALL=C
                                                                                                                     
# Start gkrellm and put it in the slit
# When configured correctly, gkrellm will run fetchmail the fetchmail daemon
# if you have a .fetchmailrc file correctly set up with permission of 600
gkrellm -w &
                                                                                                                     
# Start the keyboard hotkeys
/usr/bin/acme &
                                                                                                                     
# Run the Gnome panel
gnome-panel &
                                                                                                                     
# This will run a screensaver as your background
# /usr/X11R6/lib/xscreensaver/hopalong -root &
                                                                                                                     
# Start the screensaver daemon
screensaver -no-splash &
                                                                                                                     
# Finally, I start my window manager
# Fluxbox that I installed by compiling from source code
exec /usr/local/bin/fluxbox
# Fluxbox that I installed by rpm
# exec fluxbox
# exec kde
# exec gnome-session
                                                                                                                     
# Sample .xinitrc entries for starting evilwm
# Merge X resources from ~/.Xdefaults
# [ -f $HOME/.Xdefaults ] && xrdb $HOME/.Xdefaults
# Set the background and root cursor shape
# xsetroot -solid \#400040
# xsetroot -cursor_name top_left_arrow
# Start evilwm - snap to borders within 10 pixels
# /usr/bin/evilwm -snap 10 &
# Transfer control to xclock - killing xclock (with Ctrl+Alt+Escape, say)
# will exit our session
# exec xclock -digital -padding 2 -g -0+0

Last edited by fancypiper; 05-07-2005 at 02:36 PM.
 
Old 05-07-2005, 02:44 PM   #13
K0K0NUT_h3lmut
LQ Newbie
 
Registered: Apr 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Thank You!!! So MUCH!!! I think last time i had it on my computer it used to boot to KDE automatically, but yea all i had to do was login and hiy startx. Thank you again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux - IPW2100 - loads but doesn't work rieger Linux - Wireless Networking 5 08-10-2004 12:43 PM
installed dropline, root loads kde3.2, user loads drop pgrimes Linux - Software 7 06-28-2004 07:11 PM
mandrake loads slow. bolinux Mandriva 3 10-15-2003 08:35 PM
I have XP/redhat dualboot, how can i change it so that windows loads by default? chanceK Linux - Newbie 4 07-08-2003 12:39 PM
Oops - Mandrake 8.2 loads to command prompt ebakunin Linux - Newbie 3 06-07-2002 05:01 AM


All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration