LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2008, 10:58 PM   #1
Craig Milum
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Rep: Reputation: 0
Windows List Lost on Taskbar, possibly related to dpkg --configure -a error


Yesterday, I attempted to use update manager to get my Ubuntu software updated. There were about 240 files that needed to be updated. This took about 45 minutes to transfer these files and then during updating the system with these files, the system hung up. Since then, I have not been able to get my windows list to appear on the bottom taskbar. I have tried to right click on the handle on the left of the buttons, then choose Preferences to get a dialog in order access Behavior so that I could specify show windows from current workspace. However, I could find no handle on which to right click. I also noticed that the minimize/maximize/close icons on the various panels had shifted to the left about a third of the distance to the left panel edge.

I tried the update manager again, but, the effort hung with the message "E: dpkg was interrupted, you must manually run 'dpkg --configure -a'. I did that logged in with su privileges. I got hung up then at "Updating fontconfig chache...". I shut down and re-booted. The minimize/maximize/close icons had shifted back to the extreme right of each panel, but, still no windows list on the lower taskbar. I tried upgrading to a new release, to 7.10. This got hung up indcating that it was unable to get exclusive lock, that another package management application was already running. I checked the system monitor and only gnome-system-monitor was shown as a active process.

This has taken hours to get this far. I do not know what else to try other than reloading the operating system.

Any suggestions?

Craig Milum, craigmilum@milumtextileservices.com
 
Old 04-01-2008, 04:27 AM   #2
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Hi, and welcome to LQ!

To get your windows list back, right-click an open area of the bottom taskbar, select "Add/Remove Buttons", then select "Windows List" from the menu. You can also manually move buttons around by right-clicking the button, select "Unlock from Panel", "Move", & "Lock to Panel".

To complete update, try:

Code:
sudo apt-get updates
Cheers

Last edited by DragonSlayer48DX; 04-01-2008 at 04:30 AM.
 
Old 04-01-2008, 02:20 PM   #3
Craig Milum
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Bill,

Thanks. The Windows List is back. I should have seen that myself much earlier. Thanks so much.

On the "sudo apt-get updates" instruction line, I tried that with su privileges from the pound sign and from the home directory and root directory as well as from the $ and each time I received the response "E: Invalid operation updates".

Since the critical for use Windows List problem has been repaired, the only thing that I know is wrong with my current system besides the system files update problem that gets hung on the updating fontconfig cache is that Open Office always suffers an unexpected error and crashes whenever I attempt to select a font different from the default font. As I slide down on the list of fonts, as soon as I slide down below "DejaVu Serif" the crash occurs. I wonder if there is a connection between the update getting hung up on the fontconfig cache and the Open Office crashes when reviewing font options.

I also wonder about the lack of ability to upgrade from my current version of Ubuntu, Feisty, I think it is to Gertrude or something starting with a "G", but, that is not causing operation problems for which I am aware.

Thanks very much for your help.

Craig Milum
 
Old 04-01-2008, 04:23 PM   #4
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Glad you got your window list back.

My apologies for the erroneous code-- it should have been:

Code:
sudo apt-get update
Cheers

EDIT: A seriously belated afterthought~ make sure all repositories are active before running that code. That will ensure all updates are available. Also, to upgrade, I believe you need to go from one release to the next.

Last edited by DragonSlayer48DX; 04-01-2008 at 08:51 PM.
 
Old 04-01-2008, 10:28 PM   #5
Craig Milum
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Bill,

I am not sure what to do to make sure that all repositories are active before running the code. I closed out all sessions before I entered the instruction, #sudo apt-get upgrade hoping that would help ensure that all repositories were active.

The response was again "E: dkpg was interrupted you must manually run 'dkpg --config -a' to correct the problem."

Then when I entered #dkpg --config -a, the response was "updating fontconfig cache.." and the system hung at that point.

Not knowing much about what I was doing, but, seeing the following instruction on one site and since it seemed possibly like a productive thing to do, I also tried #sudo apt-get install fontconfig. Again, I received the response, "E: dkpg was interrupted you must manually run 'dkpg --config -a' to correct the problem."

My system is currently 7.04 (feisty). I was trying to upgrade to 7.10.

Thanks very much for your help.

I don't have any further ideas.

Any more directions?

Thanks.

Craig
 
Old 04-02-2008, 04:03 AM   #6
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Craig~

Here are the instructions for adding the repositories:

Navigate to "System" > "Administration" > "Software Properties". You will have to enter your password here. A list of repositories or "Channels" will be shown. Select "Ubuntu x.xx (source)" from the list (should be the first one), click "Add...", select "non-free (multiverse)" and "community maintained (universe)" by clicking their check boxes. Now click the "add" button. Click Close to save your changes. A dialog box should appear asking whether you'd like to update the list of repositories. Click Reload to apply your changes.

Cheers
 
Old 04-02-2008, 08:53 PM   #7
Craig Milum
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Bill,

Thanks for your continued assistance. On my system, navigating System > Administration does not generate a list with Software Properties as an option, but, it does generate Software Sources as one of the options plus Synaptic Package Manager and several others. I think that Software Sources is probably the near equivalent of what you expected for Software Properties. I was required to enter an administrative password a couple of times when I entered Software Sources, but other times, the password was not required.

The Software Sources panel for Ubuntu Software tab had five selections that are probably similar to what you expected with Software Properties:

Canonical-supported Open Source software (main)
Community-maintained Open Source software (universe)
Proprietary drivers for devices (restricted)
Software restricted by copyright or legal issues (multiverse)
Source Code

Each of these had a check in their respective boxes except Source code which had a “-”.

I tried unchecking each of the boxes excepting only the universe and multiverse channels. I clicked on close and received a response entitled, “The information about available software is out-of date”. The text then said, “To install software and updates from newly added or changed sources, you have to reload the information about available software. You need a working internet connection to continue.

The options at that point were Reload or Close. I selected Reload.

After loading several packages, I again received a response, “An error occured” and a panel which gave me the same message that I have previously received a number of ways:
“E: dpkg was interrupted, you must manually run 'dkpg --configure -a' to correct the problem.”
“E:_cache->open() failed, please report.

The only option to that was Close.

I changed the check marks and – to the five entries of the Ubuntu Software tab under System>Administration>Software Sources and this time the system tried to do the updates again, but, again I got the same error message as immediately above.

Next I tried entering into a Terminal panel with root privileges, “dkpg –configure -a”.

Different from past efforts on this in previous days where it did some updating and then got hung up on fontconfig, this time the response was “bash: dkpg: command not found”.

Any more suggestions?

Thanks for your help.

Craig
 
Old 04-03-2008, 04:25 AM   #8
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Craig,

Cool- They've added a shortcut. -Sources is where we were going with -Properties. As for the password confusion, the system is time-sensitive. IOW, after a few seconds of inactivity while working with admin privileges, you'll be required to re-enter the password.

I do have one more suggestion- open Synaptic, then check the status bar. It will report "broken packages". If any are reported, try uninstalling and reinstalling them. If that doesn't work...

I once commented that I hate to suggest reinstalling the system, to which a Senior Member replied, "Sometimes that's the best way..."

Quote:
Thanks for your help.
You're welcome.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB error 2 and possibly related problem cajunaggie Linux - General 4 08-31-2007 04:08 AM
KDSKBENT Error -Nvidia Related... Possibly MTUTech Fedora 0 12-10-2004 05:38 PM
GLIBC_2.0 Error When installing Oracle 8i OR 9i - Possibly related to JRE 1.1.8 itfcfan Linux - Software 1 05-26-2004 08:43 AM
GLIBC_2.0 Error When installing Oracle 8i OR 9i - Possibly related to JRE 1.1.8 itfcfan Mandriva 5 04-23-2004 11:25 AM
BLFS 5.0 dpkg build fails (ncurses-related error) bhaskie Linux From Scratch 2 02-07-2004 04:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration