LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-23-2007, 05:20 AM   #16
webb.ryan
Member
 
Registered: Oct 2007
Location: Philippines / Pilipinas
Distribution: FedoraCore5 :: Debian Etch
Posts: 37

Original Poster
Rep: Reputation: 15

To Dark Angel:

Thanks for your advice! I will keep that in mind! Your from phils too? that's great! Kuya Yongkitz too!

To kuya Yongkitz:
here's the result:

[root@host ~]#ls -l /root/Desktop/WST-FileCabinet
total 16

drwxr-xr-x 2 root root 4096 Oct 23 17:18 Albert
drwxr-xr-x 2 root root 4096 Oct 23 17:18 Ryan
 
Old 10-23-2007, 05:46 AM   #17
yongitz
Member
 
Registered: Nov 2005
Location: Davao City, Philippines
Distribution: RHEL, CentOS, Ubuntu, Mint
Posts: 139

Rep: Reputation: 20
Quote:
Originally Posted by jschiwal View Post
You should not be sharing a directory in /root. Root is the administrator and no one else has the right to access it.
The problem is that this directory (WST-FileCabinet) is inside a directory you don't have permissions to enter (/root).

You can move the WST-FileCabinet directory elsewhere, such as maybe /home/WST-FileCabinet. For a public share, maybe /home/samba/WST-FileCabinet. Some people use /var/samba if the host is used predominately as a file server.

There is a Fedora Core RPM package called samba-doc, that supplies the book "Samba-3 by Example". It includes not only example smb.conf configurations but also shows you step by step how to create the directories being shared in the example including the directory permissions. For example, it this is a publicly read and writeable share, you will want to set the sticky bit.
INDEED!

I was about to say that when this issue will be resolve because I have tested this scenario in my box and got no problem with accessing files with
the right permissions.(I did this test on slax box)

Well Ryan, you should start moving your shared directory into somewhere else as suggested by jschiwal to avoid headache and be safe.

The way I see it from your last post, I guess it's not a file permission issue. Move your share directory and see if it can fix your problem.
If you still have issues then post back..

Last edited by yongitz; 10-23-2007 at 06:07 AM.
 
Old 10-23-2007, 06:00 AM   #18
dark_angel
Member
 
Registered: Oct 2006
Location: Bacolod, Philippines
Distribution: Slackware 12
Posts: 62

Rep: Reputation: 15
you should move these folders out of root's home directory. try creating a shared directory like /home/samba and transfer the directories there. also, change the ownership of this directories. give ownership to an ordinary account. if this is just a simple share (no security issues), try activating the guest account in samba. add this to smb.conf :

guest ok = Yes

Last edited by dark_angel; 10-23-2007 at 06:03 AM.
 
Old 10-23-2007, 07:38 PM   #19
webb.ryan
Member
 
Registered: Oct 2007
Location: Philippines / Pilipinas
Distribution: FedoraCore5 :: Debian Etch
Posts: 37

Original Poster
Rep: Reputation: 15
to kuya yongkitz, dark angel and jschiwal:

yes i think that solved the problem! (because you've all agreed about what i should do...thanks!)

do i need to set some special things for my windows box? thanks!

if this still doesnt work..maybe i have done some mistakes in the process..

(maybe i will study more about this..its very hard to transfer from windows to linux)
 
Old 10-23-2007, 11:19 PM   #20
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If you have any problems, you can post back the [General] and the [WST-FileCabinet] sections of your /etc/smb.conf configuration file. Also show the long listing of the directory begin shared, as in "ls -ld /home/samba/WST-FileCabinet".
Also provide information about this share. Such as is it read-only or read-write. Is it private or public.

If I were you I would look in the "Samba 3 by Example" book I mentioned. If you can't install a samba-doc package, go to the www.samba.org web site and download the book from there. You may want to use one of the earlier configurations in the book as a guide. The book also guides you through the setup of the shared directories as well.
Quote:
do i need to set some special things for my windows box?
If there is something to do on the windows machine it may be shown as well. There are only a couple of instances of that in the book, and only with earlier versions of windows, like 95 and ME. You probably won't have to run into that. You do need to use the same WORKGROUP name for all your windows machines and the Samba configuration.

I already mentioned about creating regular users in Linux to match the windows users and using the "smbpasswd" program. You don't need to create a home directory for each of them if you don't want to. Their entries in /etc/passwd and the users file that smbpasswd creates is what is important for granting access. There are other ways of doing the samba authentication, but this is the easiest. Unless you have something like 25-50 users it's the best way to go.

By the way, the example setups in the book include one configuring a samba PDC for a 500+ users network. You probably don't need to study that one, but who knows, maybe you could be a hero at work some day!
 
Old 10-23-2007, 11:52 PM   #21
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Looking back on your earlier post, I'm not sure if you can have a user name by the name ryan.web. The dot makes it look like a canonical domain name.

If what you want to do is share users home directories, then consider a profile share or home share. The smb.conf man page will have more information, but your samba server configuration program may do this for you automatically.

Your smb.conf file could be as simple as:
Code:
[global]
        workgroup = JESNET
        wins server = hpmedia.jesnet

[homes]
        valid users = %S
        read only = No
        browseable = No

Also consider using samba swat to configure samba. You will need to edit your /etc/xinetd.d/swat file. You will probably only need to change the line from "disable = yes" to "disable = no". Here is mine:
Code:
# SWAT is the Samba Web Administration Tool.
service swat
{
        socket_type     =  stream
        protocol        =  tcp
        wait            =  no
        user            =  root
        server          =  /usr/sbin/swat
        only_from       =  127.0.0.1
        log_on_failure  += USERID
        disable         =  no
}
Then restart the xinetd service. After that you can point your web browser to http://localhost:901. Enter the root username and password in the popup dialog.

The webpage setup may also have links to the books I mentioned ( but the html versions not the ps or pdf version ).

Last edited by jschiwal; 10-24-2007 at 12:02 AM.
 
Old 10-24-2007, 04:34 AM   #22
webb.ryan
Member
 
Registered: Oct 2007
Location: Philippines / Pilipinas
Distribution: FedoraCore5 :: Debian Etch
Posts: 37

Original Poster
Rep: Reputation: 15
Red face

to jschiwal:

thanks for your full and continuous support!

I downloaded the book you recommended its really nice..I also downloaded the pdf file. samba-doc installed successfully..this maybe a stupid question but how do i open the installed samba-doc in linux?

I will do everything you suggested..and post back / email you about this.(i added you to my buddy list haha!)
 
  


Reply

Tags
access, can, cant, directories, shared, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no access to shared directories with samba Meriadoc Linux - Networking 1 03-13-2005 06:42 AM
Windows XP/NTFS + Virtual PC/Mandrake + Samba = Shared Directories? IamI Mandriva 1 12-18-2004 06:06 PM
Can't acess directories shared by Samba in windows XP vador Linux - Networking 4 10-29-2004 04:06 PM
Samba 3: Can't write to shared directories from Windows robintw Linux - Networking 10 07-31-2004 09:13 PM
Access Shared Directories gotmonkey Linux - Networking 5 04-15-2004 09:20 PM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration