LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2004, 09:52 PM   #1
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Rep: Reputation: 30
WindowMaker Icon Problem


I have changed the icons on the fixed buttons on my WindowManager desktop. However when I start some of the applications, the icon reverts back to the original icon. Other icons stay fixed. Is there a file I can adjust to stop this occurring?
 
Old 03-09-2004, 11:50 AM   #2
matador
Member
 
Registered: Jul 2003
Location: sweden
Distribution: gentoo @home, RH @ school
Posts: 107

Rep: Reputation: 15
Could you elaborate... What exactly have you done? For instance when you exit WM do you exit via the menu or just type halt/reboot in a terminal. If so, you don't save the desktop state wich results in no changes saved.
 
Old 03-09-2004, 09:04 PM   #3
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Original Poster
Rep: Reputation: 30
Thanks Matador. I will explain.

I have changed the icon settings for the docked app in WindowMaker and saved my changes on exit out of WindowMaker and xf86.

When I reboot into WindowMaker everythings looks perfect and my icons look perfect!

However when I open an appliation, then the relevant docked app icon changes to the original icon picture setting.

For example, I have the nice crystal icon for my konqueror browser docked app in WindowMaker and it looks sweet. When I open Konqueror, the icon in the dock reverts back to the original dodgy icon . Then when I close the application, the icon reverts back to the nice crystal icon.

Hope this is clear. Thanks. Not a major problem, but would nice to clear-up.
 
Old 03-10-2004, 03:14 AM   #4
matador
Member
 
Registered: Jul 2003
Location: sweden
Distribution: gentoo @home, RH @ school
Posts: 107

Rep: Reputation: 15
So you've created a button by dragging it to the side and dedicated a new icon to it. When launched the icon resets, and save session at exit doesn't work?.. I've had problems with the icon resetting but saving the session fixed it.

It could be a compilation/distro problem or a bug. There has been several icon bugs...
 
Old 03-10-2004, 03:48 PM   #5
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Original Poster
Rep: Reputation: 30
That is more or less correct.

Save session maintains the correct icon on the button - just when the app is launched, it reverts back to an older icon.

I thought the same - a bug.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gFTP icon in WindowMaker dock taylor_venable Linux - Software 2 10-04-2005 12:16 AM
windowmaker font problem HailKingPhil Linux - General 0 09-10-2004 08:02 PM
PSI with enabled WindowMaker docklet> huge icon Trygleren Linux - Software 0 08-10-2004 05:34 PM
WindowMaker Problem VIP3R Linux - Software 4 03-18-2004 09:49 AM
WindowMaker icon questions itsjustme Slackware 9 08-20-2003 01:33 PM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration