LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-02-2007, 02:30 PM   #1
vinayakbhat
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
Unhappy window focus for global shortcuts


I am using an application which runs in full screen mode. On using a shortcut like Ctrl+Shift+Z when the focus is on the application window, I do not see any effect on that window. Instead the Amarok window gets the interrupt and it switches to previous track. How can I make the active window have higher priority?
 
Old 04-04-2007, 03:23 AM   #2
Agrouf
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79
What is the window manager and which application is this?
 
Old 04-04-2007, 02:18 PM   #3
vinayakbhat
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Say I have Amarok window in minimized state and I have an OpenOffice window open (full screen) and under focus. On pressing Ctrl+Shift+V, I expect the Paste Special Window (of OpenOffice) to show up, but instead the song being played in Amarok stops because Ctrl+Shift+V is shortcut used to stop the song in Amarok.
 
Old 01-05-2009, 10:15 AM   #4
qajaq
Member
 
Registered: Sep 2008
Location: north-central Florida
Distribution: Kubuntu 9.04 / 12.04
Posts: 50

Rep: Reputation: 15
I am having similar a similar problem. When I'm running Amarok (on openSuSE 11.1 / KDE 4.1), I can't use the space key in any other application because it will Pause/Play the Amarok player instead of inserting a space character in whatever document I'm writing. I've tried going into Amarok's Settings (menu option) to 'Configure Shortcuts' and 'Configure Global Shortcuts' by changing the keyboard shortcut for the Pause/Play function, or to eliminate that keyboard shortcut altogether, but that has proven futile... the default shortcut still applies after the change, whether I'm using Amarok immediately, shutdown-and-restart, or shutdown-reboot-and-restart.

In fact, when I shutdown Amarok and restart it, the Shift-key shortcut is back on the list (even though other changes I've made to the shortcuts have stayed the way I changed them). I can't get rid of the Shift-key shortcut and it hijacks the Shift-key input whenever Amarok is running.

Any ideas either on how to make a custom keyboard-shortcut stick, or how to disable keyboard shortcuts altogether in Amarok?
 
  


Reply

Tags
focus, global, shortcuts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
click to focus window dynamicit Suse/Novell 0 08-01-2006 10:54 AM
New window focus in XFce xray_fl Programming 0 05-12-2005 02:05 PM
XMMS Global KB Shortcuts... Logitech Internet Navigator USB Keyboard Buttons..... Nalorin Linux - Software 2 04-12-2005 06:53 PM
window focus thaprza Linux - Newbie 3 03-06-2005 03:25 PM
SDL window focus rebelcan Programming 1 10-06-2003 07:36 AM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration