LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2004, 06:52 AM   #1
alirezan1
Member
 
Registered: Nov 2004
Location: Vancouver
Distribution: Ubunty, CentOS ,Mandriva, Gentoo, RedHat, Fedora, Knoppix
Posts: 150

Rep: Reputation: 15
winbind and smb.conf??


Hello,

I have mandrake 10.1 installed. When I try to do : "winbind start" I get the error message:

"Starting Winbind services: Winbind is not configured in /etc/samba/smb.conf, not starting"

I have no idea what this is about. But, I have two problems:

When I check the status of Samba with SWAT, I get :

"smbd: not running
nmbd: running
winbindd: running"

but when I do samba status I get:
"# samba status
smbd (pid 7077 7076) is running...
nmbd (pid 7086) is running..."

Also, the problem is that when I try to browse the network with smb4k, it does not show the network computers automatically. However, when I search for any computer on the net, it starts to show the network computers.

I don't know what might be wrong, so here is my smb.conf and hoping someone could help me:

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2004/12/21 03:00:15

# Global parameters
[global]
workgroup = ARNIT
netbios name = LINUX
server string = Samba Server %v
security = SHARE
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
printer admin = @adm

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = Yes
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm, root
inherit permissions = Yes
guest ok = Yes

[pdf-gen]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
printing = bsd
print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" "%m" "%I" "%J" &
lpq command = /bin/true
lprm command = lprm -P'%p' %j

Please tell me what is wrong with my samba. Thanks

Alireza
 
Old 01-11-2005, 06:27 PM   #2
ctwos
LQ Newbie
 
Registered: Jan 2005
Location: Denver, Colorado
Posts: 3

Rep: Reputation: 0
Remove "netbios name = LINUX" from smb.conf will fix it.

I had same problem, seems like its a bug.

If I find out how to get around it will let you know, like you I want to use the name I pick.

Walt
 
Old 01-11-2005, 07:02 PM   #3
alirezan1
Member
 
Registered: Nov 2004
Location: Vancouver
Distribution: Ubunty, CentOS ,Mandriva, Gentoo, RedHat, Fedora, Knoppix
Posts: 150

Original Poster
Rep: Reputation: 15
Thank you for your reply. I will try this out.

Alireza
 
Old 01-15-2005, 12:57 PM   #4
ctwos
LQ Newbie
 
Registered: Jan 2005
Location: Denver, Colorado
Posts: 3

Rep: Reputation: 0
Thumbs up found it

For a long time I have had two servers (RH7.3 and Mandrake 10.1), one which SWAT works, one which reports "smbd not running".
I finally decided to figure out what the difference was. Here is what it was.

Simply add to:
"/etc/samba/lmhosts"
"IP Address of the server" "the name of the server"

Example here is mine:

[root@chilly root]# cat /etc/samba/lmhosts
127.0.0.1 localhost
192.168.0.10 chilly

and put back
"netbios name = CHILLY" in smb.conf

Walt
 
Old 02-11-2005, 09:20 PM   #5
ctwos
LQ Newbie
 
Registered: Jan 2005
Location: Denver, Colorado
Posts: 3

Rep: Reputation: 0
Lightbulb fyi

While set up my print server using samba I came across the following:

#man smb.conf

under:
bind interfaces only, (about line 784)

If bind interfaces only is set then unless the network address
127.0.0.1 is added to the interfaces parameter list smbpasswd(8)
and swat(8) may not work as expected due to the reasons covered
below.....

The swat status page tries to connect withsmbd and nmbd at the
address127.0.0.1 to determine if they are running. Not adding
127.0.0.1 will cause smbd and nmbd to always show "not running"
even if they really are. This can prevent swat from start-
ing/stopping/restarting smbd and nmbd.

PS
Did you get it working?

Walt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
smb.conf example xox Linux - Networking 7 10-09-2010 03:04 AM
Trouble accessing smb share using winbind xscousr Linux - Networking 2 06-09-2005 04:12 PM
samba conf smb.conf regnier Mandriva 5 02-17-2005 05:27 AM
smb.conf help PlatinumRik Linux - Networking 6 05-29-2003 02:30 PM
where is my smb.conf pallocca Linux - General 14 03-04-2003 09:35 AM


All times are GMT -5. The time now is 05:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration