LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2003, 06:43 AM   #1
mcbaboon
LQ Newbie
 
Registered: Oct 2003
Location: near manchester in england
Posts: 4

Rep: Reputation: 0
Win Xp & Win 2000 & Mandrake 9.1 (ntoskrnl missing for xp)



I have just started using linux (mandrake 9.1) its ok still popping my cherry!!!...
my problem is that when i goto load windows with lilo or grub it gives me the option for win 2000 or win xp (like it used to) win 2000 never worked but that isn't a problem.... but when i go to load xp which i NEED!!! it says ntoskrn missing something or over, i have looked all over the net and i cant find ne help
my partitions as below
swap
primary win2000 fat32
logical winxp ntfs
ext3
downloads (logical) fat32
programs (logical) fat32

what can i do i have a good understanding of windows and i am a it technician at college 2nd year....

also partition magic 8 reads partition table as BAD???

When i installed lilo it went to the mbr!!!

PLEASE HELP ME!!!
 
Old 10-13-2003, 06:48 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
did you add swap and ext3 with partition magic(ie your partition layout changed)?
can you post the content of your boot.ini? which is probably inside win2k partition.
 
Old 10-13-2003, 06:55 AM   #3
mcbaboon
LQ Newbie
 
Registered: Oct 2003
Location: near manchester in england
Posts: 4

Original Poster
Rep: Reputation: 0
im at college at the moment and no i did it withing the mandrake installation
 
Old 10-13-2003, 03:03 PM   #4
mindnumbed
Member
 
Registered: Jul 2003
Location: Scotland
Distribution: Debian
Posts: 74

Rep: Reputation: 15
mandrake 9.1 has a "rescue" option. boot from the first CD and push F1 when asked to push F1 or enter. type at the boot: prompt
boot: rescue <enter>
once it chugs for a bit, choose "restore windows boot sector" which will make the computer boot in windows XP all the time (it should at any rate, or windows 2000 depending on which you installed first). If that doesn't work, it might be because you resized a partition when you were installing mandrake. you can screw up a partition when resizing it, so if you have done that, restore your backup of the windows partition (which you made before installing linux like a good it technitian ) .
MN
 
Old 10-13-2003, 05:16 PM   #5
mcbaboon
LQ Newbie
 
Registered: Oct 2003
Location: near manchester in england
Posts: 4

Original Poster
Rep: Reputation: 0
Unhappy

i didnt do a backup and now ive lost the windows boot loader some how
heres wots in the boot.ini on c (win 2000 partition)

[Boot Loader]
Timeout=5
Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
[Operating Systems]
multi(0)disk(0)rdisk(0)partition(6)\WINDOWS="Windows XP Media Center Edition" /fastdetect
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
C:\ = "Previous Operating System on C:"
C:\$WIN_NT$.~BT\BOOTSECT.DAT = "Windows XP Installation/Upgrade"
 
Old 10-13-2003, 08:22 PM   #6
mindnumbed
Member
 
Registered: Jul 2003
Location: Scotland
Distribution: Debian
Posts: 74

Rep: Reputation: 15
what hapens when you try to restore the windows bootloader with the rescue option on teh install cd? Mandrake makes an automatic backup of that.
 
Old 10-14-2003, 03:49 AM   #7
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try changing
multi(0)disk(0)rdisk(0)partition(6)\WINDOWS
to
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS

also win2k should be on
multi(0)disk(0)rdisk(0)partition(2)

boot with xp cd to get into recovery console and use fixboot/fixmbr to recover ntldr
 
Old 10-14-2003, 04:18 AM   #8
mcbaboon
LQ Newbie
 
Registered: Oct 2003
Location: near manchester in england
Posts: 4

Original Poster
Rep: Reputation: 0
when i use the mandrake cd1 and do rescue and the windows bootloader, when i click on windows on lilo it just say LOADING WINDOWS............ ????
 
Old 10-14-2003, 10:34 AM   #9
mindnumbed
Member
 
Registered: Jul 2003
Location: Scotland
Distribution: Debian
Posts: 74

Rep: Reputation: 15
interesting...restoring the windows boot sector should overwrite LILO, so that you don't see LILO. the only way to get at linux then is to boot from the rescue cd and restore the bootloader, or try to get the bootloader on floppy, there's an option to do that (don't ask me how)
MN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Fedora Core 3, Samba, gnome & win 2000/XP edesmarais Linux - Networking 21 12-15-2005 02:36 PM
multiboot with Mandrake & win Steel Shepherd SUSE / openSUSE 2 10-17-2004 03:24 AM
Mandrake 9.2 & Win XP cyberkat75 Linux - Newbie 4 03-25-2004 11:16 AM
Lilo: Dual boot Debian & Win 2000 mudelf Linux - General 3 11-12-2003 02:55 AM
Win ME & Mandrake 8.1 - Some problems. boyrobot Linux - Newbie 1 12-25-2001 12:33 PM


All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration