LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Wifi problem Toshiba laptop (http://www.linuxquestions.org/questions/linux-newbie-8/wifi-problem-toshiba-laptop-823810/)

Ledge 08-03-2010 09:23 AM

Wifi problem Toshiba laptop
 
Hello all. I have recently purchased a Toshiba satellite pro C650 laptop. I have installed Ubuntu 10.04 via Wubi which has installed ok and boots fine but it fails to recognise my Wifi card or network so I am unable to download any drivers. It also sees my dvd rom drive but not any usb ports or other hardware. I have searched the Toshiba site but cannot find a fix on any of the Linux forums there. Does anybody know where to get a driver update or fix thanks.

jkzfixme 08-03-2010 11:30 AM

I have had good luck previously using the Atheros 9k module by linux-wireless. The c650 should have the same chipset unless things drastically changed in the last week or two

http://linuxwireless.org/en/users/Drivers/ath9k#ath9k


Regards,
JKZfixme

cantab 08-03-2010 11:33 AM

at the command prompt, try "lspci" and also "dmesg". Look for anything related to wireless networking.

Basically, one of four things could be the case

1) There are linux drivers installed and you need to figure out how to use them (perhaps the wireless hardware is switched off, try the relevant Fn key combination)
2) Linux drivers exist but aren't installed by default
3) Linux drivers exist, but you also need firmware - you simply get this and copy it to the right place
4) No Linux drivers exist - you will have to try ndiswrapper

Ledge 08-04-2010 03:34 AM

Thanks jkzfixme I tried the driver update it went through ok but did not seem to change anything, and cantab thanks also your suggestions seem a bit scary for a newbie but we all have to learn so I will have a go. The positive side is no matter how many times I hang the system windows 7 always boots back up so it keeps the wife happy.If I manage to succeed I will call back cheers guys.

chuinker 08-07-2010 04:10 PM

This worked for me:

$ your-favorite-editor /etc/default/grub

replace
GRUB_CMDLINE_LINUX=""
with
GRUB_CMDLINE_LINUX="noapic"

(note: do NOT also add it to GRUB_CMDLINE_LINUX_DEFAULT, it will choke if it sees "noapic" twice)

$ sudo update-grub

(note: sometimes this step hangs, if so, you need to reboot and just try again, i have not researched why it hangs)


For some reason I don't understand, the desktop was a bit funky the first time i rebooted, but on the second it was able to find my wifi network. have not yet tried ethernet, which was also non-functional prior to using noapic.

- Corey

Ledge 08-09-2010 01:43 PM

Hi Corey,
Thanks for taking the time to have a look at my problem. I am a real linux newbie sorry, do you mean open up a terminal window and type in the command as I have typed in $ sudo update-grub but I can see no reference to the lines you have. If its no trouble could you give me the idiots guide to the procedure as I am keen to learn.
Ledge.

chuinker 08-10-2010 12:26 AM

1. open a terminal
2. At the $ prompt, type
Code:

sudo gedit /etc/default/grub
enter password when prompted, unless you've recently done another sudo command in this terminal, in which case it remembers that password for a few minutes.
3. use arrows to navigate to the line
Code:

GRUB_CMDLINE_LINUX=""
4. replace it with
Code:

GRUB_CMDLINE_LINUX="noapic"
5. File->Save
6. File->Quit
7. At the $ prompt, type
Code:

sudo update-grub
It probably won't prompt you for a password here, unless you went to lunch or something.
8. Normally, step 7 will finish in 10 seconds or so, and you can safely reboot. However, If the last command fails to complete after a minute, you can close the terminal, open another one, and re-run step 7. Worst case scenario is that you reboot, verify that your edit to /etc/default/grub is still in place, and re-run step 7.

Is that newbie-worthy?

Ledge 08-11-2010 04:51 AM

Very newbie worthy thanks. I ran the changes as you described and it was succesfull after the 4th attempt. I have managed to progress a little. After the reboot Ubuntu was able to see my Atheros wifi card, I tried to connect to the internet after entering the router settings and passwords etc, but the scan fails and a message appears saying that the router needs a code to connect. I renter the code (which I know is correct because I have set up our other 2 computers running windows with it) and it still fais to connect. I updated the wifi drivers to the latest one in windows 7 do I need to point ubuntu to these ?.

cantab 08-11-2010 05:39 AM

You may need to set the type of code correctly. WEP, WPA, or WPA2. Normally it's autodetected.

Demerzel 08-11-2010 07:01 AM

As I already written in other post:
When right drivers are installed gnome manager will do everything. The problem is that some cards with some AP cannot use WEP or WPA usually at least one work so try changing.

onebuck 08-11-2010 08:49 AM

Hi,
Quote:

Originally Posted by Demerzel (Post 4062806)
As I already written in other post:
When right drivers are installed gnome manager will do everything.

What other post? You are speaking of configuration when saying 'everything'?

Quote:

Originally Posted by Demerzel (Post 4062806)
The problem is that some cards with some AP cannot use WEP or WPA usually at least one work so try changing.

What problem? Please expand on this for meaning and clarification? Seems contradictory?
:hattip:

Demerzel 08-11-2010 09:08 AM

onebuck
1. Other post in other thread
2. Contradictory is to say words smart and onebuck in one sentence. You understand this one or is it to difficult?

3. Ledge
Quote:

it fails to recognise my Wifi card or network
cantab
Quote:

You may need to set the type of code correctly. WEP, WPA, or WPA2. Normally it's autodetected.
If WiFi drivers are working and you can't connect network change between WEP/WPA on your AP settings. GNM will ask key and just work.

onebuck 08-11-2010 09:16 AM

Quote:

Originally Posted by Demerzel (Post 4062928)
onebuck
1. Other post in other thread
2. Contradictory is to say words smart and onebuck in one sentence. You understand this one or is it to difficult?<snip>

It is polite and correct to reference the post directly if not contained within the thread for the post that you are referencing. That way no confusion. Valid query? As for your snide references, you can put them where the sun doesn't shine and hopefully things will come to a close.
:hattip:

chuinker 08-25-2010 11:11 PM

An even better solution can be had by installing the 2.6.35 kernel using these directions

http://ubuntuforums.org/showthread.php?t=1503491

The new kernel and the copy_dsdt boot option not only enabled wifi control, it also enabled battery status on my Satellite C650.


All times are GMT -5. The time now is 12:27 AM.