LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2009, 12:47 AM   #1
evil_empire
Member
 
Registered: Mar 2005
Distribution: Fedora Core 3
Posts: 176

Rep: Reputation: 31
wifi connection from text mode


Hi,
I haven't been able to connect to the wireless internet in text mode. I have a WEP connection at home. I know its insecure but due to hardware limitation I have to keep it like that for sometime.

I've tried wpa supplicant but failed miserably. Since I'm using WEP, I don't think I'm required to use wpa supplicant. But the simple technique of using iwconfig has failed as well.
Can anybody guide me thru this? Its more or less becoming like a dream to connect wifi from text mode. I'm loosing hope

I've tried,
iwconfig wlan0 essid my_essid key my_key
dhclient wlan0

few things I have noted are,
1)first I'm not associated to the AP!
2)second dhclient gets the address for my router, pings it but gets no reply

I think no 1 is causing no 2.

What could be the reason?

When I'm using wpa_supplicant, its the same. My wpa_supplicant config is as follows.

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
ssid="MY_SSID"
scan_ssid=1
key_mgmt=NONE
wep_key0=2437234757
wep_tx_keyidx=0
priority=5
#auth_alg=OPEN
}

I do a
wpa_supplicant -B -Dwext -i wlan0 -c/path_to/wpa_supplicant.conf
and then
dhclient wlan0

In both of the case, first its not associated to the AP, second it shows that my router couldn't be pinged. I've also tried running wpa supplicant with -d option but couldn't figure out what was going on.

What could be the reason, what am I doing wrong? My AP doesn't use any authentication, I just have to supply the 10 digits numeric key. The ath9k driver is working fine and I can connect wifi using nm-applet.

Plzzzz Help!!!

PS: I'll post the exact log messages in the second post.
 
Old 03-14-2009, 04:05 AM   #2
evil_empire
Member
 
Registered: Mar 2005
Distribution: Fedora Core 3
Posts: 176

Original Poster
Rep: Reputation: 31
After a lot of hits and trials I've finally managed to connect wifi from the text mode both using iwconfig and wpa supplicant. I had to supply bssid for both approaches and they worked.

Now, if I could just write some scripts for them.

Thankx anyways.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does monitor go out of sync in text mode but work ok in graphics mode? tjsgifan Linux - Hardware 6 09-27-2007 09:42 AM
Profile variable exports in text mode, not in GUI mode....huh? duderancher Red Hat 1 09-13-2007 07:45 PM
LXer: Howto Boot debian in text mode instead of graphical mode (GUI) LXer Syndicated Linux News 0 09-09-2007 08:41 PM
Changing FC6 a text mode installation to graphics mode. wbuik Fedora 2 06-19-2007 09:38 PM
flickering of screen while returning back to GUI mode from Text mode using Ctl+Alt+F7 varun_shrivastava Linux - Newbie 1 03-30-2007 11:12 AM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration