LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2011, 07:05 AM   #16
stuartjohn
LQ Newbie
 
Registered: Jun 2011
Distribution: ubuntu 11.04
Posts: 29

Original Poster
Rep: Reputation: Disabled

Sorry for the confusion.
Here's what happened:
I installed Ubuntu 11.04 ( kernel 2.6.38.10 generic) on a Toshiba Satellite A100-250. Wireless was extremely slow using the ath5k driver, so on suggestions from the forum I installed madwifi. This worked fine.
Wifi stopped completely after a suggested update, which had installed a new kernel 2.6.38.11. Looking at the network manager when this kernel has started up, only the ethernet connection is running, no wireless at all.

Frankbell suggested I change the kernel call in grub, but this is too intimidating to me.
So I can either:

1. Revert completely to the previous kernel,
2. Try to fix the current kernel to support wifi,
3. Manually choose the previous kernel on startup.

If the current kernel has important fixes compared to the previous one, option 2 would be preferable.

Last edited by stuartjohn; 08-29-2011 at 07:07 AM.
 
Old 08-29-2011, 07:54 AM   #17
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Quote:
Originally Posted by stuartjohn View Post
Sorry for the confusion.
Here's what happened:
I installed Ubuntu 11.04 ( kernel 2.6.38.10 generic) on a Toshiba Satellite A100-250. Wireless was extremely slow using the ath5k driver, so on suggestions from the forum I installed madwifi. This worked fine.
Wifi stopped completely after a suggested update, which had installed a new kernel 2.6.38.11. Looking at the network manager when this kernel has started up, only the ethernet connection is running, no wireless at all.

Frankbell suggested I change the kernel call in grub, but this is too intimidating to me.
So I can either:

1. Revert completely to the previous kernel,
2. Try to fix the current kernel to support wifi,
3. Manually choose the previous kernel on startup.

If the current kernel has important fixes compared to the previous one, option 2 would be preferable.
Ok, That clears things up a bit. I don't understand what the problem is about reverting to the previous kernel. Normally kernels (called linux-images) don't disappear unless you explicitly remove them. When you boot up, don't you see a list of kernel options, each one in normal mode or recovery mode, to choose from? I don't see why editing grub should be necessary unless you did something drastic.

2nd point: 2.6.38 is nowhere near being the latest kernel version. There's 2.6.39 and then 3.0 came out to much brouhaha a while ago. I'm running 3.0-3.dmz.2-liquorix-amd64 right now. So you have two ways to go: backwards or forwards. If you're unhappy with your kernel's performance then change it. It's not a big deal.
ciao,
jdk
 
Old 08-29-2011, 08:07 AM   #18
stuartjohn
LQ Newbie
 
Registered: Jun 2011
Distribution: ubuntu 11.04
Posts: 29

Original Poster
Rep: Reputation: Disabled
Thanks for looking into this issue.

When starting up grub indeed offers choices. Current kernel: 2.6.38-11, and recovery mode.
Going back to previous it's 2.6.38-10 and recovery mode.

How to change it (either forward or backward) is what I don't know how to do.
I understand that the kernel call can be changed in grub, but honestly I hesitate to go that road.
On the other hand, how to get wifi going in the current kernel is also beyond me.

Last edited by stuartjohn; 08-29-2011 at 08:08 AM.
 
Old 08-29-2011, 08:16 AM   #19
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Wow! Ubuntu seems incredibly complicated. I use Debian and when I see the menu I just use the arrow keys to move upwards or downwards. When I arrive at what I want, I just hit <CR> and voilą I've got the kernel I desire. Doesn't Ubuntu work this way?
Quote:
I understand that the kernel call can be changed in grub, but honestly I hesitate to go that road.
But that's what Grub does! at least one of the things it does. It allows you to choose which kernel to boot up in. Believe me, it's not a big deal. You're just selecting an item on a menu. If you're not happy reboot and select a different kernel.
ciao,
jdk
 
Old 08-29-2011, 05:08 PM   #20
stuartjohn
LQ Newbie
 
Registered: Jun 2011
Distribution: ubuntu 11.04
Posts: 29

Original Poster
Rep: Reputation: Disabled
No, Ubuntu's not any more complicated. It's exactly the same thing (It's Debian based). You can select which you need as explained before. That's what I do now. But I have to do this manually, or it will default to 2.6.38-11.
I hesitate editing the grub, that's what I mean.

So the questions remain:
1. How to get wifi going in the current kernel (2.6.38-11)
2. How to revert completely to the previous (2.6.38-10) (Not just manually choose it on startup)
 
Old 08-30-2011, 12:35 AM   #21
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Grub normally defaults to the first menu item (typically the most recent). Selecting another kernel will not change the default. In the old Grub days you could edit the file menu.lst and set the order (and thus the default) any way you wished. I don't know how that's done in Grub2. As for your questions, I think they have been answered:
1. For some reason you can't. I would suggest getting a more recent kernel e.g. 2.6.39 or 3.0.
2. Remove 2.6.38.11
Code:
sudo aptitude remove linux-image-2.6.38-11<insert end of package name>
That's it.
ciao,
jdk
 
Old 08-30-2011, 09:31 AM   #22
stuartjohn
LQ Newbie
 
Registered: Jun 2011
Distribution: ubuntu 11.04
Posts: 29

Original Poster
Rep: Reputation: Disabled
O.K. I'll give that a try.
Thanks for the assistance.
 
Old 08-30-2011, 09:57 AM   #23
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by stuartjohn View Post
No, Ubuntu's not any more complicated. It's exactly the same thing (It's Debian based). You can select which you need as explained before. That's what I do now. But I have to do this manually, or it will default to 2.6.38-11.
I hesitate editing the grub, that's what I mean.

So the questions remain:
1. How to get wifi going in the current kernel (2.6.38-11)
2. How to revert completely to the previous (2.6.38-10) (Not just manually choose it on startup)
It's easy to get grub to use the kernel you want as default:

Use a text editor to open /etc/default/grub as root
Code:
sudo vim /etc/default/grub
or use another editor.

Start of file:
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to <snip>
Change GRUB_DEFAULT=0 to GRUB_DEFAULTLT=2, assuming the correct kernel is 3rd down from top.

Then run update-grub like it says.
 
Old 08-31-2011, 04:42 PM   #24
stuartjohn
LQ Newbie
 
Registered: Jun 2011
Distribution: ubuntu 11.04
Posts: 29

Original Poster
Rep: Reputation: Disabled
Must do some reading on use of vi before attempting this, I guess.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WiFi can't switch the connection to wifi hotspot when already connect to an AP pologuy Linux - Wireless Networking 2 08-02-2011 04:05 AM
[SOLVED] WiFi Connection Failure on Intel Corporation WiFi Link 5100 physicsguru Linux - Wireless Networking 1 04-08-2011 07:41 PM
dual wifi and wired connection: how to make a specific website use only wifi? shinji2001xyz Linux - Networking 2 04-08-2010 11:13 AM
lshw -C network shows USB wifi disabled? hattrick Linux - Networking 2 03-05-2010 10:15 AM
Wifi gets disabled according to X suspend (possible ACPI prob?) Su-Shee Linux - Laptop and Netbook 1 05-14-2008 02:28 PM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration