LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-23-2004, 05:24 AM   #1
mlr266
LQ Newbie
 
Registered: Nov 2004
Distribution: RedHat Enterprise WS
Posts: 6

Rep: Reputation: 0
Wifi@Home can't connect to internet


I really have two problems with my Asus Wifi@home card. I am a total newbie with Linux, and I have tried to follow the directions for this driver to the best of my ability but it’s just not working for me.

My Bigger problem (of the two) is that once the card is installed and the built in utility is working, it see the AP and can connect to it, but I can not seem to access a web sites. From the terminal I can ping the AP and that works fine I can even log onto the AP, but that’s as far as it will go.

The second problem I am having is that I have to jump though the hoops of reinstalling the card every time I reboot. I think I just have to make a script that will be loaded on boot, but I have never done this and the directions that came with the driver were kind of vague. It details the script it self, but does not really say what I have to do to make and then run the script.

I am using Red Hat Enterprise WS 3. The card is a Wfi@home made ASUS. But from what I have seen online the chip set is Ralink RT2400. And I have confirmed this by using “/sbin/lspci”. I have been using the driver and install instruction from the file rt2400-1.2.1.tar.gz

I can not seem to use the modprobe command either. I even searched the hard drive, I don’t have any files named that… and it says to use this command in the install instructions. (modprobe rt2400)

Also I don’t know if some how while I was playing around with the network settings I screwed some thing up but now Gnome gives me a message at log in about not being able to find the localhost, but I am able to skip passed and every thing seems to work fine (except the internet of course).

Thanks for any help you can give
Mike
 
Old 11-23-2004, 05:41 AM   #2
mdixon
LQ Newbie
 
Registered: Oct 2003
Location: Perth, Western Australia
Distribution: Fedora & FreeBSD
Posts: 14

Rep: Reputation: 2
Re: Wifi@Home can't connect to internet

Quote:
Originally posted by mlr266
My Bigger problem (of the two) is that once the card is installed and the built in utility is working, it see the AP and can connect to it, but I can not seem to access a web sites. From the terminal I can ping the AP and that works fine I can even log onto the AP, but that’s as far as it will go. [/B]
Mike, have you been able to access the web through that access point using any other operating system, for example Windows?

What is the configuration of your network? Is it DSL at the wall; to a DSL modem via phone jack; to the access point via Ethernet? Or something different to that? Can you list what is connected to what, and also what the IP number is for each device (for those that have an IP address).
 
Old 11-23-2004, 08:15 AM   #3
mlr266
LQ Newbie
 
Registered: Nov 2004
Distribution: RedHat Enterprise WS
Posts: 6

Original Poster
Rep: Reputation: 0
network config

I am dual booting this machine right now I am logged into windows XP and using this Wifi setup just fine. It is a DSL connection hooked up to a Linksys router. The modem and router are at another house down the street from mine, and I use a larger than normal antenna to connect (I have there permission to use there connection). This setup has been working fine for months, and since I can post this its still full functional. The routers IP is 192.168.1.1 the routers DHCP is set to start assigning IP’s starting at 192.168.1.100 there is one computer at that house that connects using Ethernet and another computer down there that uses WiFi, but neither has a static IP. I can ping all the computers, and the router.

When I first log on to linux and try to type an IP I get a message that says the request was refused. Once I install the card I can log onto the router by type the IP in just like I would in windows. When I then try for a web site it tries to load it but never gets any where.


I have been playing around some more and I have gotten the scripts to run, but still no Internet connection. And I have no idea where I would put the script or what to do with it to make it run every time. Here is an example of the script I am running

*********************************************************************
#!/bin/sh
#bring up the card so iwconfig works with it
./ifconfig ra0 up

#set wireless params as needed
#some parameters are dependent on others so the order may be important,
#particularly be sure to set at least the mode and authentication-type
#BEFORE you start scanning
./iwconfig ra0 mode Managed

#key and encryption optional
./iwconfig ra0 key [1] 6fd5s4gdsf654g
./iwconfig ra0 enc restrict

#setting the essid starts scanning
./iwconfig ra0 essid YOUR_ESSID

#settings for static
./IP ifconfig ra0 192.168.1.126 netmask 255.255.255.0 broadcast 192.168.1.255

#if only card, or really is your default uplink:
./ip route add default via 192.168.1.1 dev ra0
***********************************************************************

This is not 100% what I have assembled, as I said I am dual booting, and windows and redhat aren’t talking. And I forgot to copy it to disk before I rebooted. The script I have set up does a few more things, but I quickly rewrote this one from an example I found online and used to help make the one I am actually using. I have done some networking, so I think I have all the basics down, but I don’t know what this “broadcast 192.168.1.255” IP is. The number was all X’s in most examples I found except for one and that one had the broadcast number set to 192.168.1.255 so that’s why mine is set to that.


I have also noticed that once the card is installed the computer slows way down in linux. New windows take forever to open, it took forever to shut down, its just running very slowly.

The step by step configuration is:

Phone jack at the wall
To DSL modem
Through Ethernet
To router/firewall/AP/switch all in one
Through air
To my computer
 
Old 11-24-2004, 05:51 AM   #4
mlr266
LQ Newbie
 
Registered: Nov 2004
Distribution: RedHat Enterprise WS
Posts: 6

Original Poster
Rep: Reputation: 0
Almost working 100%

Well i got the Internet working, and just in case anyone searches this out and finds it of use i will detail what i have done. I still need to know where to put this script to make it run every time i boot.

First i restarted fresh... i dumped everything Linux and then reinstalled.
I then started the terminal window up and changed to Super user
#su

I navigated into the folder/usr/src/linux-2.4.21-15.EL and ran the following command
#make config
(i had to do this because just running the “make” command like the included diver directions suggest, gave me an error. The error told me to run this command so i could activate module support. Running this command asks a lot of questions, and to be honest i did not know what to answer for most of them. I think just hitting Enter at any question leaves it at the default, so that is what i did for all but the module question, which i think was the first question(might have been second) I answered Y for that one)

I then copied, from a diskette, the folder rt2400-1.2.1, and put it in /usr/src/

I used the terminal to navigate to /usr/src/rt2400-1.2.1/Module and ran the following commands.
#make
#make install

I think this is every thing needed to get the card talking to Linux, but it still needs to be set up. I used the following script. I wrote and initially saved it to my home folder. Activated the executable permissions using the graphical interface, and then copied it to the /sbin folder. The included directions said to run it anywhere, but It would only run in this folder. This script is a compilation of the included scripts that came with the file and one or two I found online. One major change I made was to add “./” in front of each executable line. For some reason this made a difference and the sh command would only give errors unless they were there, but that might have been before i was trying to run it from the /sbin directory. Here are the commands i used to run it, and then the script. I called the file i created “one3”.
(commands were run as super user)
# cd /sbin
#sh one3
(the out put after i ran this command)
[root@localhost sbin]# sh one3
insmod: a module named rt2400 already exists
[root@localhost sbin]#



Script
#####################################################################
#!/bin/sh
#------------------------------------------------------------
# By eaglenest@users.sourceforge.net
# July-August 2004, based on tips from the
# rt2400 Linux Driver project help forum
# (rt2400.sourceforge.net) - no copyright.
#
# This script brings up and connects an
# rt2400 chipset based wireless network
# card to a DHCP server. It is not validated
# with regard to static IP addressing.
#
#this version also uses parts from:
#http://sourceforge.net/docman/displa...roup_id=107832
#http://sourceforge.net/projects/rt2400
#------------------------------------------------------------

./ifconfig ra0 down

# Install the module if not installed
./insmod /usr/src/rt2400-1.2.1/Module/rt2400.o

./ifconfig ra0 up

# Set wireless parameters as needed
./iwconfig ra0 mode Managed
#the scipts had “auto” instead of 6 here, but my computer did not like that
#use your own channel number here
./iwconfig ra0 channel 6
./iwconfig ra0 rate auto
#i think this is just what the AP sees the devise name as
./iwconfig ra0 nick nowhereman
#WEP info
./iwconfig ra0 key restricted [1] (your Key here)
./iwconfig ra0 key [1]
#iwconfig ra0 key off

# Note: scanning must start very soon after ifconfig
./iwconfig ra0 essid linksys

# Connect to DHCP server (comment if not DHCP)
#i could not get this to work, i would get info from the AP, but said a
#some thing was missing
#./dhclient ra0

# Settings for static IP (i.e. not DHCP)

#the IP for your computer / your netmask that goes with your IP /
#no idea what the broadcast is, but i put that number in anyway
./ifconfig ra0 192.168.1.126 netmask 255.255.255.0 broadcast 192.168.1.255
#the IP for my router
./ip route add default via 192.168.1.1 dev ra0
#~~~~~~~~~~~~~~~~~~~~~~~~~~~~

# ./script
#####################################################################


******** I Still need Help *********
I still have no idea where i would put this script to make run on its own every time the computer boots.
******************************

At this point my computer would be able to ping any computer on my LAN and would even connect to and log onto the HTML based management software on the linksys router, but would not connect to the Internet. What i had to do to was go into the main pop up menu>system settings>network

I did not have anything listed here and all I changed was in the “DNS” tab. As the “primary DNS” i put 192.168.1.1 (the IP of my router) and as the “Secondary DNS” i put 151.197.0.38 (it was listed on my router as a DNS and since it is off my local network it probably does nothing, but i put t in anyway). I though I put 192.168.1.1 in here on my previous installation, with no effect, so i put 151.197.0.38 in this time for good measure.

The included directions for installing and using the graphical interface worked fine for me, and i had no problems with that.
 
Old 11-24-2004, 06:17 AM   #5
mlr266
LQ Newbie
 
Registered: Nov 2004
Distribution: RedHat Enterprise WS
Posts: 6

Original Poster
Rep: Reputation: 0
reboot

By the way after rebooting i have to go into the /usr/src/rt2400-1.2.1/Module directory and use the “make” command again. Then load my script again from the /sbin directory

Not that smooth but it works
 
Old 11-24-2004, 06:34 AM   #6
enemorales
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Ubuntu
Posts: 410

Rep: Reputation: 30
Hi,

I'm not an expert, so it could not work for you, but to make the script to run while booting what I did was, AS ROOT:

1.- Put the script in the /etc/init.d directory (do not forget to give it execution permissions with

Code:
chmod +x <script>
2.- Run

Code:
ksysv
to say the system in which run-level you want the script to run (just drag and drop it from the list on the left).

Good luck...
 
Old 11-24-2004, 06:48 AM   #7
enemorales
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Ubuntu
Posts: 410

Rep: Reputation: 30
Hi,

I'm not an expert, so it could not work for you, but to make the script to run while booting what I did was, AS ROOT:

1.- Put the script in the /etc/init.d directory (do not forget to give it execution permissions with

Code:
chmod +x <script>
2.- Run

Code:
ksysv
to say the system in which run-level you want the script to run (just drag and drop it from the list on the left).

I didn't understand if you got internet or not. Anyway, since Windows is well configured, you should use the same configuration in Linux. Probably you are using DHCP, and in that case you have to uncomment that section in the script, so your rourter will give to your computer a IP number on demand. This, I think is what the line "dhclient ro0" does. (I use other command, called "pump". No idea what is the difference or which is better). On the other hand, if Windows is set to use a fixed IP, using the same should work in Linux...

I hope this could help. Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't connect wifi at home, but can connect everywhere else Javi2 Suse/Novell 1 08-25-2005 07:49 PM
ASUS WiFi@Home, not able to get passed the modprobe..... silverdrgn Linux - Wireless Networking 2 08-15-2005 04:30 PM
Ralink WIFI with Asus@Home WIFI wavemachine Linux - Hardware 0 10-20-2004 04:10 PM
can ping to/from pcs on home network but not connect to internet stumblefingers Linux - Networking 13 04-12-2004 10:34 AM
added second nic to network at home now cannot connect to internet gonus Linux - Networking 12 08-23-2002 10:56 PM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration