LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2003, 10:51 AM   #1
thereof
Member
 
Registered: Jan 2003
Location: Sweden
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
Wierd grub.conf


Can anyone explain to me why this works? Since I'm at work, I don't have my grub.conf avaliable, though it looks something like this..

---------
title linux
root (hd0,0)

title win xp
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1
-----------

shouldn't winxp be accessed by (hd0,0) once I mapped them? Or, stupid me.. perhaps it should be only one map-line? I haven't found any understandable reading on Grub. My english isn't behaving like I want it to.
 
Old 02-19-2003, 11:19 AM   #2
Palin
Member
 
Registered: Feb 2003
Location: A Meatlocker, well feels like one
Distribution: Gentoo
Posts: 292

Rep: Reputation: 30
could you explain your partion setup? is windows on a different drive?
 
Old 02-19-2003, 11:19 AM   #3
atko
Member
 
Registered: Feb 2003
Location: UK
Distribution: Currently Fedora Core 3
Posts: 136

Rep: Reputation: 15
It seems you have installed Grub in the master boot record (MBR). Grub starts and requests your input - i.e do you want to boot to XP or Linux. Grub is also set to a default and therefore if you have not selected your preferred o/s within 30 seconds it will load the default. You do not say what distro you are runnign but if you have the Commercial version of Redhat 8 you will have the documentation on cd. In that documentation there is a detailed chapter on Grub. It should also be available on the redhat network if you want further info.
 
Old 02-19-2003, 01:28 PM   #4
thereof
Member
 
Registered: Jan 2003
Location: Sweden
Distribution: Slackware
Posts: 54

Original Poster
Rep: Reputation: 15
I run RH8 on a scsi-drive raid (/dev/ida/c0d0) and WinXp on an ide (/dev/hdg). Grub is installed in MBR on the scsi-drive and the scsi-drive is set to boot first. The setup is working fine, I'm just curious to know why

It's that map-ing stuff that I don't understand.

Last edited by thereof; 02-19-2003 at 01:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
create lilo.conf or grub.conf through commands newpenguin Linux - Software 1 11-28-2003 09:22 PM
lilo.conf and grub.conf no read access shanenin Linux - Software 1 10-02-2003 04:53 PM
Wierd PAM limits.conf behavior Kostko Linux - Software 0 08-26-2003 06:55 AM
Installation help - Wierd thing with my grub ... I think kko88 Slackware 11 05-29-2003 06:09 PM
Wierd grub question log Linux - General 4 01-10-2003 07:07 PM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration