LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-18-2004, 02:33 PM   #1
lailoken
LQ Newbie
 
Registered: Apr 2004
Location: tel aviv
Distribution: redhat 9
Posts: 10

Rep: Reputation: 0
Arrow why won't my fat32 partitions show up in fstab


why won't my fat32 partitions show up in fstab and how do I add them. I am running redhat 9 in dual boot (boot magic 8) with winxp and none of my fat32 partitions show up in fstab or in the disk manager.
Any one???
 
Old 04-18-2004, 02:40 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
You have to add them to your fstab file. It doesn't do it for you..
Should look something like this, where XX is the location of the partition, etc:
Code:
/dev/hdXX    /mnt/windows    vfat     defaults    0 0

Last edited by trickykid; 04-18-2004 at 02:41 PM.
 
Old 04-18-2004, 02:51 PM   #3
lailoken
LQ Newbie
 
Registered: Apr 2004
Location: tel aviv
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
I din't mind the work but...

In previous distros that I used (suse 6.4) I could edit fstab witha setup tool. It lost my mount points all the time (probably wasn't auto) but could be done . Do I gotta do it by hand this time?
 
Old 04-18-2004, 03:04 PM   #4
hus
Member
 
Registered: Dec 2003
Location: Bangkok- Thailand
Distribution: Mandriva 10.0,Fedora Core 4
Posts: 79

Rep: Reputation: 15
If u use Mandrake it will set up automatically for u.
But it's a good thing to do by yourself I think
in /etc/fstab file I think it 's some info. that is good
enough.

but u have to know where's the windows partition
/dev/hda* (if you install win32 on primary hdd)
/dev/hdb* ("---------------------------secondary hdd)

How to know?
In my way I use "fdisk"
"man fdisk"
 
Old 04-18-2004, 03:15 PM   #5
lailoken
LQ Newbie
 
Registered: Apr 2004
Location: tel aviv
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
do I decide what label to give it or is it important. I actually think I am fine with all the rest of the options but on this silly one I am a bit skittish

hus I have Thai friends here and I want to set up a computer with xp or 2000 thai so they can use it. do you have suggestions??
 
Old 04-18-2004, 03:31 PM   #6
hus
Member
 
Registered: Dec 2003
Location: Bangkok- Thailand
Distribution: Mandriva 10.0,Fedora Core 4
Posts: 79

Rep: Reputation: 15
U must install Windows before linux!!!
****************************
And then use partition magic do allacate space
for you.
then setup linux
I've never use Boot magic.
So I suggest LILO(Linux Loader)
While configuring LILO It's very imaportant!!!
(not just LILO but if u want dual boot as well)
If u want to install XP
Boot loader must install at MBR (It's not fix but good idea)
If u want to install 2000
Boot loader must install at first sector of root partition

******
I think if i were u I 'll install XP!
because if u want windows partition
is the part of Linux. XP can do safer
Because Xp's file format have two choice
1.NTFS
2.FAT32
Use FAT32 if U want to mount win partion in LINUX.
It 's safer and easier.
 
Old 04-18-2004, 03:43 PM   #7
hus
Member
 
Registered: Dec 2003
Location: Bangkok- Thailand
Distribution: Mandriva 10.0,Fedora Core 4
Posts: 79

Rep: Reputation: 15
Sorry if I answer the wrong question!
if u 've a problem with hda*
I suggest U try like this
open /etc/fstab with VI
then append it like this (I hope u understand me)

/dev/hda3 /mnt/c1 vfat defaults 00
/dev/hda4 /mnt/c2 vfat defaults 00
/dev/hda5 /mnt/c3 vfat defaults 00

safe it and then reboot
if u can browse /mnt/c3.Bingo! it's the right part.
if not try the other
It may seem stupid way but works!


Another way I 've never tried

mkdir /mnt/c
mount defaults /dev/hda* /mnt/c
(represent * with integer)

Last edited by hus; 04-18-2004 at 03:44 PM.
 
Old 04-20-2004, 12:00 AM   #8
lailoken
LQ Newbie
 
Registered: Apr 2004
Location: tel aviv
Distribution: redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
thanks
I think I got all the info I need for now
 
Old 04-21-2004, 02:44 PM   #9
hus
Member
 
Registered: Dec 2003
Location: Bangkok- Thailand
Distribution: Mandriva 10.0,Fedora Core 4
Posts: 79

Rep: Reputation: 15
mkdir /mnt/c
mount defaults /dev/hda* /mnt/c
(represent * with integer)

Correction:

mkdir /mnt/c
mount -o defaults /dev/hda* /mnt/c
(represent * with integer)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab, fat32, permissions. isaac_e Slackware 7 02-01-2010 10:13 PM
fstab entries show non-linear partition numbers Caysho Linux - Newbie 2 01-01-2005 09:25 AM
Suse 9.0 - FAT32 no show up ssueri Linux - Newbie 5 04-16-2004 01:10 PM
mounting fat32 in fstab true_atlantis Linux - Newbie 2 01-14-2004 05:46 PM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 03:10 AM


All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration